aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Shout
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-14 15:10:39 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-14 15:10:39 +0000
commit123e52fddad22dcc43b30d930cf1d37d66f155fe (patch)
treeeba931909eb27cf784763cd68ea7a3d342e3f9d0 /audio/p5-Shout
parent978782db68eebc7df1df050a589fb9fdc7453f48 (diff)
downloadports-123e52fddad22dcc43b30d930cf1d37d66f155fe.tar.gz
ports-123e52fddad22dcc43b30d930cf1d37d66f155fe.zip
Notes
Diffstat (limited to 'audio/p5-Shout')
-rw-r--r--audio/p5-Shout/Makefile23
-rw-r--r--audio/p5-Shout/distinfo4
-rw-r--r--audio/p5-Shout/files/patch-aa23
-rw-r--r--audio/p5-Shout/files/patch-ab20
-rw-r--r--audio/p5-Shout/pkg-plist11
5 files changed, 22 insertions, 59 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index 542a24b0a662..2d089369f753 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= Shout
-PORTVERSION= 1.0
+PORTVERSION= 2.0.1
CATEGORIES= audio perl5
-MASTER_SITES= # http://www.icecast.org/files/libshout/
+MASTER_SITES= http://www.icecast.org/files/libshout/
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mat@FreeBSD.org
COMMENT= Perl glue for libshout MP3 streaming source library
-LIB_DEPENDS= shout.2:${PORTSDIR}/audio/libshout
+LIB_DEPENDS= shout.3:${PORTSDIR}/audio/libshout2
PERL_CONFIGURE= yes
MAN3= Shout.3
-pre-configure:
- ${MKDIR} ${WRKSRC}/examples
- ${MV} ${WRKSRC}/example.pl ${WRKSRC}/example2.pl ${WRKSRC}/examples
+DOCSDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+post-patch:
+ @${PERL} -i -pe 's/CCFLAGS/INC/;' ${WRKSRC}/Makefile.PL
+
+post-configure:
+ @${PERL} -i -pe '$$_ .= " ${PTHREAD_LIBS}" if /^LDDLFLAGS/;' ${WRKSRC}/Makefile
post-install:
.ifndef(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
- ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example*.pl ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/audio/p5-Shout/distinfo b/audio/p5-Shout/distinfo
index 6afa1147892d..cb168563ef28 100644
--- a/audio/p5-Shout/distinfo
+++ b/audio/p5-Shout/distinfo
@@ -1,2 +1,2 @@
-MD5 (Shout-1.0.tar.gz) = f5cba6e7a8b6b1462b9c17bdcdf6216a
-SIZE (Shout-1.0.tar.gz) = 8799
+MD5 (Shout-2.0.1.tar.gz) = dcfd725f2411cd5e44ce00648878fc39
+SIZE (Shout-2.0.1.tar.gz) = 8876
diff --git a/audio/p5-Shout/files/patch-aa b/audio/p5-Shout/files/patch-aa
deleted file mode 100644
index a0d33272a532..000000000000
--- a/audio/p5-Shout/files/patch-aa
+++ /dev/null
@@ -1,23 +0,0 @@
---- Makefile.PL.orig Tue Dec 11 11:59:35 2001
-+++ Makefile.PL Tue Dec 11 11:59:41 2001
-@@ -4,8 +4,8 @@
- WriteMakefile(
- 'NAME' => 'Shout',
- 'VERSION_FROM' => 'Shout.pm', # finds $VERSION
-- 'LIBS' => ['-lshout'], # e.g., '-lm'
-+ 'LIBS' => ['-L/usr/local/lib -lshout'], # e.g., '-lm'
- 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
-- 'INC' => '', # e.g., '-I/usr/include/other'
-+ 'INC' => '-I/usr/local/include', # e.g., '-I/usr/include/other'
- 'MYEXTLIB' => ''
- );
---- MANIFEST.orig Tue Dec 11 12:43:44 2001
-+++ MANIFEST Tue Dec 11 12:43:49 2001
-@@ -3,7 +3,5 @@
- Makefile.PL
- Shout.pm
- Shout.xs
--example.pl
--example2.pl
- test.pl
- typemap
diff --git a/audio/p5-Shout/files/patch-ab b/audio/p5-Shout/files/patch-ab
deleted file mode 100644
index 3b36ab4866a4..000000000000
--- a/audio/p5-Shout/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Shout.xs.orig Tue Dec 11 12:36:56 2001
-+++ Shout.xs Tue Dec 11 12:37:20 2001
-@@ -200,13 +200,15 @@
- CODE:
- self->aim = strdup(str);
-
--void shout_set_icq(self, str)
-+void
-+shout_set_icq(self, str)
- shout_conn_t *self
- char *str
- CODE:
- self->icq = strdup(str);
-
--void shout_set_irc(self, str)
-+void
-+shout_set_irc(self, str)
- shout_conn_t *self
- char *str
- CODE:
diff --git a/audio/p5-Shout/pkg-plist b/audio/p5-Shout/pkg-plist
index 6cd363eec318..f30891024bda 100644
--- a/audio/p5-Shout/pkg-plist
+++ b/audio/p5-Shout/pkg-plist
@@ -3,8 +3,11 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/Shout.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/Shout.so
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout/autosplit.ix
-%%PORTDOCS%%share/examples/p5-Shout/example.pl
-%%PORTDOCS%%share/examples/p5-Shout/example2.pl
-%%PORTDOCS%%@dirrm share/examples/p5-Shout
+%%SITE_PERL%%/%%PERL_ARCH%%/example.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/example2.pl
+%%PORTDOCS%%%%DOCSDIR%%/example.pl
+%%PORTDOCS%%%%DOCSDIR%%/example2.pl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Shout
-@unexec rmdir %D/%%SITE_PERL%%/%%PER_ARCH%%/auto/Shout 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach 2>/dev/null || true