aboutsummaryrefslogtreecommitdiff
path: root/audio/penguinsap
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-18 22:12:49 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-18 22:12:49 +0000
commitc310c992725e4e30c03a89a15f26c40398ba13ca (patch)
treedeb55c26f55cca67a48da47bf87c6baa5adfdb33 /audio/penguinsap
parent1c72a7109e10943a9da5e864e25e8fff26d788a9 (diff)
downloadports-c310c992725e4e30c03a89a15f26c40398ba13ca.tar.gz
ports-c310c992725e4e30c03a89a15f26c40398ba13ca.zip
Notes
Diffstat (limited to 'audio/penguinsap')
-rw-r--r--audio/penguinsap/Makefile49
-rw-r--r--audio/penguinsap/distinfo2
-rw-r--r--audio/penguinsap/pkg-descr7
-rw-r--r--audio/penguinsap/pkg-message3
4 files changed, 61 insertions, 0 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
new file mode 100644
index 000000000000..7264b9a5df61
--- /dev/null
+++ b/audio/penguinsap/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: penguinsap
+# Date created: 16 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= penguinsap
+PORTVERSION= 0.1
+CATEGORIES= audio
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line Atari(TM) .sap player
+
+USE_REINPLACE= yes
+
+SOURCES= sapPokey pokey1 sapCpu sapEngine main pokey0
+CXXFLAGS+= --no-exceptions
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+EXTRAFLAGS= -ffast-math -malign-double -finline-limit-1000000 \
+ -funroll-loops -fstrength-reduce -finline-functions
+.endif
+
+PLIST_FILES= bin/sap
+
+post-patch:
+# gcc 2.95.4 does not like CR/LFs
+ @${FIND} ${WRKSRC} -type f -exec \
+ ${REINPLACE_CMD} -E -e 's| ||' {} \;
+ @${REINPLACE_CMD} -e 's|linux/soundcard\.h|sys/soundcard\.h|' \
+ ${WRKSRC}/main.cpp
+
+do-build:
+.for f in ${SOURCES}
+ ${CXX} ${CXXFLAGS} ${EXTRAFLAGS} -c ${WRKSRC}/${f}.cpp \
+ -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} ${EXTRAFLAGS} ${SOURCES:C/(.*)/${WRKSRC}\/\1.o/} \
+ -o ${WRKSRC}/sap
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sap ${PREFIX}/bin
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/penguinsap/distinfo b/audio/penguinsap/distinfo
new file mode 100644
index 000000000000..cf92ff6904c2
--- /dev/null
+++ b/audio/penguinsap/distinfo
@@ -0,0 +1,2 @@
+MD5 (penguinsap-0.1.tar.gz) = 800f818d3ef1b93346b07a5861bb1e17
+SIZE (penguinsap-0.1.tar.gz) = 44057
diff --git a/audio/penguinsap/pkg-descr b/audio/penguinsap/pkg-descr
new file mode 100644
index 000000000000..7afeea6c0d0f
--- /dev/null
+++ b/audio/penguinsap/pkg-descr
@@ -0,0 +1,7 @@
+A simple command line player for playing 8bit Atari(TM) .sap (Slight Atari
+Player) audio files.
+
+WWW: http://asma.atari.org/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/penguinsap/pkg-message b/audio/penguinsap/pkg-message
new file mode 100644
index 000000000000..2b197e25ebaf
--- /dev/null
+++ b/audio/penguinsap/pkg-message
@@ -0,0 +1,3 @@
+===============================================================================
+A huge .sap file collection can be found at: http://asma.atari.org/
+===============================================================================