aboutsummaryrefslogtreecommitdiff
path: root/audio/pianobar
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2012-05-14 23:43:18 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2012-05-14 23:43:18 +0000
commit9e09a439b9f7caa8850db50ad72bd114f6dbdf93 (patch)
treebf367d0ed40ad61d713f134915150bb73a10b634 /audio/pianobar
parent3ea1cde66b4daa66d4afcec23efb1a27573de0c6 (diff)
Update to 2012.05.06
PR: ports/167889 Submitted by: John Hixson Sponsored by: iXsystems
Notes
Notes: svn path=/head/; revision=296628
Diffstat (limited to 'audio/pianobar')
-rw-r--r--audio/pianobar/Makefile6
-rw-r--r--audio/pianobar/distinfo4
-rw-r--r--audio/pianobar/files/patch-crypt.c10
-rw-r--r--audio/pianobar/files/patch-crypt.h10
-rw-r--r--audio/pianobar/files/patch-main.c36
-rw-r--r--audio/pianobar/files/patch-piano.c19
-rw-r--r--audio/pianobar/files/patch-piano.h10
7 files changed, 36 insertions, 59 deletions
diff --git a/audio/pianobar/Makefile b/audio/pianobar/Makefile
index 716164608ee6..ef3866e8da2d 100644
--- a/audio/pianobar/Makefile
+++ b/audio/pianobar/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pianobar
-PORTVERSION= 2012.04.24
+PORTVERSION= 2012.05.06
CATEGORIES= audio
MASTER_SITES= http://6xq.net/projects/${PORTNAME}/
@@ -16,7 +16,9 @@ COMMENT= Command line Pandora player
LIB_DEPENDS= ao:${PORTSDIR}/audio/libao \
faad:${PORTSDIR}/audio/faad \
mad:${PORTSDIR}/audio/libmad \
- gnutls.47:${PORTSDIR}/security/gnutls
+ gnutls.47:${PORTSDIR}/security/gnutls \
+ json.0:${PORTSDIR}/devel/json-c \
+ gcrypt:${PORTSDIR}/security/libgcrypt
LICENSE= MIT
diff --git a/audio/pianobar/distinfo b/audio/pianobar/distinfo
index e2fc985774e8..32044e615d41 100644
--- a/audio/pianobar/distinfo
+++ b/audio/pianobar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pianobar-2012.04.24.tar.bz2) = 1286005b14ef58ea5b7baece054e772761e6351fdeceadd3a69e0a7c8b9bf28e
-SIZE (pianobar-2012.04.24.tar.bz2) = 69538
+SHA256 (pianobar-2012.05.06.tar.bz2) = b143882ca50303d560f49567d1a508ca4b48208db4eb8aa67f369fcaae708d7a
+SIZE (pianobar-2012.05.06.tar.bz2) = 47052
diff --git a/audio/pianobar/files/patch-crypt.c b/audio/pianobar/files/patch-crypt.c
new file mode 100644
index 000000000000..4fc444a1dac6
--- /dev/null
+++ b/audio/pianobar/files/patch-crypt.c
@@ -0,0 +1,10 @@
+--- src/libpiano/crypt.c.orig 2012-05-06 07:33:54.000000000 -0700
++++ src/libpiano/crypt.c 2012-05-12 19:42:13.000000000 -0700
+@@ -23,6 +23,7 @@
+
+ #include <string.h>
+ #include <assert.h>
++#define _GCRYPT_IN_LIBGCRYPT
+ #include <gcrypt.h>
+ #include <stdio.h>
+ #include <stdlib.h>
diff --git a/audio/pianobar/files/patch-crypt.h b/audio/pianobar/files/patch-crypt.h
new file mode 100644
index 000000000000..a93b21e53b69
--- /dev/null
+++ b/audio/pianobar/files/patch-crypt.h
@@ -0,0 +1,10 @@
+--- src/libpiano/crypt.h.orig 2012-05-06 07:33:54.000000000 -0700
++++ src/libpiano/crypt.h 2012-05-12 19:42:29.000000000 -0700
+@@ -24,6 +24,7 @@
+ #ifndef _CRYPH_H
+ #define _CRYPT_H
+
++#define _GCRYPT_IN_LIBGCRYPT
+ #include <gcrypt.h>
+
+ char *PianoDecryptString (gcry_cipher_hd_t, const char * const,
diff --git a/audio/pianobar/files/patch-main.c b/audio/pianobar/files/patch-main.c
index 021da4f02a0c..e69de29bb2d1 100644
--- a/audio/pianobar/files/patch-main.c
+++ b/audio/pianobar/files/patch-main.c
@@ -1,36 +0,0 @@
---- src/main.c.orig 2012-04-24 11:09:20.000000000 -0700
-+++ src/main.c 2012-04-26 16:07:03.000000000 -0700
-@@ -77,10 +77,32 @@
- WaitressReturn_t wRet;
- PianoRequestDataLogin_t reqData;
- bool ret;
-+ WaitressHandle_t waithSync;
-+ char *syncTime;
-+ unsigned long int syncTimeInt;
-+
-+ /* skip sync step by fetching time from somewhere else */
-+ WaitressInit (&waithSync);
-+ WaitressSetUrl (&waithSync, "http://ridetheclown.com/s2/synctime.php");
-+ if (app->settings.proxy != NULL && strlen (app->settings.proxy) > 0) {
-+ WaitressSetProxy (&waithSync, app->settings.proxy);
-+ }
-+ wRet = WaitressFetchBuf (&waithSync, &syncTime);
-+ WaitressFree (&waithSync);
-+ if (wRet != WAITRESS_RET_OK) {
-+ BarUiMsg (&app->settings, MSG_ERR, "Unable to sync: %s\n",
-+ WaitressErrorToStr (wRet));
-+ return false;
-+ }
-+
-+ syncTimeInt = strtoul (syncTime, NULL, 0);
-+ app->ph.timeOffset = time (NULL) - syncTimeInt;
-+ free (syncTime);
-+
-
- reqData.user = app->settings.username;
- reqData.password = app->settings.password;
-- reqData.step = 0;
-+ reqData.step = 1;
-
- BarUiMsg (&app->settings, MSG_INFO, "Login... ");
- ret = BarUiPianoCall (app, PIANO_REQUEST_LOGIN, &reqData, &pRet, &wRet);
diff --git a/audio/pianobar/files/patch-piano.c b/audio/pianobar/files/patch-piano.c
index aca1fc7d3754..e69de29bb2d1 100644
--- a/audio/pianobar/files/patch-piano.c
+++ b/audio/pianobar/files/patch-piano.c
@@ -1,19 +0,0 @@
---- src/libpiano/piano.c.orig 2012-04-24 11:09:20.000000000 -0700
-+++ src/libpiano/piano.c 2012-04-26 16:05:39.000000000 -0700
-@@ -42,7 +42,7 @@
- #include "crypt.h"
- #include "config.h"
-
--#define PIANO_PROTOCOL_VERSION "33"
-+#define PIANO_PROTOCOL_VERSION "34"
- #define PIANO_RPC_HOST "www.pandora.com"
- #define PIANO_RPC_PORT "80"
- #define PIANO_RPC_PATH "/radio/xmlrpc/v" PIANO_PROTOCOL_VERSION "?"
-@@ -272,6 +272,7 @@
- "<?xml version=\"1.0\"?><methodCall>"
- "<methodName>listener.authenticateListener</methodName>"
- "<params><param><value><int>%lu</int></value></param>"
-+ "<param><value><string></string></value></param>"
- /* user */
- "<param><value><string>%s</string></value></param>"
- /* password */ \ No newline at end of file
diff --git a/audio/pianobar/files/patch-piano.h b/audio/pianobar/files/patch-piano.h
new file mode 100644
index 000000000000..260526d1a970
--- /dev/null
+++ b/audio/pianobar/files/patch-piano.h
@@ -0,0 +1,10 @@
+--- src/libpiano/piano.h.orig 2012-05-06 07:33:54.000000000 -0700
++++ src/libpiano/piano.h 2012-05-12 19:42:41.000000000 -0700
+@@ -25,6 +25,7 @@
+ #define _PIANO_H
+
+ #include <stdbool.h>
++#define _GCRYPT_IN_LIBGCRYPT
+ #include <gcrypt.h>
+
+ /* this is our public API; don't expect this api to be stable as long as