aboutsummaryrefslogtreecommitdiff
path: root/audio/picard/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-08-16 16:01:51 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-08-16 16:01:51 +0000
commitf322351990a8f9050ab3bd99b18ad0aeedc163c9 (patch)
tree51d90fb532090d286dbcd1af3e956cae158ee3c4 /audio/picard/Makefile
parent715cf897de5b31108cc94ee7c48dded2824204b0 (diff)
downloadports-f322351990a8f9050ab3bd99b18ad0aeedc163c9.tar.gz
ports-f322351990a8f9050ab3bd99b18ad0aeedc163c9.zip
Notes
Diffstat (limited to 'audio/picard/Makefile')
-rw-r--r--audio/picard/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/audio/picard/Makefile b/audio/picard/Makefile
index 2595b1bc1096..1a31bb5e28b0 100644
--- a/audio/picard/Makefile
+++ b/audio/picard/Makefile
@@ -3,6 +3,7 @@
PORTNAME= picard
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= http://ftp.musicbrainz.org/pub/musicbrainz/picard/ \
ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/ \
@@ -12,6 +13,7 @@ MAINTAINER= jhale@FreeBSD.org
COMMENT= Next generation MusicBrainz Tagger
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
LIB_DEPENDS= libdiscid.so:${PORTSDIR}/audio/libdiscid
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=0:${PORTSDIR}/audio/py-mutagen \
@@ -20,28 +22,20 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=0:${PORTSDIR}/audio/py-mutagen \
${PYTHON_PKGNAMEPREFIX}qt4-network>=0:${PORTSDIR}/net/py-qt4-network \
${PYTHON_PKGNAMEPREFIX}qt4-xml>=0:${PORTSDIR}/textproc/py-qt4-xml
-USES= gettext
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
+USES= gettext python:2 desktop-file-utils
+PYTHON_FEATURES=distutils
INSTALLS_ICONS= yes
OPTIONS_DEFINE= ACOUSTID REPLAYGAIN
-ACOUSTID_DESC= AcoustID audio fingerprinting support
-REPLAYGAIN_DESC=ReplayGain audio normalization support
+ACOUSTID_DESC= AcoustID audio fingerprinting support
+ACOUSTID_RUN_DEPENDS= fpcalc:${PORTSDIR}/audio/chromaprint
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MACOUSTID}
-RUN_DEPENDS+= fpcalc:${PORTSDIR}/audio/chromaprint
-.endif
-
-.if ${PORT_OPTIONS:MREPLAYGAIN}
-RUN_DEPENDS+= metaflac:${PORTSDIR}/audio/flac \
- mp3gain:${PORTSDIR}/audio/mp3gain \
- vorbisgain:${PORTSDIR}/audio/vorbisgain \
- wvgain:${PORTSDIR}/audio/wavpack
-.endif
+REPLAYGAIN_DESC= ReplayGain audio normalization support
+REPLAYGAIN_RUN_DEPENDS= metaflac:${PORTSDIR}/audio/flac \
+ mp3gain:${PORTSDIR}/audio/mp3gain \
+ vorbisgain:${PORTSDIR}/audio/vorbisgain \
+ wvgain:${PORTSDIR}/audio/wavpack
post-patch:
@${REINPLACE_CMD} -e "s|'picard.plugins',|'picard.plugins', 'picard.plugins.lastfm', 'picard.plugins.lastfmplus', 'picard.plugins.replaygain',|" \
@@ -49,4 +43,7 @@ post-patch:
${WRKSRC}/setup.py
@${CP} -R ${WRKSRC}/contrib/plugins/ ${WRKSRC}/picard/plugins
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/picard/util/astrcmp.so
+
.include <bsd.port.mk>