aboutsummaryrefslogtreecommitdiff
path: root/audio/playgsf/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-28 12:15:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-28 12:15:12 +0000
commit853ffe1b2b3b95d78a2414c012e39baf2d5f3760 (patch)
tree1fabb518e5e1f66333427fb950dc6ba5beb1791a /audio/playgsf/Makefile
parent2c98a82bf1d9f400e14d7df95254548d7c977391 (diff)
Notes
Diffstat (limited to 'audio/playgsf/Makefile')
-rw-r--r--audio/playgsf/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
new file mode 100644
index 000000000000..0974a4564bc9
--- /dev/null
+++ b/audio/playgsf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: playgsf
+# Date created: 10 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= playgsf
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= http://projects.raphnet.net/playgsf/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command line player for gsf audio files
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+USE_GCC= 3.4+
+
+# avoid a "of memory error" gcc bug
+CFLAGS+= -O0
+
+PLIST_FILES= bin/playgsf
+
+ONLY_FOR_ARCHS= i386 # contains x86 assembler
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(CFLAGS="\)\(-DLINUX\)|\1${CFLAGS} \2|' \
+ ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>