aboutsummaryrefslogtreecommitdiff
path: root/audio/playgsf
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-18 13:26:30 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-05-18 13:26:30 +0000
commit9bdd4f12738ac102def43e60cc49dbf4414aba71 (patch)
treee9e2a73ecf40cf894373c25a88182f19d61d12a0 /audio/playgsf
parent4c2ffaec01f22049dce137975317126bb6d7a391 (diff)
downloadports-9bdd4f12738ac102def43e60cc49dbf4414aba71.tar.gz
ports-9bdd4f12738ac102def43e60cc49dbf4414aba71.zip
Notes
Diffstat (limited to 'audio/playgsf')
-rw-r--r--audio/playgsf/Makefile26
-rw-r--r--audio/playgsf/distinfo6
2 files changed, 25 insertions, 7 deletions
diff --git a/audio/playgsf/Makefile b/audio/playgsf/Makefile
index 089deecf72e7..6db3181d0128 100644
--- a/audio/playgsf/Makefile
+++ b/audio/playgsf/Makefile
@@ -6,28 +6,46 @@
#
PORTNAME= playgsf
-PORTVERSION= 0.6
+PORTVERSION= 0.7.1
CATEGORIES= audio
-MASTER_SITES= http://projects.raphnet.net/playgsf/
+MASTER_SITES= http://projects.raphnet.net/playgsf/ \
+ http://critical.ch/distfiles/
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A command line player for gsf audio files
+LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
-# avoid a "of memory error" gcc bug
+# disable optimization flags to avoid a possible bug in gcc
+# (gcc tries to allocate memory in an endless loop)
CFLAGS+= -O0
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_ENV+= LIBS="${LDFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" LDFLAGS="${LDFLAGS}" LIBS="${LDFLAGS}" CFLAGS="${CFLAGS}"
+
PLIST_FILES= bin/playgsf
-ONLY_FOR_ARCHS= i386 # contains x86 assembler
+# contains x86 assembler
+ONLY_FOR_ARCHS= i386
post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|\(@LDFLAGS@\)|\1 ${LDFLAGS}|' \
+ -e 's|\([[:space:]]*\).*configure.*|\1@true|' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|^\(CFLAGS="\)\(-DLINUX\)|\1${CFLAGS} \2|' \
${WRKSRC}/configure
+post-configure:
+ @(cd ${WRKSRC}/libresample-0.1.3; ./configure ${CONFIGURE_ENV})
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/audio/playgsf/distinfo b/audio/playgsf/distinfo
index 837e57e349c2..1d154a095885 100644
--- a/audio/playgsf/distinfo
+++ b/audio/playgsf/distinfo
@@ -1,3 +1,3 @@
-MD5 (playgsf-0.6.tar.gz) = 019f052657896e0fed6939ca1a3527e6
-SHA256 (playgsf-0.6.tar.gz) = d1553e22b0a1066a6b069de6658449c4a0095434cfb432fabdcb6acf00db24ce
-SIZE (playgsf-0.6.tar.gz) = 243894
+MD5 (playgsf-0.7.1.tar.gz) = b68de49a511c3a9bfd051ebf3325b1ef
+SHA256 (playgsf-0.7.1.tar.gz) = 1ba45e733ca29fdbf36ee7d307391ae6e0a134deb9f1f2576b44dc8f4ac3ebcd
+SIZE (playgsf-0.7.1.tar.gz) = 270364