aboutsummaryrefslogtreecommitdiff
path: root/audio/playmidi
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-01-18 11:34:02 +0000
committerChris Rees <crees@FreeBSD.org>2013-01-18 11:34:02 +0000
commit193b93c8d9ab6242d4c80f4dc8844d42f640903a (patch)
tree9d0c6459cf8d86fc44f684d7d21f3437c05c78a3 /audio/playmidi
parent65e8e3d6a747d8dbe336f603eb02ce7b7a44c899 (diff)
downloadports-193b93c8d9ab6242d4c80f4dc8844d42f640903a.tar.gz
ports-193b93c8d9ab6242d4c80f4dc8844d42f640903a.zip
Notes
Diffstat (limited to 'audio/playmidi')
-rw-r--r--audio/playmidi/Makefile37
-rw-r--r--audio/playmidi/files/patch-Configure (renamed from audio/playmidi/files/patch-ac)0
-rw-r--r--audio/playmidi/files/patch-Makefile (renamed from audio/playmidi/files/patch-ab)0
-rw-r--r--audio/playmidi/files/patch-playmidi_h-dist (renamed from audio/playmidi/files/patch-ad)0
4 files changed, 29 insertions, 8 deletions
diff --git a/audio/playmidi/Makefile b/audio/playmidi/Makefile
index b612c1c2a247..6fa773bc9cf8 100644
--- a/audio/playmidi/Makefile
+++ b/audio/playmidi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: playmidi
-# Date created: 27 Feb 1995
-# Whom: ache
-#
+# Created by: ache
# $FreeBSD$
-#
PORTNAME= playmidi
PORTVERSION= 2.5
@@ -16,12 +12,37 @@ COMMENT= MIDI player
WRKSRC= ${WRKDIR}/${PORTNAME}-2.4
-ONLY_FOR_ARCHS= i386
-IS_INTERACTIVE= YES # asks what devices you want to support
-HAS_CONFIGURE= YES
+ONLY_FOR_ARCHS= i386 amd64
+HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ENV= PREFIX=${PREFIX}
INSTALL_TARGET= install.lame install.man
MAN1= playmidi.1
+OPTIONS_SINGLE= DEFAULTDEVICE
+OPTIONS_SINGLE_DEFAULTDEVICE= EXTERNAL YAMAHA2 YAMAHA4 GRAVISULTRA SBAWE32
+
+OPTIONS_DEFAULT= EXTERNAL
+
+EXTERNAL_DESC= External midi synth, Ensoniq Soundscape, TB Maui, waveblaster cards
+YAMAHA2_DESC= Yamaha 2-op FM
+YAMAHA4_DESC= Yamaha 4-op FM
+GRAVISULTRA_DESC= Gravis Ultrasound
+SBAWE32_DESC= SB AWE32 Synth
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${REINPLACE_CMD} '/^read/d' ${WRKSRC}/Configure
+
+.if ${PORT_OPTIONS:MYAMAHA2}
+CONFIGURE_ENV+= ans1=2
+.elif ${PORT_OPTIONS:MYAMAHA4}
+CONFIGURE_ENV+= ans1=3
+.elif ${PORT_OPTIONS:MGRAVISULTRA}
+CONFIGURE_ENV+= ans1=4
+.elif ${PORT_OPTIONS:MSBAWE32}
+CONFIGURE_ENV+= ans1=5
+.endif # EXTERNAL is default anyway; just use other defaults
+
.include <bsd.port.mk>
diff --git a/audio/playmidi/files/patch-ac b/audio/playmidi/files/patch-Configure
index 4e764cf74af6..4e764cf74af6 100644
--- a/audio/playmidi/files/patch-ac
+++ b/audio/playmidi/files/patch-Configure
diff --git a/audio/playmidi/files/patch-ab b/audio/playmidi/files/patch-Makefile
index 15bc07ae7d2a..15bc07ae7d2a 100644
--- a/audio/playmidi/files/patch-ab
+++ b/audio/playmidi/files/patch-Makefile
diff --git a/audio/playmidi/files/patch-ad b/audio/playmidi/files/patch-playmidi_h-dist
index 53ef556a7e4b..53ef556a7e4b 100644
--- a/audio/playmidi/files/patch-ad
+++ b/audio/playmidi/files/patch-playmidi_h-dist