aboutsummaryrefslogtreecommitdiff
path: root/audio/pocketsphinx/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-22 20:37:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-22 20:37:29 +0000
commitce5c5cae595bb150043ce59ccc9f7c454e89b89c (patch)
tree4e4a13b051c1555807f75ac3c021500522913926 /audio/pocketsphinx/Makefile
parentd58a3f6d331792ef970c227cbf50942300cb3301 (diff)
downloadports-ce5c5cae595bb150043ce59ccc9f7c454e89b89c.tar.gz
ports-ce5c5cae595bb150043ce59ccc9f7c454e89b89c.zip
Notes
Diffstat (limited to 'audio/pocketsphinx/Makefile')
-rw-r--r--audio/pocketsphinx/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/pocketsphinx/Makefile b/audio/pocketsphinx/Makefile
new file mode 100644
index 000000000000..635dd8446632
--- /dev/null
+++ b/audio/pocketsphinx/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pocketsphinx
+# Date created: 3 Jan 2008
+# Whom: Richard Neese
+#
+# $FreeBSD$
+#
+
+PORTNAME= pocketsphinx
+PORTVERSION= 0.4.1
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cmusphinx
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= Speech recognition system
+
+LIB_DEPENDS= sphinxfe.0:${PORTSDIR}/audio/sphinxbase
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/sphinxbase" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAKE_ENV= MKDIR="${MKDIR}" \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>