aboutsummaryrefslogtreecommitdiff
path: root/audio/polyphone
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:32:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-11 08:32:25 +0000
commit5072637d8dafc4ed7504b5593fc32e9255e89b37 (patch)
tree8e74546605f3dcde1f871192f1ae3f64a2d69731 /audio/polyphone
parentff25e7794c87e60691e14800cf67b19977a81eb8 (diff)
downloadports-5072637d8dafc4ed7504b5593fc32e9255e89b37.tar.gz
ports-5072637d8dafc4ed7504b5593fc32e9255e89b37.zip
Notes
Diffstat (limited to 'audio/polyphone')
-rw-r--r--audio/polyphone/Makefile50
-rw-r--r--audio/polyphone/distinfo3
-rw-r--r--audio/polyphone/files/patch-sfark_sfarkextractor1.cpp11
-rw-r--r--audio/polyphone/files/polyphone.desktop14
-rw-r--r--audio/polyphone/files/polyphone.xml20
-rw-r--r--audio/polyphone/pkg-descr6
6 files changed, 104 insertions, 0 deletions
diff --git a/audio/polyphone/Makefile b/audio/polyphone/Makefile
new file mode 100644
index 000000000000..79e4231867d4
--- /dev/null
+++ b/audio/polyphone/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= polyphone
+DISTVERSION= 1.8
+DISTVERSIONSUFFIX= -src
+CATEGORIES= audio
+MASTER_SITES= http://polyphone-soundfonts.com/en/download/file/76-polyphone-1-8-src-zip/latest/download?ae95d968569b61bc77f7b8559a14db4d=1/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Graphical user interface for editing soundfont (sf2 and sfz) files
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libjack.so:audio/jack \
+ libogg.so:audio/libogg \
+ libportaudio.so:audio/portaudio \
+ librtmidi.so:audio/rtmidi \
+ libstk-4.6.0.so:audio/stk \
+ libvorbisfile.so:audio/libvorbis
+
+USES= compiler:c++11-lang desktop-file-utils pkgconfig qmake:outsource shared-mime-info zip
+USE_GL= gl
+USE_QT5= core concurrent gui network printsupport svg widgets buildtools_build qmake_build
+USE_CXXSTD= c++11
+QMAKE_ARGS= DEFINES=USE_LOCAL_QCUSTOMPLOT
+CXXFLAGS+= -D__UNIX_JACK__
+
+WRKSRC= ${WRKDIR}/trunk
+
+PLIST_FILES= bin/polyphone \
+ share/applications/polyphone.desktop \
+ share/mime/packages/polyphone.xml \
+ share/pixmaps/polyphone.png
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s| -mfpmath=387||g; \
+ s|/usr/include|${LOCALBASE}/include|g; \
+ s| alsa||g; \
+ s|ExtraCompiler.commands = $$$${QMAKE_CXX} -fPIC|ExtraCompiler.commands = $$$${QMAKE_CXX} $$(CXXFLAGS) -fPIC|g' \
+ ${WRKSRC}/polyphone.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/RELEASE/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/ressources/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/mime/packages
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.xml ${STAGEDIR}${PREFIX}/share/mime/packages
+
+.include <bsd.port.mk>
diff --git a/audio/polyphone/distinfo b/audio/polyphone/distinfo
new file mode 100644
index 000000000000..d06974b7c3a3
--- /dev/null
+++ b/audio/polyphone/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509636821
+SHA256 (polyphone-1.8-src.zip) = 2b0ba2887646208ae9953a336adfebe460133cd403e76f7fe795d3071827dfdd
+SIZE (polyphone-1.8-src.zip) = 3699516
diff --git a/audio/polyphone/files/patch-sfark_sfarkextractor1.cpp b/audio/polyphone/files/patch-sfark_sfarkextractor1.cpp
new file mode 100644
index 000000000000..aad888b51328
--- /dev/null
+++ b/audio/polyphone/files/patch-sfark_sfarkextractor1.cpp
@@ -0,0 +1,11 @@
+--- sfark/sfarkextractor1.cpp.orig 2017-08-10 19:26:54 UTC
++++ sfark/sfarkextractor1.cpp
+@@ -30,6 +30,8 @@
+ #include "zlib.h"
+ #include "stdint.h"
+
++#include <unistd.h>
++
+ static const char * SfArkId = ".sfArk";
+
+ SfArkExtractor1::SfArkExtractor1(const char * fileName) : AbstractExtractor(),
diff --git a/audio/polyphone/files/polyphone.desktop b/audio/polyphone/files/polyphone.desktop
new file mode 100644
index 000000000000..4f58fcb44375
--- /dev/null
+++ b/audio/polyphone/files/polyphone.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Polyphone
+Name[fr]=Polyphone
+Comment=soundfont editor
+Comment[fr]=éditeur de soundfonts
+TryExec=polyphone
+Exec=polyphone %F
+Icon=polyphone
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Audio;Midi;Music
+Keywords=sf2;sfz;sfArk;soundfonts;editor;instrument
+MimeType=audio/x-soundfont;
diff --git a/audio/polyphone/files/polyphone.xml b/audio/polyphone/files/polyphone.xml
new file mode 100644
index 000000000000..4f3a1dcf8aa9
--- /dev/null
+++ b/audio/polyphone/files/polyphone.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0"?>
+<mime-info xmlns='http://www.freedesktop.org/standards/shared-mime-info'>
+ <mime-type type="audio/x-soundfont">
+ <comment>SoundFont sf2</comment>
+ <magic priority="50">
+ <match type="string" offset="0" value="RIFF">
+ <match type="string" offset="8" value="sfbk"/>
+ </match>
+ </magic>
+ <glob pattern="*.sf2"/>
+ </mime-type>
+ <mime-type type="audio/x-soundfont">
+ <comment>SoundFont sfz</comment>
+ <glob pattern="*.sfz"/>
+ </mime-type>
+ <mime-type type="audio/x-soundfont">
+ <comment>SoundFont archive sfArk</comment>
+ <glob pattern="*.sfArk"/>
+ </mime-type>
+</mime-info>
diff --git a/audio/polyphone/pkg-descr b/audio/polyphone/pkg-descr
new file mode 100644
index 000000000000..b2b50216ccb2
--- /dev/null
+++ b/audio/polyphone/pkg-descr
@@ -0,0 +1,6 @@
+Polyphone is a free software for editing soundfonts in format sf2. These
+files contain a multitude of audio samples put together and configured so
+as to form musical instruments that can be used by synthesizers such as
+fluidsynth and played using a MIDI keyboard.
+
+WWW: http://www.polyphone-soundfonts.com/