aboutsummaryrefslogtreecommitdiff
path: root/audio/pulseaudio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-26 21:29:53 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-07-26 21:29:53 +0000
commit166c13a9767bdb3261dfb6335ef78699cb7c2f15 (patch)
tree2c4ba0314b1a6a4ac0d92df9f62a92712e75208b /audio/pulseaudio
parent439b679763b06bbc6318f74adca4bebbacc22a16 (diff)
Notes
Diffstat (limited to 'audio/pulseaudio')
-rw-r--r--audio/pulseaudio/Makefile12
-rw-r--r--audio/pulseaudio/distinfo6
-rw-r--r--audio/pulseaudio/files/patch-configure24
-rw-r--r--audio/pulseaudio/files/patch-src_daemon_caps.h12
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_core-util.c30
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_proplist-util.c11
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_protocol-native.c18
-rw-r--r--audio/pulseaudio/files/patch-src_tests_rtstutter.c18
-rw-r--r--audio/pulseaudio/pkg-plist11
9 files changed, 98 insertions, 44 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 09cc41a74b7f..181f34583b53 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= pulseaudio
-PORTVERSION= 0.9.10
-PORTREVISION= 2
+PORTVERSION= 0.9.11
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
@@ -16,7 +15,9 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Sound server for UNIX
LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
- oil-0.3.0:${PORTSDIR}/devel/liboil
+ oil-0.3.0:${PORTSDIR}/devel/liboil \
+ speexdsp.1:${PORTSDIR}/audio/speex \
+ dbus-1.3:${PORTSDIR}/devel/dbus
USE_GNOME= gnometarget gnomehack glib20 ltverhack
USE_XORG= x11 sm
@@ -67,7 +68,8 @@ PLIST_SUB+= AVAHI="@comment "
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
PLIST_SUB+= HAL=""
.else
-CONFIGURE_ARGS+=--disable-hal
+CONFIGURE_ARGS+=--disable-hal \
+ --disable-polkit
PLIST_SUB+= HAL="@comment "
.endif
@@ -80,8 +82,6 @@ PLIST_SUB+= GCONF="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/share/PolicyKit/policy/|${PREFIX}/share/PolicyKit/policy/|' \
- ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/daemon/default.pa.in
.if ${OSVERSION} < 700042
diff --git a/audio/pulseaudio/distinfo b/audio/pulseaudio/distinfo
index 3e593a3491da..3f17dc81c7ef 100644
--- a/audio/pulseaudio/distinfo
+++ b/audio/pulseaudio/distinfo
@@ -1,3 +1,3 @@
-MD5 (pulseaudio-0.9.10.tar.gz) = 9187ac1b302b9ab45f355242f453882e
-SHA256 (pulseaudio-0.9.10.tar.gz) = 1ae8b587759b33ad954e717728fab6df58bd28088d0ac8faf22e90253b774975
-SIZE (pulseaudio-0.9.10.tar.gz) = 1081546
+MD5 (pulseaudio-0.9.11.tar.gz) = fa121f8e5dd4b98d65096de1b6c84021
+SHA256 (pulseaudio-0.9.11.tar.gz) = 6cc4aff778275f087cfbd65d2040b1587cafc588749499a452eb496329505ab0
+SIZE (pulseaudio-0.9.11.tar.gz) = 1166430
diff --git a/audio/pulseaudio/files/patch-configure b/audio/pulseaudio/files/patch-configure
index ffac463e64cc..5130810053df 100644
--- a/audio/pulseaudio/files/patch-configure
+++ b/audio/pulseaudio/files/patch-configure
@@ -1,27 +1,27 @@
---- configure.orig 2008-03-31 07:31:37.381987526 -0400
-+++ configure 2008-03-31 07:31:37.771922603 -0400
-@@ -23902,6 +23902,7 @@
+--- configure.orig 2008-07-26 15:15:12.000000000 -0400
++++ configure 2008-07-26 15:15:35.000000000 -0400
+@@ -25321,6 +25321,7 @@ $as_echo_n "checking whether to check fo
check_inconsistencies=yes
case "${host_cpu}-${host_os}" in
*-darwin*) check_inconsistencies=no ;;
+ *-freebsd*) check_inconsistencies=no ;;
esac
if test x"$GCC" != xyes -o "x$check_inconsistencies" != xyes ; then
- { echo "$as_me:$LINENO: result: no" >&5
-@@ -30280,9 +30281,9 @@
+ { $as_echo "$as_me:$LINENO: result: no" >&5
+@@ -32654,9 +32655,9 @@ _ACEOF
else
-- { { echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
--echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
+- { { $as_echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
+-$as_echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
- { (exit 1); exit 1; }; }
-+# { { echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
-+#echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
++# { { $as_echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
++#$as_echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
+# { (exit 1); exit 1; }; }
fi
-@@ -30290,9 +30291,9 @@
+@@ -32664,9 +32665,9 @@ done
# Win32 does not need the lib and breaks horribly if we try to include it
@@ -32,5 +32,5 @@
+# LIBS="$LIBS -latomic_ops"
+# fi
else
- { echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6; }
+ { $as_echo "$as_me:$LINENO: result: no" >&5
+ $as_echo "no" >&6; }
diff --git a/audio/pulseaudio/files/patch-src_daemon_caps.h b/audio/pulseaudio/files/patch-src_daemon_caps.h
deleted file mode 100644
index 517da35b6e23..000000000000
--- a/audio/pulseaudio/files/patch-src_daemon_caps.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/daemon/caps.h.orig 2008-03-31 07:34:39.290608458 -0400
-+++ src/daemon/caps.h 2008-03-31 07:36:12.728192195 -0400
-@@ -25,7 +25,8 @@
- ***/
-
- void pa_drop_root(void);
--void pa_drop_caps(void);
-+/* Defined in caps.c */
-+/* void pa_drop_caps(void); */
- int pa_limit_caps(void);
-
- #endif
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_core-util.c b/audio/pulseaudio/files/patch-src_pulsecore_core-util.c
index cb91964ad90b..56ae5acc2ea9 100644
--- a/audio/pulseaudio/files/patch-src_pulsecore_core-util.c
+++ b/audio/pulseaudio/files/patch-src_pulsecore_core-util.c
@@ -1,22 +1,22 @@
---- src/pulsecore/core-util.c.orig Sun Jul 8 18:35:21 2007
-+++ src/pulsecore/core-util.c Sun Jul 8 18:39:04 2007
-@@ -40,6 +40,7 @@
+--- src/pulsecore/core-util.c.orig 2008-06-21 13:25:57.000000000 -0400
++++ src/pulsecore/core-util.c 2008-07-26 17:01:01.000000000 -0400
+@@ -37,6 +37,7 @@
#include <time.h>
#include <ctype.h>
#include <sys/types.h>
+#include <sys/socket.h>
#include <sys/stat.h>
#include <sys/time.h>
-
-@@ -544,6 +545,7 @@ fail:
- cap_free(caps);
- }
+ #include <dirent.h>
+@@ -548,6 +549,7 @@ int pa_make_realtime(int rtprio) {
+ #else
+ return -1;
#endif
+ ;
}
- /* Reset the priority to normal, inverting the changes made by pa_raise_priority() */
-@@ -838,22 +840,22 @@ int pa_check_in_group(gid_t g) {
+ /* This is merely used for giving the user a hint. This is not correct
+@@ -1036,22 +1038,22 @@ int pa_check_in_group(gid_t g) {
(advisory on UNIX, mandatory on Windows) */
int pa_lock_fd(int fd, int b) {
#ifdef F_SETLKW
@@ -47,3 +47,15 @@
return 0;
}
+@@ -1990,7 +1992,11 @@ int pa_reset_sigs(int except, ...) {
+ int pa_reset_sigsv(const int except[]) {
+ int sig;
+
++#ifdef _NSIG
+ for (sig = 1; sig < _NSIG; sig++) {
++#else
++ for (sig = 1; sig < NSIG; sig++) {
++#endif
+ pa_bool_t reset = TRUE;
+
+ switch (sig) {
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_proplist-util.c b/audio/pulseaudio/files/patch-src_pulsecore_proplist-util.c
new file mode 100644
index 000000000000..fc72aa4c1e12
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_pulsecore_proplist-util.c
@@ -0,0 +1,11 @@
+--- src/pulsecore/proplist-util.c.orig 2008-07-26 17:01:44.000000000 -0400
++++ src/pulsecore/proplist-util.c 2008-07-26 17:02:32.000000000 -0400
+@@ -37,7 +37,7 @@
+
+ void pa_init_proplist(pa_proplist *p) {
+ int a, b;
+-#ifndef HAVE_DECL_ENVIRON
++#if HAVE_DECL_ENVIRON == 0
+ extern char **environ;
+ #endif
+ char **e;
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_protocol-native.c b/audio/pulseaudio/files/patch-src_pulsecore_protocol-native.c
new file mode 100644
index 000000000000..be0b2899325b
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_pulsecore_protocol-native.c
@@ -0,0 +1,18 @@
+--- src/pulsecore/protocol-native.c.orig 2008-07-26 17:04:23.000000000 -0400
++++ src/pulsecore/protocol-native.c 2008-07-26 17:08:27.000000000 -0400
+@@ -2058,6 +2058,7 @@ static void command_auth(PA_GCC_UNUSED p
+ if (c->version < 10 || (c->version >= 13 && !shm_on_remote))
+ do_shm = FALSE;
+
++#ifdef HAVE_CREDS
+ if (do_shm) {
+ /* Only enable SHM if both sides are owned by the same
+ * user. This is a security measure because otherwise data
+@@ -2067,6 +2068,7 @@ static void command_auth(PA_GCC_UNUSED p
+ if (!(creds = pa_pdispatch_creds(pd)) || getuid() != creds->uid)
+ do_shm = FALSE;
+ }
++#endif
+
+ pa_log_debug("Negotiated SHM: %s", pa_yes_no(do_shm));
+ pa_pstream_enable_shm(c->pstream, do_shm);
diff --git a/audio/pulseaudio/files/patch-src_tests_rtstutter.c b/audio/pulseaudio/files/patch-src_tests_rtstutter.c
new file mode 100644
index 000000000000..c8d657481d62
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_tests_rtstutter.c
@@ -0,0 +1,18 @@
+--- src/tests/rtstutter.c.orig 2008-07-26 17:10:17.000000000 -0400
++++ src/tests/rtstutter.c 2008-07-26 17:12:26.000000000 -0400
+@@ -42,6 +42,7 @@ static int msec_lower, msec_upper;
+ static void* work(void *p) PA_GCC_NORETURN;
+
+ static void* work(void *p) {
++#ifndef __FreeBSD__
+ cpu_set_t mask;
+ struct sched_param param;
+
+@@ -83,6 +84,7 @@ static void* work(void *p) {
+ } while (now.tv_sec < end.tv_sec ||
+ (now.tv_sec == end.tv_sec && now.tv_nsec < end.tv_nsec));
+ }
++#endif
+ }
+
+ int main(int argc, char*argv[]) {
diff --git a/audio/pulseaudio/pkg-plist b/audio/pulseaudio/pkg-plist
index 00d4a0b31c26..0aa8c7464eeb 100644
--- a/audio/pulseaudio/pkg-plist
+++ b/audio/pulseaudio/pkg-plist
@@ -9,25 +9,28 @@ bin/parec
bin/pasuspender
bin/pax11publish
bin/pulseaudio
+bin/start-pulseaudio-x11
@unexec if cmp -s %D/etc/pulse/client.conf %D/etc/pulse/client.conf-dist; then rm -f %D/etc/pulse/client.conf; fi
etc/pulse/client.conf-dist
@unexec if cmp -s %D/etc/pulse/daemon.conf %D/etc/pulse/daemon.conf-dist; then rm -f %D/etc/pulse/daemon.conf; fi
etc/pulse/daemon.conf-dist
@unexec if cmp -s %D/etc/pulse/default.pa %D/etc/pulse/default.pa-dist; then rm -f %D/etc/pulse/default.pa; fi
etc/pulse/default.pa-dist
-etc/xdg/autostart/pulseaudio-module-xsmp.desktop
+etc/xdg/autostart/pulseaudio.desktop
%%AVAHI%%include/pulse/browser.h
include/pulse/cdecl.h
include/pulse/channelmap.h
include/pulse/context.h
include/pulse/def.h
include/pulse/error.h
+include/pulse/gccmacro.h
include/pulse/glib-mainloop.h
include/pulse/introspect.h
include/pulse/mainloop-api.h
include/pulse/mainloop-signal.h
include/pulse/mainloop.h
include/pulse/operation.h
+include/pulse/proplist.h
include/pulse/pulseaudio.h
include/pulse/sample.h
include/pulse/scache.h
@@ -60,7 +63,7 @@ lib/libpulse.so.0
lib/libpulsecore.a
lib/libpulsecore.la
lib/libpulsecore.so
-lib/libpulsecore.so.5
+lib/libpulsecore.so.6
lib/libpulsedsp.so
lib/pulse-%%PULSE_VERSION%%/modules/libauthkey-prop.so
lib/pulse-%%PULSE_VERSION%%/modules/libauthkey.so
@@ -89,12 +92,15 @@ lib/pulse-%%PULSE_VERSION%%/modules/libstrlist.so
lib/pulse-%%PULSE_VERSION%%/modules/libtagstruct.so
lib/pulse-%%PULSE_VERSION%%/modules/libx11prop.so
lib/pulse-%%PULSE_VERSION%%/modules/libx11wrap.so
+lib/pulse-%%PULSE_VERSION%%/modules/module-always-sink.so
lib/pulse-%%PULSE_VERSION%%/modules/module-cli-protocol-tcp.so
lib/pulse-%%PULSE_VERSION%%/modules/module-cli-protocol-unix.so
lib/pulse-%%PULSE_VERSION%%/modules/module-cli.so
lib/pulse-%%PULSE_VERSION%%/modules/module-combine.so
+lib/pulse-%%PULSE_VERSION%%/modules/module-console-kit.so
lib/pulse-%%PULSE_VERSION%%/modules/module-default-device-restore.so
lib/pulse-%%PULSE_VERSION%%/modules/module-detect.so
+lib/pulse-%%PULSE_VERSION%%/modules/module-device-restore.so
lib/pulse-%%PULSE_VERSION%%/modules/module-esound-compat-spawnfd.so
lib/pulse-%%PULSE_VERSION%%/modules/module-esound-compat-spawnpid.so
lib/pulse-%%PULSE_VERSION%%/modules/module-esound-protocol-tcp.so
@@ -115,6 +121,7 @@ lib/pulse-%%PULSE_VERSION%%/modules/module-null-sink.so
lib/pulse-%%PULSE_VERSION%%/modules/module-oss.so
lib/pulse-%%PULSE_VERSION%%/modules/module-pipe-sink.so
lib/pulse-%%PULSE_VERSION%%/modules/module-pipe-source.so
+lib/pulse-%%PULSE_VERSION%%/modules/module-position-event-sounds.so
lib/pulse-%%PULSE_VERSION%%/modules/module-remap-sink.so
lib/pulse-%%PULSE_VERSION%%/modules/module-rescue-streams.so
lib/pulse-%%PULSE_VERSION%%/modules/module-rtp-recv.so