aboutsummaryrefslogtreecommitdiff
path: root/audio/pulseaudio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /audio/pulseaudio
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
Notes
Diffstat (limited to 'audio/pulseaudio')
-rw-r--r--audio/pulseaudio/Makefile8
-rw-r--r--audio/pulseaudio/distinfo6
-rw-r--r--audio/pulseaudio/files/patch-configure22
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_shm.c17
-rw-r--r--audio/pulseaudio/files/patch-src_tests_rtstutter.c27
-rw-r--r--audio/pulseaudio/pkg-plist6
6 files changed, 64 insertions, 22 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index fd3a0acfc8fb..bab70c26ba67 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -3,11 +3,15 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/audio/pulseaudio/Makefile,v 1.5 2009/07/20 21:26:40 marcus Exp $
+# $MCom: ports/audio/pulseaudio/Makefile,v 1.21 2009/11/28 19:08:20 marcus Exp $
+#
+# !!!NOTE!!! Any PORTVERSION update to this port must be accompanied by
+# PORTREVISION bumps to audio/gnome-media, sysutils/gnome-settings-daemon,
+# and audio/gstreamer-plugins-pulse.
#
PORTNAME= pulseaudio
-PORTVERSION= 0.9.19
+PORTVERSION= 0.9.21
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
diff --git a/audio/pulseaudio/distinfo b/audio/pulseaudio/distinfo
index c516046fca19..8529bce24ed9 100644
--- a/audio/pulseaudio/distinfo
+++ b/audio/pulseaudio/distinfo
@@ -1,3 +1,3 @@
-MD5 (pulseaudio-0.9.19.tar.gz) = 02adc2b99252675f0271db3b9edd432e
-SHA256 (pulseaudio-0.9.19.tar.gz) = e47e27083deb79571fb2b9215874ddc26d77c3dec2a7dc8de5ecec9058e4b806
-SIZE (pulseaudio-0.9.19.tar.gz) = 2029090
+MD5 (pulseaudio-0.9.21.tar.gz) = 76e623c4c72e2258bc8bdeb1599bad74
+SHA256 (pulseaudio-0.9.21.tar.gz) = 94e22356ac70ee95388ae58da90d88c6b3186d1938618d21671627ff56cee254
+SIZE (pulseaudio-0.9.21.tar.gz) = 2056896
diff --git a/audio/pulseaudio/files/patch-configure b/audio/pulseaudio/files/patch-configure
index 5130810053df..21a97d9124cc 100644
--- a/audio/pulseaudio/files/patch-configure
+++ b/audio/pulseaudio/files/patch-configure
@@ -1,27 +1,23 @@
---- configure.orig 2008-07-26 15:15:12.000000000 -0400
-+++ configure 2008-07-26 15:15:35.000000000 -0400
-@@ -25321,6 +25321,7 @@ $as_echo_n "checking whether to check fo
+--- configure.orig 2009-11-24 16:31:47.000000000 +0100
++++ configure 2009-11-24 16:32:35.000000000 +0100
+@@ -13586,6 +13586,7 @@
check_inconsistencies=yes
case "${host_cpu}-${host_os}" in
*-darwin*) check_inconsistencies=no ;;
+ *-freebsd*) check_inconsistencies=no ;;
esac
if test x"$GCC" != xyes -o "x$check_inconsistencies" != xyes ; then
- { $as_echo "$as_me:$LINENO: result: no" >&5
-@@ -32654,9 +32655,9 @@ _ACEOF
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+@@ -18007,7 +18008,7 @@
else
-- { { $as_echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
--$as_echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
-- { (exit 1); exit 1; }; }
-+# { { $as_echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
-+#$as_echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
-+# { (exit 1); exit 1; }; }
+- as_fn_error "*** libatomic-ops headers not found" "$LINENO" 5
++# as_fn_error "*** libatomic-ops headers not found" "$LINENO" 5
fi
-@@ -32664,9 +32665,9 @@ done
+@@ -18015,9 +18016,9 @@
# Win32 does not need the lib and breaks horribly if we try to include it
@@ -32,5 +28,5 @@
+# LIBS="$LIBS -latomic_ops"
+# fi
else
- { $as_echo "$as_me:$LINENO: result: no" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
$as_echo "no" >&6; }
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_shm.c b/audio/pulseaudio/files/patch-src_pulsecore_shm.c
index 549091ccc487..4dfa3a3a9392 100644
--- a/audio/pulseaudio/files/patch-src_pulsecore_shm.c
+++ b/audio/pulseaudio/files/patch-src_pulsecore_shm.c
@@ -1,7 +1,7 @@
---- src/pulsecore/shm.c.orig 2007-10-28 15:13:53.000000000 -0400
-+++ src/pulsecore/shm.c 2008-01-01 16:19:19.000000000 -0500
-@@ -80,7 +80,7 @@ struct shm_marker {
- };
+--- src/pulsecore/shm.c.orig 2009-08-19 10:17:06.000000000 +0800
++++ src/pulsecore/shm.c 2009-11-11 21:25:03.000000000 +0800
+@@ -91,7 +91,7 @@
+ #define SHM_MARKER_SIZE PA_ALIGN(sizeof(struct shm_marker))
static char *segment_name(char *fn, size_t l, unsigned id) {
- pa_snprintf(fn, l, "/pulse-shm-%u", id);
@@ -9,3 +9,12 @@
return fn;
}
+@@ -142,7 +142,7 @@
+ pa_random(&m->id, sizeof(m->id));
+ segment_name(fn, sizeof(fn), m->id);
+
+- if ((fd = shm_open(fn, O_RDWR|O_CREAT|O_EXCL, mode & 0444)) < 0) {
++ if ((fd = shm_open(fn, O_RDWR|O_CREAT|O_EXCL, mode & 0644)) < 0) {
+ pa_log("shm_open() failed: %s", pa_cstrerror(errno));
+ goto fail;
+ }
diff --git a/audio/pulseaudio/files/patch-src_tests_rtstutter.c b/audio/pulseaudio/files/patch-src_tests_rtstutter.c
new file mode 100644
index 000000000000..c80737b1946f
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_tests_rtstutter.c
@@ -0,0 +1,27 @@
+--- src/tests/rtstutter.c.orig 2009-07-23 15:40:47.000000000 +0200
++++ src/tests/rtstutter.c 2009-11-24 16:26:36.000000000 +0100
+@@ -31,6 +31,11 @@
+ #include <string.h>
+ #include <pthread.h>
+
++#ifdef HAVE_PTHREAD_SETAFFINITY_NP
++#include <sys/param.h>
++#include <sys/cpuset.h>
++#endif
++
+ #include <pulse/timeval.h>
+ #include <pulse/gccmacro.h>
+
+@@ -44,8 +49,12 @@
+
+ static void* work(void *p) {
+ #ifdef HAVE_PTHREAD_SETAFFINITY_NP
++#ifdef __FreeBSD__
++ cpuset_t mask;
++#else
+ cpu_set_t mask;
+ #endif
++#endif
+ struct sched_param param;
+
+ pa_log_notice("CPU%i: Created thread.", PA_PTR_TO_UINT(p));
diff --git a/audio/pulseaudio/pkg-plist b/audio/pulseaudio/pkg-plist
index b42a03710b05..8be11434795d 100644
--- a/audio/pulseaudio/pkg-plist
+++ b/audio/pulseaudio/pkg-plist
@@ -11,6 +11,7 @@ bin/parecord
bin/pasuspender
bin/pax11publish
bin/pulseaudio
+bin/start-pulseaudio-kde
bin/start-pulseaudio-x11
etc/dbus-1/system.d/pulseaudio-system.conf
@unexec if cmp -s %D/etc/pulse/client.conf %D/etc/pulse/client.conf-dist; then rm -f %D/etc/pulse/client.conf; fi
@@ -26,12 +27,14 @@ etc/pulse/default.pa-dist
etc/pulse/system.pa-dist
@exec [ -f %B/system.pa ] || cp %B/%f %B/system.pa
etc/xdg/autostart/pulseaudio.desktop
+etc/xdg/autostart/pulseaudio-kde.desktop
%%AVAHI%%include/pulse/browser.h
include/pulse/cdecl.h
include/pulse/channelmap.h
include/pulse/context.h
include/pulse/def.h
include/pulse/error.h
+include/pulse/ext-device-manager.h
include/pulse/ext-stream-restore.h
include/pulse/gccmacro.h
include/pulse/glib-mainloop.h
@@ -81,6 +84,8 @@ lib/libpulsedsp.a
lib/libpulsedsp.so
%%AVAHI%%lib/pulse-%%PULSE_VERSION%%/modules/libavahi-wrap.a
%%AVAHI%%lib/pulse-%%PULSE_VERSION%%/modules/libavahi-wrap.so
+lib/pulse-%%PULSE_VERSION%%/modules/module-device-manager.a
+lib/pulse-%%PULSE_VERSION%%/modules/module-device-manager.so
lib/pulse-%%PULSE_VERSION%%/modules/libcli.a
lib/pulse-%%PULSE_VERSION%%/modules/libcli.so
lib/pulse-%%PULSE_VERSION%%/modules/liboss-util.a
@@ -230,6 +235,7 @@ share/locale/fi/LC_MESSAGES/pulseaudio.mo
share/locale/fr/LC_MESSAGES/pulseaudio.mo
share/locale/gu/LC_MESSAGES/pulseaudio.mo
share/locale/hi/LC_MESSAGES/pulseaudio.mo
+share/locale/hu/LC_MESSAGES/pulseaudio.mo
share/locale/it/LC_MESSAGES/pulseaudio.mo
share/locale/ja/LC_MESSAGES/pulseaudio.mo
share/locale/kn/LC_MESSAGES/pulseaudio.mo