aboutsummaryrefslogtreecommitdiff
path: root/audio/pulseaudio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-24 18:59:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-05-24 18:59:23 +0000
commit5d84ee7e5d8a26120ace246f49dfb4f15de59d13 (patch)
tree216825cf65d2cfe640e4a6a0b2e8012bd0976d2e /audio/pulseaudio
parent4887c1312f0744b6fb1d6f3cfd7b2ca5d193cf42 (diff)
downloadports-5d84ee7e5d8a26120ace246f49dfb4f15de59d13.tar.gz
ports-5d84ee7e5d8a26120ace246f49dfb4f15de59d13.zip
Notes
Diffstat (limited to 'audio/pulseaudio')
-rw-r--r--audio/pulseaudio/Makefile2
-rw-r--r--audio/pulseaudio/files/patch_src_pulsecore_shm.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index 3e950b6a6868..1ead6bf12253 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pulseaudio
PORTVERSION= 0.9.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
diff --git a/audio/pulseaudio/files/patch_src_pulsecore_shm.c b/audio/pulseaudio/files/patch_src_pulsecore_shm.c
new file mode 100644
index 000000000000..9c501dd4b095
--- /dev/null
+++ b/audio/pulseaudio/files/patch_src_pulsecore_shm.c
@@ -0,0 +1,10 @@
+--- src/pulsecore/shm.c.orig Thu May 17 11:57:56 2007
++++ src/pulsecore/shm.c Thu May 17 11:58:10 2007
+@@ -50,7 +50,7 @@
+ #define MAX_SHM_SIZE (1024*1024*20)
+
+ static char *segment_name(char *fn, size_t l, unsigned id) {
+- snprintf(fn, l, "/pulse-shm-%u", id);
++ snprintf(fn, l, "/tmp/pulse-shm-%u", id);
+ return fn;
+ }