aboutsummaryrefslogtreecommitdiff
path: root/audio/pulseaudio
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-25 12:53:23 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-25 12:53:23 +0000
commit4d8e904ca9cd60b71d0f9103a4caf7968f7635ec (patch)
treea05444a897b915246446b580c4c055c84db47454 /audio/pulseaudio
parentea394acd2508a6e7893d5cfc58ac048623f9dc2b (diff)
downloadports-4d8e904ca9cd60b71d0f9103a4caf7968f7635ec.tar.gz
ports-4d8e904ca9cd60b71d0f9103a4caf7968f7635ec.zip
Notes
Diffstat (limited to 'audio/pulseaudio')
-rw-r--r--audio/pulseaudio/Makefile61
-rw-r--r--audio/pulseaudio/distinfo5
-rw-r--r--audio/pulseaudio/files/patch-src_Makefile.in4
-rw-r--r--audio/pulseaudio/files/patch-src_daemon_default.pa.in26
-rw-r--r--audio/pulseaudio/files/patch-src_modules_module-detect.c14
-rw-r--r--audio/pulseaudio/files/patch-src_pulsecore_shm.c4
-rw-r--r--audio/pulseaudio/pkg-plist2
7 files changed, 51 insertions, 65 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index d2fa282cac2e..59e2de57203e 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -5,7 +5,7 @@
# PORTREVISION bumps of depending ports.
PORTNAME= pulseaudio
-PORTVERSION= 8.0
+PORTVERSION= 9.0
CATEGORIES= audio
MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
@@ -16,24 +16,22 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LGPL
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
- libspeexdsp.so:audio/speexdsp \
libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
- liborc-0.4.so:devel/orc \
libjson-c.so:devel/json-c \
libdbus-1.so:devel/dbus \
libltdl.so:devel/libltdl \
libck-connector.so:sysutils/consolekit
USE_GNOME= glib20 intltool
-USE_XORG= x11 sm xtst ice
+USE_XORG= ice sm x11 xcb xtst
USE_LDCONFIG= yes
-USES= cpe compiler:c11 execinfo gettext gmake gnome libtool \
- pathfix pkgconfig shebangfix tar:xz
+USES= compiler:c11 cpe execinfo gettext gmake gnome iconv libtool \
+ pathfix pkgconfig shebangfix ssl tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_LIBS="-lpthread" \
- OPENSSL_CFLAGS="-I/usr/include" \
- OPENSSL_LIBS="-lcrypto -lssl" \
+ OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl" \
LIBS="-lm -lintl" \
ac_cv_header_linux_input_h=""
CPPFLAGS+= -I${LOCALBASE}/include
@@ -45,47 +43,70 @@ bash_CMD= ${SETENV} bash
SUB_FILES= pkg-message
CONFIGURE_ARGS= --localstatedir=/var \
- --with-database=simple \
--without-caps \
--disable-udev \
--disable-gtk3 \
- --disable-systemd \
+ --disable-systemd-daemon \
+ --disable-systemd-journal \
+ --disable-systemd-login \
--disable-neon-opt \
--disable-xen \
--disable-lirc # untested
-#FIXME --with-database=auto|tdb|gdbm|simple
-
USERS= pulse
GROUPS= pulse pulse-access pulse-rt
OPTIONS_SUB= yes
-OPTIONS_DEFINE= JACK AVAHI GCONF ALSA SIMD BASH ZSH
-OPTIONS_DEFAULT=AVAHI SIMD
-JACK_CONFIGURE_ENABLE= jack
-JACK_LIB_DEPENDS= libjack.so:audio/jack
+OPTIONS_DEFINE= AVAHI GCONF SIMD
+OPTIONS_DEFAULT=AVAHI SIMD SIMPLE SOXR SPEEX
AVAHI_CONFIGURE_ENABLE= avahi
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
GCONF_CONFIGURE_ENABLE= gconf
GCONF_USE= GNOME=gconf2
-ALSA_CONFIGURE_ENABLE= alsa
-ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
SIMD_CONFIGURE_ENABLE= orc
SIMD_LIB_DEPENDS= liborc-0.4.so:devel/orc
+
+OPTIONS_GROUP= AUDIO COMPLETIONS
+OPTIONS_GROUP_AUDIO= ALSA JACK SOXR SPEEX
+OPTIONS_GROUP_COMPLETIONS= BASH ZSH
+AUDIO_DESC= Audio support
+COMPLETIONS_DESC= Programmable completions
+ALSA_CONFIGURE_ENABLE= alsa
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+JACK_CONFIGURE_ENABLE= jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack
+SOXR_DESC= SoX resampler support
+SOXR_CONFIGURE_WITH= soxr
+SOXR_LIB_DEPENDS= libsoxr.so:audio/libsoxr
+SPEEX_DESC= Speex resampler and AEC support
+SPEEX_CONFIGURE_WITH= speex
+SPEEX_LIB_DEPENDS= libspeexdsp.so:audio/speexdsp
ZSH_CONFIGURE_OFF= --without-zsh-completion-dir
+OPTIONS_SINGLE= DATABASE
+OPTIONS_SINGLE_DATABASE= TDB GDBM SIMPLE
+DATABASE_DESC= Database support
+GDBM_DESC= GNU database manager support
+GDBM_CONFIGURE_ON= --with-database=gdbm
+GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
+SIMPLE_DESC= Simple database support
+SIMPLE_CONFIGURE_ON= --with-database=simple
+TDB_DESC= Trivial database support
+TDB_CONFIGURE_ON= --with-database=tdb
+TDB_LIB_DEPENDS= libtdb.so:databases/tdb
+
PULSE_VERSION= ${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
PLIST_SUB= PULSE_VERSION=${PULSE_VERSION}
post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
${WRKSRC}/src/daemon/default.pa.in
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
-e 's|/lib/dbus/machine-id|/db/dbus/machine-id|g' \
${WRKSRC}/configure
post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/etc/pulse
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/pulse
.for ii in default.pa daemon.conf client.conf system.pa
${INSTALL_DATA} ${WRKSRC}/src/${ii} \
${STAGEDIR}${PREFIX}/etc/pulse/${ii}.sample
diff --git a/audio/pulseaudio/distinfo b/audio/pulseaudio/distinfo
index c91a1cf3dbde..ecbb2783c774 100644
--- a/audio/pulseaudio/distinfo
+++ b/audio/pulseaudio/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pulseaudio-8.0.tar.xz) = 690eefe28633466cfd1ab9d85ebfa9376f6b622deec6bfee5091ac9737cd1989
-SIZE (pulseaudio-8.0.tar.xz) = 1517656
+TIMESTAMP = 1466578411
+SHA256 (pulseaudio-9.0.tar.xz) = c3d3d66b827f18fbe903fe3df647013f09fc1e2191c035be1ee2d82a9e404686
+SIZE (pulseaudio-9.0.tar.xz) = 1537568
diff --git a/audio/pulseaudio/files/patch-src_Makefile.in b/audio/pulseaudio/files/patch-src_Makefile.in
index 1c4093c8e217..06bf44085945 100644
--- a/audio/pulseaudio/files/patch-src_Makefile.in
+++ b/audio/pulseaudio/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2016-01-22 07:34:26 UTC
+--- src/Makefile.in.orig 2016-06-24 23:00:54 UTC
+++ src/Makefile.in
-@@ -11042,7 +11042,7 @@ info-am:
+@@ -11092,7 +11092,7 @@ info-am:
install-data-am: install-commonlibLTLIBRARIES install-dbuspolicyDATA \
install-dist_alsapathsDATA install-dist_alsaprofilesetsDATA \
diff --git a/audio/pulseaudio/files/patch-src_daemon_default.pa.in b/audio/pulseaudio/files/patch-src_daemon_default.pa.in
deleted file mode 100644
index 5b2918cc291a..000000000000
--- a/audio/pulseaudio/files/patch-src_daemon_default.pa.in
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/daemon/default.pa.in.orig 2016-01-18 10:14:20 UTC
-+++ src/daemon/default.pa.in
-@@ -26,10 +26,10 @@ ifelse(@OS_IS_WIN32@, 1, [dnl
- load-sample x11-bell %WINDIR%\Media\ding.wav
- load-sample-dir-lazy %WINDIR%\Media\*.wav
- ], [dnl
--#load-sample-lazy x11-bell /usr/share/sounds/freedesktop/stereo/bell.oga
--#load-sample-lazy pulse-hotplug /usr/share/sounds/freedesktop/stereo/device-added.oga
--#load-sample-lazy pulse-coldplug /usr/share/sounds/freedesktop/stereo/device-added.oga
--#load-sample-lazy pulse-access /usr/share/sounds/freedesktop/stereo/message.oga
-+#load-sample-lazy x11-bell %%LOCALBASE%%/share/sounds/freedesktop/stereo/bell.oga
-+#load-sample-lazy pulse-hotplug %%LOCALBASE%%/share/sounds/freedesktop/stereo/device-added.oga
-+#load-sample-lazy pulse-coldplug %%LOCALBASE%%/share/sounds/freedesktop/stereo/device-added.oga
-+#load-sample-lazy pulse-access %%LOCALBASE%%/share/sounds/freedesktop/stereo/message.oga
- ])dnl
-
- .fail
-@@ -40,7 +40,7 @@ load-module module-stream-restore
- load-module module-card-restore
-
- ### Automatically augment property information from .desktop files
--### stored in /usr/share/application
-+### stored in %%LOCALBASE%%/share/application
- load-module module-augment-properties
-
- ### Should be after module-*-restore but before module-*-detect
diff --git a/audio/pulseaudio/files/patch-src_modules_module-detect.c b/audio/pulseaudio/files/patch-src_modules_module-detect.c
index e5360d7128b6..a762c22ceb1c 100644
--- a/audio/pulseaudio/files/patch-src_modules_module-detect.c
+++ b/audio/pulseaudio/files/patch-src_modules_module-detect.c
@@ -1,16 +1,6 @@
---- src/modules/module-detect.c.orig 2015-09-10 04:51:41 UTC
+--- src/modules/module-detect.c.orig 2016-05-10 12:28:04 UTC
+++ src/modules/module-detect.c
-@@ -46,7 +46,9 @@ PA_MODULE_DESCRIPTION("Detect available
- PA_MODULE_VERSION(PACKAGE_VERSION);
- PA_MODULE_LOAD_ONCE(true);
- PA_MODULE_USAGE("just-one=<boolean>");
-+#ifdef __linux__
- PA_MODULE_DEPRECATED("Please use module-udev-detect instead of module-detect!");
-+#endif
-
- static const char* const valid_modargs[] = {
- "just-one",
-@@ -157,8 +159,7 @@ static int detect_oss(pa_core *c, int ju
+@@ -160,8 +160,7 @@ static int detect_oss(pa_core *c, int ju
continue;
} else if (sscanf(line, "pcm%u: ", &device) == 1) {
diff --git a/audio/pulseaudio/files/patch-src_pulsecore_shm.c b/audio/pulseaudio/files/patch-src_pulsecore_shm.c
index c1a7b33dc1cb..ef723c6e6664 100644
--- a/audio/pulseaudio/files/patch-src_pulsecore_shm.c
+++ b/audio/pulseaudio/files/patch-src_pulsecore_shm.c
@@ -1,6 +1,6 @@
---- src/pulsecore/shm.c.orig 2015-12-31 06:28:35 UTC
+--- src/pulsecore/shm.c.orig 2016-06-21 10:58:21 UTC
+++ src/pulsecore/shm.c
-@@ -95,7 +95,7 @@ struct shm_marker {
+@@ -102,7 +102,7 @@ static inline size_t shm_marker_size(pa_
#ifdef HAVE_SHM_OPEN
static char *segment_name(char *fn, size_t l, unsigned id) {
diff --git a/audio/pulseaudio/pkg-plist b/audio/pulseaudio/pkg-plist
index 283b7222de1e..4ce05014c082 100644
--- a/audio/pulseaudio/pkg-plist
+++ b/audio/pulseaudio/pkg-plist
@@ -69,7 +69,7 @@ lib/libpulse-simple.so.0
lib/libpulse-simple.so.0.1.0
lib/libpulse.so
lib/libpulse.so.0
-lib/libpulse.so.0.19.0
+lib/libpulse.so.0.20.0
%%AVAHI%%lib/pulse-%%PULSE_VERSION%%/modules/libavahi-wrap.so
lib/pulse-%%PULSE_VERSION%%/modules/module-device-manager.so
%%ALSA%%lib/pulse-%%PULSE_VERSION%%/modules/libalsa-util.so