aboutsummaryrefslogtreecommitdiff
path: root/audio/pulseaudio
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-08-17 02:59:20 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-08-17 02:59:20 +0000
commitc508bc2793c74021a2a872c30ab8064c0f3f6e4d (patch)
treeca10643daf53ca0e52d9b699bf1c37eb42c65862 /audio/pulseaudio
parent6af85f564d05aff93f185529728e03eaf8a2f052 (diff)
downloadports-c508bc2793c74021a2a872c30ab8064c0f3f6e4d.tar.gz
ports-c508bc2793c74021a2a872c30ab8064c0f3f6e4d.zip
Notes
Diffstat (limited to 'audio/pulseaudio')
-rw-r--r--audio/pulseaudio/Makefile2
-rw-r--r--audio/pulseaudio/files/patch-src_modules_module-hal-detect.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index afe7f1849faa..aa0fa5bb9911 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -8,7 +8,7 @@
PORTNAME= pulseaudio
PORTVERSION= 0.9.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://0pointer.de/lennart/projects/${PORTNAME}/
diff --git a/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c b/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c
new file mode 100644
index 000000000000..fd7f8bd45e52
--- /dev/null
+++ b/audio/pulseaudio/files/patch-src_modules_module-hal-detect.c
@@ -0,0 +1,11 @@
+--- src/modules/module-hal-detect.c.orig 2009-04-04 20:16:18.000000000 -0500
++++ src/modules/module-hal-detect.c 2009-08-16 16:09:49.000000000 -0500
+@@ -293,7 +293,7 @@
+
+ /* We only care for the main device */
+ device = libhal_device_get_property_int(context, udi, "oss.device", &error);
+- if (dbus_error_is_set(&error) || device != 0)
++ if (dbus_error_is_set(&error))
+ goto finish;
+
+ r = TRUE;