aboutsummaryrefslogtreecommitdiff
path: root/audio/py-fastaudio
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2010-05-14 05:41:11 +0000
committerMarcus von Appen <mva@FreeBSD.org>2010-05-14 05:41:11 +0000
commitdecaca3feca96c34565d963069d88d226b660604 (patch)
tree23bedae61f9bea768f9ff4eff2479b08d5f6827a /audio/py-fastaudio
parent578f24eff702d5733597437d8908e27c58fd3134 (diff)
downloadports-decaca3feca96c34565d963069d88d226b660604.tar.gz
ports-decaca3feca96c34565d963069d88d226b660604.zip
Notes
Diffstat (limited to 'audio/py-fastaudio')
-rw-r--r--audio/py-fastaudio/Makefile1
-rw-r--r--audio/py-fastaudio/files/patch-fastaudio.pyx13
2 files changed, 12 insertions, 2 deletions
diff --git a/audio/py-fastaudio/Makefile b/audio/py-fastaudio/Makefile
index d51e2d36202b..a11b5737c29c 100644
--- a/audio/py-fastaudio/Makefile
+++ b/audio/py-fastaudio/Makefile
@@ -8,6 +8,7 @@
PORTNAME= fastaudio
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= http://www.freenet.org.nz/python/pyPortAudio/:site1 \
http://www.portaudio.com/archives/:site2
diff --git a/audio/py-fastaudio/files/patch-fastaudio.pyx b/audio/py-fastaudio/files/patch-fastaudio.pyx
index 8f097b13b3f0..025b6aaacfb5 100644
--- a/audio/py-fastaudio/files/patch-fastaudio.pyx
+++ b/audio/py-fastaudio/files/patch-fastaudio.pyx
@@ -1,5 +1,5 @@
---- fastaudio.pyx.orig 2004-06-15 20:37:39.000000000 +0900
-+++ fastaudio.pyx 2009-06-06 18:54:52.000000000 +0900
+--- fastaudio.pyx.orig 2004-06-15 13:37:39.000000000 +0200
++++ fastaudio.pyx 2010-05-08 09:24:38.000000000 +0200
@@ -92,7 +92,7 @@
#@+node:portaudio.h
# portaudio-specifics
@@ -9,6 +9,15 @@
ctypedef int PaError
cdef enum PA_ERRORS:
+@@ -553,7 +553,7 @@
+ cdef int isrunning
+ #@-node:attributes
+ #@+node:__new__
+- def __new__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
++ def __cinit__(self, samplerate=8000, channels=2, format='int16', framesPerBuf=4096, maxbufs=16, **kwds):
+ """
+ Constructor for fastaudio stream objects.
+
@@ -586,8 +586,8 @@
cdata.framesPerBuf = framesPerBuf
cdata.bytesPerFrame = channels * _sampleFormatSizes[format]