aboutsummaryrefslogtreecommitdiff
path: root/audio/py-xmms2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 03:52:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-01 03:52:52 +0000
commit784eb5c8164b137832c908cb20371065aa58989b (patch)
tree4fdb17ea5535d74591e5829a4b23089af5ebe57e /audio/py-xmms2
parent40317bbdb40838f519fb01da0448f53075461516 (diff)
downloadports-784eb5c8164b137832c908cb20371065aa58989b.tar.gz
ports-784eb5c8164b137832c908cb20371065aa58989b.zip
Notes
Diffstat (limited to 'audio/py-xmms2')
-rw-r--r--audio/py-xmms2/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/py-xmms2/Makefile b/audio/py-xmms2/Makefile
new file mode 100644
index 000000000000..ede9fa4cf17a
--- /dev/null
+++ b/audio/py-xmms2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-xmms2
+# Date created: 18 Mar 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= audio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= Python Bindings for XMMS2
+
+BUILD_DEPENDS= pyrex:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../xmms2
+
+USE_PYTHON= yes
+
+PLIST_FILES= ${PYTHONPREFIX_SITELIBDIR}/xmmsclient.so
+
+SCONS_TARGET= src/clients/lib/python/xmmsclient.so
+XMMS2_SLAVE= python
+
+do-install:
+ @cd ${WRKSRC} && ${INSTALL_PROGRAM} ${SCONS_TARGET} ${PYTHONPREFIX_SITELIBDIR}/xmmsclient.so
+
+.include "${MASTERDIR}/Makefile"