aboutsummaryrefslogtreecommitdiff
path: root/audio/qmpdclient
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-09-23 05:58:38 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-09-23 05:58:38 +0000
commit888deb46e82edfe35312839820e54b1438f5061c (patch)
tree1df1774e8c7f848ca2db72ae6e0d913661f58605 /audio/qmpdclient
parentd92cf1ee419b19c99eb14c37604ff6372dde0dc7 (diff)
downloadports-888deb46e82edfe35312839820e54b1438f5061c.tar.gz
ports-888deb46e82edfe35312839820e54b1438f5061c.zip
Notes
Diffstat (limited to 'audio/qmpdclient')
-rw-r--r--audio/qmpdclient/Makefile52
-rw-r--r--audio/qmpdclient/distinfo21
-rw-r--r--audio/qmpdclient/files/patch-configure23
-rw-r--r--audio/qmpdclient/files/patch-qmpdclient.pro30
-rw-r--r--audio/qmpdclient/files/patch-src__mpd.cpp12
-rw-r--r--audio/qmpdclient/files/patch-src__mpdstatus.cpp13
-rw-r--r--audio/qmpdclient/files/patch-src__mpdstatus.h10
7 files changed, 93 insertions, 68 deletions
diff --git a/audio/qmpdclient/Makefile b/audio/qmpdclient/Makefile
index f12cb1081f6a..9cda8088aad7 100644
--- a/audio/qmpdclient/Makefile
+++ b/audio/qmpdclient/Makefile
@@ -6,24 +6,62 @@
#
PORTNAME= qmpdclient
-PORTVERSION= 1.0.7
+PORTVERSION= 1.0.8
CATEGORIES= audio
-MASTER_SITES= http://havtknut.tihlde.org/qmpdclient/files/ \
- http://mirrors.ludost.net/gentoo/distfiles/
+MASTER_SITES= http://havtknut.tihlde.org/qmpdclient/files/
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= uyamba@gmail.com
COMMENT= Easy to use musicpd client written in QT4
-BROKEN= Does not build
-
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_QT_VER= 4
-QT_COMPONENTS= gui qmake uic moc rcc
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build \
+ linguist_build corelib gui
+QMAKE_ARGS= -unix PREFIX=${PREFIX}
+
+OPTIONS= DBUS "Enable D-BUS support" off
+DATADIR= ${PREFIX}/share/QMPDClient
PLIST_FILES= bin/${PORTNAME}
+PLIST_DIRS= ${DATADIR_REL}/translations \
+ ${DATADIR_REL}
+
+USE_DOS2UNIX= qmpdclient.pro
+
+TRANSLATIONS= de_DE nl_NL nn_NO no_NO ru_RU
+.for lang in ${TRANSLATIONS}
+DISTFILES+= translations/${lang}.ts
+PLIST_FILES+= ${DATADIR_REL}/translations/${lang}.qm
+.endfor
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DBUS) && !defined(WITHOUT_DBUS)
+QT_COMPONENTS+= dbus
+QMAKE_ARGS+= CONFIG+=qdbus
+.endif
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ ${QMAKE_ARGS} qmpdclient.pro
+
+post-build:
+.for lang in ${TRANSLATIONS}
+ @${QT_PREFIX}/bin/lrelease-qt4 -compress \
+ ${DISTDIR}/${DIST_SUBDIR}/translations/${lang}.ts \
+ -qm ${WRKDIR}/${lang}.qm
+.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${TARGETDIR}/${DATADIR}/translations
+.for lang in ${TRANSLATIONS}
+ ${INSTALL_DATA} ${WRKDIR}/${lang}.qm \
+ ${TARGETDIR}/${DATADIR}/translations/${lang}.qm
+.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/qmpdclient/distinfo b/audio/qmpdclient/distinfo
index 2f58113dce92..4a3fef24fd04 100644
--- a/audio/qmpdclient/distinfo
+++ b/audio/qmpdclient/distinfo
@@ -1,3 +1,18 @@
-MD5 (qmpdclient-1.0.7.tar.gz) = ca37c7f9ff20c37aab5090b0ed531c06
-SHA256 (qmpdclient-1.0.7.tar.gz) = 4d01940020414cb5c16299dd03f32bc00daa2defc7805348b71ef7ff42d2c5d2
-SIZE (qmpdclient-1.0.7.tar.gz) = 226078
+MD5 (qmpdclient/qmpdclient-1.0.8.tar.gz) = 5c4d9734b83d87d98fe6ea24fb38227c
+SHA256 (qmpdclient/qmpdclient-1.0.8.tar.gz) = 2b9076a5c51b2c201f64e74b8756645427de539974fda10c8dd77dd2b7973381
+SIZE (qmpdclient/qmpdclient-1.0.8.tar.gz) = 190349
+MD5 (qmpdclient/translations/de_DE.ts) = a917107d043cf364c801204564bec6d4
+SHA256 (qmpdclient/translations/de_DE.ts) = 2fc335b6382ca15ab0e563741c059e801c31a96397179b305c5bb2aa9cb00bf7
+SIZE (qmpdclient/translations/de_DE.ts) = 33591
+MD5 (qmpdclient/translations/nl_NL.ts) = 261d84593ba1816fdd9b5d9bb4a847a9
+SHA256 (qmpdclient/translations/nl_NL.ts) = 8d34f47ee367a65283f47c5efb3dabbe5059d6108df1a8c14060d82ba15fc7ef
+SIZE (qmpdclient/translations/nl_NL.ts) = 33503
+MD5 (qmpdclient/translations/nn_NO.ts) = caa89089c13c56a19206afca6cd8d4fe
+SHA256 (qmpdclient/translations/nn_NO.ts) = 6dde1ead2f0039f4dd349c8ee1940ce4ffed11bd729ec71f9a7ad8472ad14ce9
+SIZE (qmpdclient/translations/nn_NO.ts) = 50385
+MD5 (qmpdclient/translations/no_NO.ts) = a07df71a9346203433b8399516b1cfcc
+SHA256 (qmpdclient/translations/no_NO.ts) = 95ab42d5e610dbfdc4a4166f2f976ac4bf492dd1f726cac84880f30a9fdc6d5b
+SIZE (qmpdclient/translations/no_NO.ts) = 50448
+MD5 (qmpdclient/translations/ru_RU.ts) = d9cb99815c9d2e9c60fca520fd4b001d
+SHA256 (qmpdclient/translations/ru_RU.ts) = 73e4fdd4590655c3396f75fd9747a480e438c0e5957739843d2530c7d1dae93d
+SIZE (qmpdclient/translations/ru_RU.ts) = 50043
diff --git a/audio/qmpdclient/files/patch-configure b/audio/qmpdclient/files/patch-configure
deleted file mode 100644
index 9fcec73168e6..000000000000
--- a/audio/qmpdclient/files/patch-configure
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure.orig Sat Apr 22 15:47:47 2006
-+++ configure Wed Jun 6 17:22:24 2007
-@@ -1,17 +1,17 @@
- #!/bin/sh
-
--QMAKE=`which qmake`
-+QMAKE=`which qmake-qt4`
-
- if [ -n ""$QMAKE -a -e ""$QMAKE ]; then
- echo "$QMAKE found. OK."
- else
-- echo "qmake not found, or not executable."
-+ echo "qmake-qt4 not found, or not executable."
- exit 1
- fi
-
- echo
- echo -n "Generating Makefile... ";
--qmake
-+qmake-qt4
- echo "Done."
- echo
- echo "Now run 'make' to compile."
diff --git a/audio/qmpdclient/files/patch-qmpdclient.pro b/audio/qmpdclient/files/patch-qmpdclient.pro
new file mode 100644
index 000000000000..13ffd453f00d
--- /dev/null
+++ b/audio/qmpdclient/files/patch-qmpdclient.pro
@@ -0,0 +1,30 @@
+--- qmpdclient.pro.orig 2007-06-27 20:44:23.000000000 +0400
++++ qmpdclient.pro 2007-07-25 14:59:51.000000000 +0400
+@@ -1,11 +1,3 @@
+-# installation prefix on *nix/osx
+-PREFIX = /usr/local
+-
+-# Most people need not muck about below here
+-!contains(QT_MAJOR_VERSION, 4) {
+- error(QMPDClient requires Qt 4)
+-}
+-
+ CONFIG += qt release #debug
+ CONFIG -= debug # Needed to avoid console on win32
+ TEMPLATE = app
+@@ -181,13 +173,12 @@
+ SOURCES += src/qmpdclient_x11.cpp
+
+ # Check for dbus support
+- contains(QT_CONFIG, qdbus) {
++ contains(CONFIG, qdbus) {
+ message(DBus notifier: enabled)
+- CONFIG += qdbus
+ SOURCES += src/notifications_dbus.cpp
+ }
+ else {
+- message(DBus notifier: disabled (Qt is not compiled with dbus support))
++ message(DBus notifier: disabled)
+ SOURCES += src/notifications_nodbus.cpp
+ }
+ }
diff --git a/audio/qmpdclient/files/patch-src__mpd.cpp b/audio/qmpdclient/files/patch-src__mpd.cpp
deleted file mode 100644
index 7a3a2a8594e4..000000000000
--- a/audio/qmpdclient/files/patch-src__mpd.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/mpd.cpp.orig Wed Dec 6 18:49:57 2006
-+++ src/mpd.cpp Fri Jun 1 23:52:14 2007
-@@ -578,6 +578,9 @@
- if (!m_connected)
- return;
-
-+ m_status.setVolume(v);
-+ emit volumeUpdated(v);
-+
- QMutexLocker lock(&m_mutex);
- mpd_sendSetvolCommand(m_connection, v);
- finishCommand();
diff --git a/audio/qmpdclient/files/patch-src__mpdstatus.cpp b/audio/qmpdclient/files/patch-src__mpdstatus.cpp
deleted file mode 100644
index 30d153b7b875..000000000000
--- a/audio/qmpdclient/files/patch-src__mpdstatus.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/mpdstatus.cpp.orig Wed Dec 6 18:23:51 2006
-+++ src/mpdstatus.cpp Fri Jun 1 23:08:56 2007
-@@ -88,6 +88,10 @@
- return d->m_volume;
- }
-
-+void MPDStatus::MPDStatus::setVolume(int vol) const {
-+ d->m_volume = vol;
-+}
-+
- int MPDStatus::repeat() const {
- return d->m_repeat;
- }
diff --git a/audio/qmpdclient/files/patch-src__mpdstatus.h b/audio/qmpdclient/files/patch-src__mpdstatus.h
deleted file mode 100644
index 387589814724..000000000000
--- a/audio/qmpdclient/files/patch-src__mpdstatus.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mpdstatus.h.orig Wed Dec 6 18:23:15 2006
-+++ src/mpdstatus.h Fri Jun 1 23:09:14 2007
-@@ -33,6 +33,7 @@
- MPDStatus(const MPDStatus &);
- ~MPDStatus();
- int volume() const;
-+ void setVolume(int vol) const;
- int repeat() const;
- int random() const;
- int playlistLength() const;