aboutsummaryrefslogtreecommitdiff
path: root/audio/qsynth/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-01-13 01:01:28 +0000
committerSteve Wills <swills@FreeBSD.org>2018-01-13 01:01:28 +0000
commitec1a47a286486053bc52cdf22804f621b91e0e0a (patch)
tree41a0ef01709c11dcf7c8557db00028cc61af453d /audio/qsynth/Makefile
parentf4a496acb89bf7b161df1dbb87c43460575b7dfb (diff)
downloadports-ec1a47a286486053bc52cdf22804f621b91e0e0a.tar.gz
ports-ec1a47a286486053bc52cdf22804f621b91e0e0a.zip
Notes
Diffstat (limited to 'audio/qsynth/Makefile')
-rw-r--r--audio/qsynth/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/audio/qsynth/Makefile b/audio/qsynth/Makefile
index 7dafb56d55df..1bc5585afa67 100644
--- a/audio/qsynth/Makefile
+++ b/audio/qsynth/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= qsynth
-PORTVERSION= 0.4.4
+DISTVERSIONPREFIX= qsynth_
+DISTVERSION= 0_5_0
CATEGORIES= audio
-MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt fluidsynth front-end application
@@ -14,7 +14,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-USES= gmake pkgconfig
+USES= autoreconf gmake pkgconfig
+USE_CXXSTD= c++11
+USE_QT5= core gui widgets x11extras buildtools_build linguisttools_build qmake_build
+USE_GL= gl
+USE_GITHUB= yes
+GH_ACCOUNT= rncbc
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
ac_cv_path_ac_moc=${MOC} \
@@ -23,21 +29,18 @@ CONFIGURE_ENV= ac_cv_path_ac_cv_qmake=${QMAKE} \
ac_cv_path_ac_lrelease=${LRELEASE}
CONFIGURE_ARGS= --localedir=${DATADIR} \
--with-fluidsynth=${LOCALBASE}
-USE_CXXSTD= c++11
-USE_QT5= core gui widgets buildtools_build linguisttools_build qmake_build
-USE_GL= gl
-INSTALLS_ICONS= yes
OPTIONS_DEFINE= GRADIENT SYSTEM_TRAY XUNIQUE
-OPTIONS_DEFAULT=GRADIENT SYSTEM_TRAY XUNIQUE
+OPTIONS_DEFAULT= GRADIENT SYSTEM_TRAY XUNIQUE
-GRADIENT_DESC= Gradient eye-candy
-GRADIENT_CONFIGURE_ENABLE= gradient
+GRADIENT_DESC= Gradient eye-candy
SYSTEM_TRAY_DESC= System-tray icon support
+XUNIQUE_DESC= X11 unique/single instance
+
+GRADIENT_CONFIGURE_ENABLE= gradient
SYSTEM_TRAY_CONFIGURE_ENABLE= system-tray
-XUNIQUE_DESC= X11 unique/single instance
XUNIQUE_CONFIGURE_ENABLE= xunique
-XUNIQUE_USE= XORG=x11
+XUNIQUE_USE= XORG=x11
post-patch:
@${REINPLACE_CMD} -e ' \