aboutsummaryrefslogtreecommitdiff
path: root/audio/raop_play
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2006-12-08 18:14:11 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2006-12-08 18:14:11 +0000
commit471473dc4b10ad353f026c20004ed1a415486f53 (patch)
tree44dc3ea2c7f81bf90e68704df9e5a956cfee2ded /audio/raop_play
parent9833a3f33a71d0280ab8d0050451031b1626fc99 (diff)
downloadports-471473dc4b10ad353f026c20004ed1a415486f53.tar.gz
ports-471473dc4b10ad353f026c20004ed1a415486f53.zip
Notes
Diffstat (limited to 'audio/raop_play')
-rw-r--r--audio/raop_play/Makefile31
-rw-r--r--audio/raop_play/distinfo3
-rw-r--r--audio/raop_play/files/getline.c174
-rw-r--r--audio/raop_play/files/getline.h23
-rw-r--r--audio/raop_play/files/hoge-patch-raop_play-audio_stream.h16
-rw-r--r--audio/raop_play/files/patch-Makefile14
-rw-r--r--audio/raop_play/files/patch-aexcl-Makefile.in32
-rw-r--r--audio/raop_play/files/patch-aexcl-aexcl_play.c12
-rw-r--r--audio/raop_play/files/patch-raop_play-Makefile.in29
-rw-r--r--audio/raop_play/files/patch-raop_play-aac_stream.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-aexcl_lib.h19
-rw-r--r--audio/raop_play/files/patch-raop_play-audio_stream.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-flac_streams.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-m4a_stream.c10
-rw-r--r--audio/raop_play/files/patch-raop_play-mp3_stream.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-ogg_stream.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-pcm_streams.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-pls_stream.c11
-rw-r--r--audio/raop_play/files/patch-raop_play-raop_client.c29
-rw-r--r--audio/raop_play/files/patch-raop_play-wav_stream.c11
-rw-r--r--audio/raop_play/files/patch-rendezvous-Client.c13
-rw-r--r--audio/raop_play/files/patch-rendezvous-Makefile.in30
-rw-r--r--audio/raop_play/files/patch-rendezvous-mDNS.c11
-rw-r--r--audio/raop_play/pkg-descr10
24 files changed, 544 insertions, 0 deletions
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
new file mode 100644
index 000000000000..04051fd81465
--- /dev/null
+++ b/audio/raop_play/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: raop_play
+# Date created: 8 Dec 2006
+# Whom: sumikawa
+#
+# $FreeBSD$
+#
+
+PORTNAME= raop_play
+PORTVERSION= 0.5.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= raop-play
+
+MAINTAINER= sumikawa@FreeBSD.org
+COMMENT= A music file player for Apple Airport Express
+
+LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
+RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321 \
+ ogg123:${PORTSDIR}/audio/vorbis-tools \
+ faad:${PORTSDIR}/audio/faad \
+ flac:${PORTSDIR}/audio/flac
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+pre-build:
+ ${CP} ${FILESDIR}/getline.c ${FILESDIR}/getline.h ${WRKSRC}/rendezvous/
+
+.include <bsd.port.mk>
diff --git a/audio/raop_play/distinfo b/audio/raop_play/distinfo
new file mode 100644
index 000000000000..16b3d6df2404
--- /dev/null
+++ b/audio/raop_play/distinfo
@@ -0,0 +1,3 @@
+MD5 (raop_play-0.5.1.tar.gz) = 921f89c1d61f2a22e737e8431df63301
+SHA256 (raop_play-0.5.1.tar.gz) = 66a198bf05cd02582bde1d48c8068795775d8a5a920cff6fd3290e169f3051bb
+SIZE (raop_play-0.5.1.tar.gz) = 259985
diff --git a/audio/raop_play/files/getline.c b/audio/raop_play/files/getline.c
new file mode 100644
index 000000000000..9830b4d25075
--- /dev/null
+++ b/audio/raop_play/files/getline.c
@@ -0,0 +1,174 @@
+/* getline.c -- Replacement for GNU C library function getline
+
+Copyright (C) 1993 Free Software Foundation, Inc.
+
+This program is free software; you can redistribute it and/or
+modify it under the terms of the GNU General Public License as
+published by the Free Software Foundation; either version 2 of the
+License, or (at your option) any later version.
+
+This program is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+General Public License for more details. */
+
+/* Written by Jan Brittenson, bson@gnu.ai.mit.edu. */
+
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
+#include <sys/types.h>
+#include <stdio.h>
+#include <assert.h>
+#include <errno.h>
+#include "getline.h"
+
+#if STDC_HEADERS
+#include <stdlib.h>
+#else
+char *malloc (), *realloc ();
+#endif
+
+/* Always add at least this many bytes when extending the buffer. */
+#define MIN_CHUNK 64
+
+/* Read up to (and including) a TERMINATOR from STREAM into *LINEPTR
+ + OFFSET (and null-terminate it). If LIMIT is non-negative, then
+ read no more than LIMIT chars.
+
+ *LINEPTR is a pointer returned from malloc (or NULL), pointing to
+ *N characters of space. It is realloc'd as necessary.
+
+ Return the number of characters read (not including the null
+ terminator), or -1 on error or EOF. On a -1 return, the caller
+ should check feof(), if not then errno has been set to indicate the
+ error. */
+
+int
+getstr (lineptr, n, stream, terminator, offset, limit)
+ char **lineptr;
+ size_t *n;
+ FILE *stream;
+ int terminator;
+ int offset;
+ int limit;
+{
+ int nchars_avail; /* Allocated but unused chars in *LINEPTR. */
+ char *read_pos; /* Where we're reading into *LINEPTR. */
+ int ret;
+
+ if (!lineptr || !n || !stream)
+ {
+ errno = EINVAL;
+ return -1;
+ }
+
+ if (!*lineptr)
+ {
+ *n = MIN_CHUNK;
+ *lineptr = malloc (*n);
+ if (!*lineptr)
+ {
+ errno = ENOMEM;
+ return -1;
+ }
+ *lineptr[0] = '\0';
+ }
+
+ nchars_avail = *n - offset;
+ read_pos = *lineptr + offset;
+
+ for (;;)
+ {
+ int save_errno;
+ register int c;
+
+ if (limit == 0)
+ break;
+ else
+ {
+ c = getc (stream);
+
+ /* If limit is negative, then we shouldn't pay attention to
+ it, so decrement only if positive. */
+ if (limit > 0)
+ limit--;
+ }
+
+ save_errno = errno;
+
+ /* We always want at least one char left in the buffer, since we
+ always (unless we get an error while reading the first char)
+ NUL-terminate the line buffer. */
+
+ assert((*lineptr + *n) == (read_pos + nchars_avail));
+ if (nchars_avail < 2)
+ {
+ if (*n > MIN_CHUNK)
+ *n *= 2;
+ else
+ *n += MIN_CHUNK;
+
+ nchars_avail = *n + *lineptr - read_pos;
+ *lineptr = realloc (*lineptr, *n);
+ if (!*lineptr)
+ {
+ errno = ENOMEM;
+ return -1;
+ }
+ read_pos = *n - nchars_avail + *lineptr;
+ assert((*lineptr + *n) == (read_pos + nchars_avail));
+ }
+
+ if (ferror (stream))
+ {
+ /* Might like to return partial line, but there is no
+ place for us to store errno. And we don't want to just
+ lose errno. */
+ errno = save_errno;
+ return -1;
+ }
+
+ if (c == EOF)
+ {
+ /* Return partial line, if any. */
+ if (read_pos == *lineptr)
+ return -1;
+ else
+ break;
+ }
+
+ *read_pos++ = c;
+ nchars_avail--;
+
+ if (c == terminator)
+ /* Return the line. */
+ break;
+ }
+
+ /* Done - NUL terminate and return the number of chars read. */
+ *read_pos = '\0';
+
+ ret = read_pos - (*lineptr + offset);
+ return ret;
+}
+
+int
+getline (lineptr, n, stream)
+ char **lineptr;
+ size_t *n;
+ FILE *stream;
+{
+ return getstr (lineptr, n, stream, '\n', 0, GETLINE_NO_LIMIT);
+}
+
+int
+getline_safe (lineptr, n, stream, limit)
+ char **lineptr;
+ size_t *n;
+ FILE *stream;
+ int limit;
+{
+ return getstr (lineptr, n, stream, '\n', 0, limit);
+}
diff --git a/audio/raop_play/files/getline.h b/audio/raop_play/files/getline.h
new file mode 100644
index 000000000000..3bbad5698eb3
--- /dev/null
+++ b/audio/raop_play/files/getline.h
@@ -0,0 +1,23 @@
+#ifndef _getline_h_
+#define _getline_h_ 1
+
+#include <stdio.h>
+
+#if defined (__GNUC__) || (defined (__STDC__) && __STDC__)
+#define __PROTO(args) args
+#else
+#define __PROTO(args) ()
+#endif /* GCC. */
+
+#define GETLINE_NO_LIMIT -1
+
+int
+ getline __PROTO ((char **_lineptr, size_t *_n, FILE *_stream));
+int
+ getline_safe __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
+ int limit));
+int
+ getstr __PROTO ((char **_lineptr, size_t *_n, FILE *_stream,
+ int _terminator, int _offset, int limit));
+
+#endif /* _getline_h_ */
diff --git a/audio/raop_play/files/hoge-patch-raop_play-audio_stream.h b/audio/raop_play/files/hoge-patch-raop_play-audio_stream.h
new file mode 100644
index 000000000000..e90eee4d7a35
--- /dev/null
+++ b/audio/raop_play/files/hoge-patch-raop_play-audio_stream.h
@@ -0,0 +1,16 @@
+--- raop_play/audio_stream.h.orig Thu Jul 28 04:43:17 2005
++++ raop_play/audio_stream.h Fri Aug 12 09:46:45 2005
+@@ -20,6 +20,13 @@
+ #ifndef __AUDIO_STREAM_H_
+ #define __AUDIO_STREAM_H_
+
++#define __u8 u_int8_t
++#define __u16 u_int16_t
++#define __u32 u_int32_t
++#define __s8 int8_t
++#define __s16 int16_t
++#define __s32 int32_t
++
+ #include <signal.h>
+
+ typedef enum data_type_t {
diff --git a/audio/raop_play/files/patch-Makefile b/audio/raop_play/files/patch-Makefile
new file mode 100644
index 000000000000..9a9870fa4c45
--- /dev/null
+++ b/audio/raop_play/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.in- Fri Aug 12 09:57:20 2005
++++ Makefile.in Fri Aug 12 09:57:58 2005
+@@ -1,9 +1,9 @@
+ SUBDIRS = rendezvous raop_play aexcl
+
+ all:
+- for i in $(SUBDIRS); do make -C $$i; done
++ for i in $(SUBDIRS); do gmake -C $$i; done
+
+ install uninstall clean:
+- for i in $(SUBDIRS); do make -C $$i $@; done
++ for i in $(SUBDIRS); do gmake -C $$i $@; done
+
+ distclean:
diff --git a/audio/raop_play/files/patch-aexcl-Makefile.in b/audio/raop_play/files/patch-aexcl-Makefile.in
new file mode 100644
index 000000000000..a8c3d6e8c7ff
--- /dev/null
+++ b/audio/raop_play/files/patch-aexcl-Makefile.in
@@ -0,0 +1,32 @@
+--- aexcl/Makefile.in.orig Fri Dec 16 23:17:00 2005
++++ aexcl/Makefile.in Thu Jul 6 16:32:41 2006
+@@ -2,6 +2,7 @@
+ CC = @CC@
+ CXX = @CXX@
+ DEFS = @DEFS@
++LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -17,8 +18,8 @@
+
+ CXXFLAGS += -Wall -D_GNU_SOURCE -I../raop_play -I../rendezvous
+ GLIB = glib-2.0
+-CXXFLAGS += -I/usr/include/$(GLIB) -I/usr/lib/$(GLIB)/include
+-CFLAGS += -Wall -I/usr/include/$(GLIB) -I/usr/lib/$(GLIB)/include -I../raop_play
++CXXFLAGS += -I$(prefix)/include -I$(prefix)/include/$(GLIB) -I/usr/X11R6/include/
++CFLAGS += -Wall -I$(prefix)/include -I$(prefix)/include/$(GLIB) -I/usr/X11R6/include/ -I../raop_play
+
+ ifdef GLIB_SUBST
+ GLIB_SUBST_OBJ = ipod/glibsubst.o
+@@ -29,8 +30,8 @@
+
+ all: $(TARGET)
+
+-$(TARGET): aexcl_gui.o aexcl_play.o ipod_browser.o ../raop_play/aexcl_lib.o ipod/itunesdb.o $(GLIB_SUBST_OBJ)
+- $(CXX) -o $@ $^ -lfltk $(GLIB_LINK)
++$(TARGET): aexcl_gui.o aexcl_play.o ipod_browser.o ../raop_play/aexcl_lib.o ipod/itunesdb.o ../rendezvous/getline.o $(GLIB_SUBST_OBJ)
++ $(CXX) $(LDFLAGS) -o $@ $^ -lfltk $(GLIB_LINK)
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(bindir)/
diff --git a/audio/raop_play/files/patch-aexcl-aexcl_play.c b/audio/raop_play/files/patch-aexcl-aexcl_play.c
new file mode 100644
index 000000000000..177a78ef6987
--- /dev/null
+++ b/audio/raop_play/files/patch-aexcl-aexcl_play.c
@@ -0,0 +1,12 @@
+--- aexcl/aexcl_play.cxx.orig Fri Dec 16 23:17:00 2005
++++ aexcl/aexcl_play.cxx Wed Jul 5 16:28:14 2006
+@@ -23,6 +23,9 @@
+ #include <signal.h>
+ #include <sys/wait.h>
+ #include <getopt.h>
++extern "C" {
++#include "getline.h"
++};
+ #include "aexcl_gui.h"
+ #include "aexcl_lib.h"
+ #include "mDNS.h"
diff --git a/audio/raop_play/files/patch-raop_play-Makefile.in b/audio/raop_play/files/patch-raop_play-Makefile.in
new file mode 100644
index 000000000000..5897bc8dfe58
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-Makefile.in
@@ -0,0 +1,29 @@
+--- raop_play/Makefile.in.orig Fri Dec 16 23:17:00 2005
++++ raop_play/Makefile.in Thu Jul 6 16:38:02 2006
+@@ -1,6 +1,7 @@
+ SHELL = @SHELL@
+ CC = @CC@
+ DEFS = @DEFS@
++LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -12,15 +13,15 @@
+ TARGET=raop_play
+ DESTDIR =
+
+-CFLAGS=-Wall
++CFLAGS=-Wall -I$(prefix)/include/
+ OBJS := raop_play.o raop_client.o rtsp_client.o aexcl_lib.o base64.o aes.o m4a_stream.o \
+ audio_stream.o wav_stream.o mp3_stream.o flac_stream.o ogg_stream.o aac_stream.o pls_stream.o \
+-pcm_stream.o flac_stream.o
++pcm_stream.o flac_stream.o ../rendezvous/getline.o
+
+ all: $(TARGET)
+
+ raop_play: $(OBJS)
+- $(CC) -o $@ -lssl -lsamplerate -lid3tag $^
++ $(CC) -o $@ $(LDFLAGS) -lssl -lsamplerate -lid3tag $^
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(bindir)/
diff --git a/audio/raop_play/files/patch-raop_play-aac_stream.c b/audio/raop_play/files/patch-raop_play-aac_stream.c
new file mode 100644
index 000000000000..15a08a7d82b3
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-aac_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/aac_stream.c~ Thu Jul 28 04:43:16 2005
++++ raop_play/aac_stream.c Fri Aug 12 09:48:37 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
diff --git a/audio/raop_play/files/patch-raop_play-aexcl_lib.h b/audio/raop_play/files/patch-raop_play-aexcl_lib.h
new file mode 100644
index 000000000000..9b08e7baf5db
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-aexcl_lib.h
@@ -0,0 +1,19 @@
+--- raop_play/aexcl_lib.h~ Thu Jul 28 04:43:17 2005
++++ raop_play/aexcl_lib.h Fri Aug 12 09:28:23 2005
+@@ -1,5 +1,5 @@
+ #include <stdio.h>
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <sys/time.h>
+ #include <time.h>
+ #include <stdlib.h>
+@@ -35,6 +35,9 @@
+ #define END_C_DECLS
+ #endif
+
++#define __u8 u_int8_t
++#define __u16 u_int16_t
++#define __u32 u_int32_t
+
+ BEGIN_C_DECLS
+
diff --git a/audio/raop_play/files/patch-raop_play-audio_stream.c b/audio/raop_play/files/patch-raop_play-audio_stream.c
new file mode 100644
index 000000000000..4efb2d4c1399
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-audio_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/audio_stream.c~ Thu Jul 28 04:43:17 2005
++++ raop_play/audio_stream.c Fri Aug 12 09:42:04 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <stdlib.h>
diff --git a/audio/raop_play/files/patch-raop_play-flac_streams.c b/audio/raop_play/files/patch-raop_play-flac_streams.c
new file mode 100644
index 000000000000..ccace8aaa8a8
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-flac_streams.c
@@ -0,0 +1,11 @@
+--- raop_play/flac_stream.c~ Fri Dec 16 23:17:02 2005
++++ raop_play/flac_stream.c Wed Jul 5 16:01:58 2006
+@@ -18,7 +18,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+ #include <netinet/in.h>
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
diff --git a/audio/raop_play/files/patch-raop_play-m4a_stream.c b/audio/raop_play/files/patch-raop_play-m4a_stream.c
new file mode 100644
index 000000000000..56780a212d64
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-m4a_stream.c
@@ -0,0 +1,10 @@
+--- raop_play/m4a_stream.c~ Thu Jul 28 04:43:17 2005
++++ raop_play/m4a_stream.c Fri Aug 12 09:32:06 2005
+@@ -20,7 +20,6 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <asm/types.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/audio/raop_play/files/patch-raop_play-mp3_stream.c b/audio/raop_play/files/patch-raop_play-mp3_stream.c
new file mode 100644
index 000000000000..dd26c8805b6c
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-mp3_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/mp3_stream.c~ Thu Jul 28 04:43:18 2005
++++ raop_play/mp3_stream.c Fri Aug 12 09:47:58 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <sys/wait.h>
diff --git a/audio/raop_play/files/patch-raop_play-ogg_stream.c b/audio/raop_play/files/patch-raop_play-ogg_stream.c
new file mode 100644
index 000000000000..ed40d0d22512
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-ogg_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/ogg_stream.c~ Thu Jul 28 04:43:18 2005
++++ raop_play/ogg_stream.c Fri Aug 12 09:48:20 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
diff --git a/audio/raop_play/files/patch-raop_play-pcm_streams.c b/audio/raop_play/files/patch-raop_play-pcm_streams.c
new file mode 100644
index 000000000000..964b5ecbe33b
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-pcm_streams.c
@@ -0,0 +1,11 @@
+--- raop_play/pcm_stream.c~ Fri Dec 16 23:17:01 2005
++++ raop_play/pcm_stream.c Wed Jul 5 16:02:29 2006
+@@ -19,7 +19,7 @@
+ *****************************************************************************/
+ #include <unistd.h>
+ #include <fcntl.h>
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <sys/poll.h>
+ #define PCM_STREAM_C_
diff --git a/audio/raop_play/files/patch-raop_play-pls_stream.c b/audio/raop_play/files/patch-raop_play-pls_stream.c
new file mode 100644
index 000000000000..7fbb2453c6ce
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-pls_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/pls_stream.c~ Thu Jul 28 04:43:18 2005
++++ raop_play/pls_stream.c Fri Aug 12 09:48:57 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ #include <unistd.h>
diff --git a/audio/raop_play/files/patch-raop_play-raop_client.c b/audio/raop_play/files/patch-raop_play-raop_client.c
new file mode 100644
index 000000000000..635bfee4a6d3
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-raop_client.c
@@ -0,0 +1,29 @@
+--- raop_play/raop_client.c.orig Thu Jul 28 04:43:18 2005
++++ raop_play/raop_client.c Fri Aug 12 09:31:35 2005
+@@ -24,7 +24,7 @@
+ #include <openssl/rsa.h>
+ #include <openssl/engine.h>
+
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include "aexcl_lib.h"
+ #include "rtsp_client.h"
+ #include "raop_client.h"
+@@ -87,7 +87,7 @@
+ return size;
+ }
+
+-static int encrypt(raopcl_data_t *raopcld, __u8 *data, int size)
++static int raop_encrypt(raopcl_data_t *raopcld, __u8 *data, int size)
+ {
+ __u8 *buf;
+ //__u8 tmp[16];
+@@ -222,7 +222,7 @@
+ raopcld->data[2]=len>>8;
+ raopcld->data[3]=len&0xff;
+ memcpy(raopcld->data+header_size,sample,count);
+- encrypt(raopcld, raopcld->data+header_size, count);
++ raop_encrypt(raopcld, raopcld->data+header_size, count);
+ len=count+header_size;
+ raopcld->wblk_remsize=count+header_size;
+ raopcld->wblk_wsize=0;
diff --git a/audio/raop_play/files/patch-raop_play-wav_stream.c b/audio/raop_play/files/patch-raop_play-wav_stream.c
new file mode 100644
index 000000000000..555d3217d886
--- /dev/null
+++ b/audio/raop_play/files/patch-raop_play-wav_stream.c
@@ -0,0 +1,11 @@
+--- raop_play/wav_stream.c~ Thu Jul 28 04:43:19 2005
++++ raop_play/wav_stream.c Fri Aug 12 09:47:15 2005
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ *****************************************************************************/
+-#include <asm/types.h>
++#include <sys/types.h>
+ #include <stdio.h>
+ #define WAV_STREAM_C
+ #include "audio_stream.h"
diff --git a/audio/raop_play/files/patch-rendezvous-Client.c b/audio/raop_play/files/patch-rendezvous-Client.c
new file mode 100644
index 000000000000..e218c98d3c18
--- /dev/null
+++ b/audio/raop_play/files/patch-rendezvous-Client.c
@@ -0,0 +1,13 @@
+--- rendezvous/Client.c.orig Fri Dec 16 23:17:02 2005
++++ rendezvous/Client.c Wed Jul 5 16:32:45 2006
+@@ -83,8 +83,9 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <asm/types.h>
++#include <sys/types.h>
+
++#include "getline.h"
+ #include "mDNSClientAPI.h"// Defines the interface to the mDNS core code
+ #include "mDNSPosix.h" // Defines the specific types needed to run mDNS on this platform
+ #include "ExampleClientApp.h"
diff --git a/audio/raop_play/files/patch-rendezvous-Makefile.in b/audio/raop_play/files/patch-rendezvous-Makefile.in
new file mode 100644
index 000000000000..ae852061d196
--- /dev/null
+++ b/audio/raop_play/files/patch-rendezvous-Makefile.in
@@ -0,0 +1,30 @@
+--- rendezvous/Makefile.in.orig Fri Dec 16 23:17:02 2005
++++ rendezvous/Makefile.in Thu Jul 6 16:40:26 2006
+@@ -1,6 +1,7 @@
+ SHELL = @SHELL@
+ CC = @CC@
+ DEFS = @DEFS@
++LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+@@ -9,7 +10,7 @@
+ top_srcdir = @top_srcdir@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+-CFLAGS += -Wall -DNOT_HAVE_SA_LEN
++CFLAGS += -Wall
+
+ TARGET = mDNSClient
+ DESTDIR =
+@@ -17,8 +18,8 @@
+ all: $(TARGET)
+
+
+-mDNSClient: mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o
+- $(CC) $(LFLAGS) $^ -o $@
++mDNSClient: mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o getline.o
++ $(CC) $(LDFLAGS) mDNSPosix.o mDNSUNP.o ExampleClientApp.o mDNS.o Client.o getline.o -o $@
+
+ install:
+ $(mkinstalldirs) $(DESTDIR)$(bindir)/
diff --git a/audio/raop_play/files/patch-rendezvous-mDNS.c b/audio/raop_play/files/patch-rendezvous-mDNS.c
new file mode 100644
index 000000000000..cb3349040f10
--- /dev/null
+++ b/audio/raop_play/files/patch-rendezvous-mDNS.c
@@ -0,0 +1,11 @@
+--- rendezvous/mDNS.c- Fri Aug 12 09:08:40 2005
++++ rendezvous/mDNS.c Fri Aug 12 09:09:07 2005
+@@ -1139,7 +1139,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
+-#include <asm/types.h>
++#include <sys/types.h>
+
+ static const struct mDNSprintf_format
+ {
diff --git a/audio/raop_play/pkg-descr b/audio/raop_play/pkg-descr
new file mode 100644
index 000000000000..02335d8286c2
--- /dev/null
+++ b/audio/raop_play/pkg-descr
@@ -0,0 +1,10 @@
+raop_play is a music file player for Apple Airport Express,
+the main functionalities are as follows:
+
+* Discover Airport Express by Apple Rendezvous
+* Browse music files
+ (Supported music file format: m4a(alac or aac), wav, mp3, ogg, aac, pls)
+* Send selected files to the Airport Express
+* Play mp3 stream data (filename started with "http://")
+
+WWW: http://raop-play.sourceforge.net/