aboutsummaryrefslogtreecommitdiff
path: root/audio/rat/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-04-06 02:26:09 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-04-06 02:26:09 +0000
commit09ea07bb8deef8729870322145b800367364d4cd (patch)
tree6154b91a53024c19b7792fd25212cc1ba921c9be /audio/rat/Makefile
parent37fdb9d2246fc462d19b8005a35b2842852103cf (diff)
downloadports-09ea07bb8deef8729870322145b800367364d4cd.tar.gz
ports-09ea07bb8deef8729870322145b800367364d4cd.zip
Notes
Diffstat (limited to 'audio/rat/Makefile')
-rw-r--r--audio/rat/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/audio/rat/Makefile b/audio/rat/Makefile
index 746885541023..cd715a63ddc4 100644
--- a/audio/rat/Makefile
+++ b/audio/rat/Makefile
@@ -7,7 +7,6 @@
PORTNAME= rat
PORTVERSION= 4.2.13
-
PORTREVISION= 0
CATEGORIES= mbone audio ipv6
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/4.2.13/ \
@@ -23,8 +22,6 @@ USE_GMAKE= yes
MAN1= rat.1
MANCOMPRESSED= no
-PATCH_DEBUG= yes
-
RAT_BUILD_DIRS= common rat
.include <bsd.port.pre.mk>
@@ -42,12 +39,12 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/rat/sdr2.plugin.S02.audio.rtp.*.rat ${LOCALBASE}/etc/sdr/plugins
do-build:
- for d in ${RAT_BUILD_DIRS}; do \
- cd ${WRKSRC}/$$d && ${GMAKE}; \
- done
+.for d in ${RAT_BUILD_DIRS}
+ cd ${WRKSRC}/${d} && ${GMAKE}
+.endfor
do-configure:
- cd ${WRKSRC}/common && autoconf && ./configure ${ENABLE_IPv6}
- cd ${WRKSRC}/rat && autoconf && ./configure --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE} ${ENABLE_IPv6}
+ cd ${WRKSRC}/common && autoconf && ./configure ${CONFIGURE_ARGS} ${ENABLE_IPv6}
+ cd ${WRKSRC}/rat && autoconf && ./configure ${CONFIGURE_ARGS} --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE} ${ENABLE_IPv6}
.include "bsd.port.post.mk"