aboutsummaryrefslogtreecommitdiff
path: root/audio/raul
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-11-16 15:48:41 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-11-16 15:48:41 +0000
commit50f7a038332b70e32847d0c11c6d45add678a958 (patch)
tree8cb0d550f3c0ee8b4adc2e8759ce9abddb880a07 /audio/raul
parent8059cba5b6c6fc690d61bc82256a9a09aadc8a35 (diff)
downloadports-50f7a038332b70e32847d0c11c6d45add678a958.tar.gz
ports-50f7a038332b70e32847d0c11c6d45add678a958.zip
Notes
Diffstat (limited to 'audio/raul')
-rw-r--r--audio/raul/Makefile27
-rw-r--r--audio/raul/distinfo3
-rw-r--r--audio/raul/files/patch-raul-AtomicInt.hpp65
-rw-r--r--audio/raul/files/patch-raul-AtomicPtr.hpp28
-rw-r--r--audio/raul/pkg-descr6
-rw-r--r--audio/raul/pkg-plist43
6 files changed, 172 insertions, 0 deletions
diff --git a/audio/raul/Makefile b/audio/raul/Makefile
new file mode 100644
index 000000000000..8677fb05f217
--- /dev/null
+++ b/audio/raul/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: raul
+# Date created: 2008-07-22
+# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= raul
+PORTVERSION= 0.5.1
+CATEGORIES= audio
+MASTER_SITES= http://download.drobilla.net/
+
+MAINTAINER= trasz@FreeBSD.org
+COMMENT= C++ utility library primarily aimed at audio/musical applications
+
+LIB_DEPENDS= boost_date_time.4:${PORTSDIR}/devel/boost \
+ jack.0:${PORTSDIR}/audio/jack \
+ lash.2:${PORTSDIR}/audio/lash \
+ glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+CONFIGURE_ENV= "CXXFLAGS=${CFLAGS} -I${LOCALBASE}/include"
+
+.include <bsd.port.mk>
diff --git a/audio/raul/distinfo b/audio/raul/distinfo
new file mode 100644
index 000000000000..3b805bf18c53
--- /dev/null
+++ b/audio/raul/distinfo
@@ -0,0 +1,3 @@
+MD5 (raul-0.5.1.tar.gz) = 509e5bb44fa3750920964357528451c4
+SHA256 (raul-0.5.1.tar.gz) = e82c3b8f95c13fedc83430f6b70e588304fe9bf04eb4b17758be914bbd0f79a0
+SIZE (raul-0.5.1.tar.gz) = 391193
diff --git a/audio/raul/files/patch-raul-AtomicInt.hpp b/audio/raul/files/patch-raul-AtomicInt.hpp
new file mode 100644
index 000000000000..3af6024517a8
--- /dev/null
+++ b/audio/raul/files/patch-raul-AtomicInt.hpp
@@ -0,0 +1,65 @@
+--- raul/AtomicInt.hpp.orig 2008-11-16 16:23:19.000000000 +0100
++++ raul/AtomicInt.hpp 2008-11-16 16:32:45.000000000 +0100
+@@ -27,22 +27,22 @@
+ public:
+
+ inline AtomicInt(int val)
+- { g_atomic_int_set(&_val, val); }
++ { g_atomic_int_set((volatile gint *)&_val, (gint)val); }
+
+ inline AtomicInt(const AtomicInt& copy)
+- { g_atomic_int_set(&_val, copy.get()); }
++ { g_atomic_int_set((volatile gint *)&_val, (gint)copy.get()); }
+
+ inline int get() const
+- { return g_atomic_int_get(&_val); }
++ { return g_atomic_int_get((volatile gint *)&_val); }
+
+ inline void operator=(int val)
+- { g_atomic_int_set(&_val, val); }
++ { g_atomic_int_set((volatile gint *)&_val, (gint)val); }
+
+ inline void operator+=(int val)
+- { g_atomic_int_add(&_val, val); }
++ { g_atomic_int_add((volatile gint *)&_val, (gint)val); }
+
+ inline void operator-=(int val)
+- { g_atomic_int_add(&_val, -val); }
++ { g_atomic_int_add((volatile gint *)&_val, (gint)-val); }
+
+ inline bool operator==(int val) const
+ { return get() == val; }
+@@ -51,28 +51,28 @@
+ { return get() + val; }
+
+ inline AtomicInt& operator++() // prefix
+- { g_atomic_int_inc(&_val); return *this; }
++ { g_atomic_int_inc((volatile gint *)&_val); return *this; }
+
+ inline AtomicInt& operator--() // prefix
+- { g_atomic_int_add(&_val, -1); return *this; }
++ { g_atomic_int_add((volatile gint *)&_val, -1); return *this; }
+
+ /** Set value to newval iff current value is oldval.
+ * @return whether set succeeded.
+ */
+ inline bool compare_and_exchange(int oldval, int newval)
+- { return g_atomic_int_compare_and_exchange(&_val, oldval, newval); }
++ { return g_atomic_int_compare_and_exchange((volatile gint *)&_val, (gint)oldval, (gint)newval); }
+
+ /** Add val to value.
+ * @return value immediately before addition took place.
+ */
+ inline int exchange_and_add(int val)
+- { return g_atomic_int_exchange_and_add(&_val, val); }
++ { return g_atomic_int_exchange_and_add((volatile gint *)&_val, (gint)val); }
+
+ /** Decrement value.
+ * @return true if value is now 0, otherwise false.
+ */
+ inline bool decrement_and_test()
+- { return g_atomic_int_dec_and_test(&_val); }
++ { return g_atomic_int_dec_and_test((gint *)&_val); }
+
+ private:
+ volatile int _val;
diff --git a/audio/raul/files/patch-raul-AtomicPtr.hpp b/audio/raul/files/patch-raul-AtomicPtr.hpp
new file mode 100644
index 000000000000..f8a33b63819f
--- /dev/null
+++ b/audio/raul/files/patch-raul-AtomicPtr.hpp
@@ -0,0 +1,28 @@
+--- raul/AtomicPtr.hpp.orig 2008-11-16 16:20:09.000000000 +0100
++++ raul/AtomicPtr.hpp 2008-11-16 16:23:06.000000000 +0100
+@@ -28,20 +28,20 @@
+ public:
+
+ inline AtomicPtr()
+- { g_atomic_pointer_set(&_val, NULL); }
++ { g_atomic_pointer_set((volatile gpointer *)&_val, NULL); }
+
+ inline AtomicPtr(const AtomicPtr& copy)
+- { g_atomic_pointer_set(&_val, copy.get()); }
++ { g_atomic_pointer_set((volatile gpointer *)&_val, (gpointer)copy.get()); }
+
+ inline T* get() const
+- { return (T*)g_atomic_pointer_get(&_val); }
++ { return (T*)g_atomic_pointer_get((volatile gpointer *)&_val); }
+
+ inline void operator=(T* val)
+- { g_atomic_pointer_set(&_val, val); }
++ { g_atomic_pointer_set((volatile gpointer *)&_val, (gpointer)val); }
+
+ /** Set value to newval iff current value is oldval */
+ inline bool compare_and_exchange(int oldval, int newval)
+- { return g_atomic_pointer_compare_and_exchange(&_val, oldval, newval); }
++ { return g_atomic_pointer_compare_and_exchange((volatile gpointer *)&_val, oldval, newval); }
+
+ private:
+ volatile T* _val;
diff --git a/audio/raul/pkg-descr b/audio/raul/pkg-descr
new file mode 100644
index 000000000000..7e8650873dcb
--- /dev/null
+++ b/audio/raul/pkg-descr
@@ -0,0 +1,6 @@
+Raul (Realtime Audio Utility Library) is a C++ utility library
+primarily aimed at audio/musical applications.
+
+It is used by Ingen, Patchage, and Machina.
+
+WWW: http://wiki.drobilla.net/Raul
diff --git a/audio/raul/pkg-plist b/audio/raul/pkg-plist
new file mode 100644
index 000000000000..3cb761909dd6
--- /dev/null
+++ b/audio/raul/pkg-plist
@@ -0,0 +1,43 @@
+include/raul/Array.hpp
+include/raul/Atom.hpp
+include/raul/AtomicInt.hpp
+include/raul/AtomicPtr.hpp
+include/raul/AtomLiblo.hpp
+include/raul/AtomRDF.hpp
+include/raul/Command.hpp
+include/raul/Deletable.hpp
+include/raul/DoubleBuffer.hpp
+include/raul/EventRingBuffer.hpp
+include/raul/JackDriver.hpp
+include/raul/List.hpp
+include/raul/ListImpl.hpp
+include/raul/lv2_event.h
+include/raul/Maid.hpp
+include/raul/midi_events.h
+include/raul/midi_names.h
+include/raul/MIDISink.hpp
+include/raul/Path.hpp
+include/raul/PathTable.hpp
+include/raul/Process.hpp
+include/raul/Quantizer.hpp
+include/raul/RingBuffer.hpp
+include/raul/Semaphore.hpp
+include/raul/SharedPtr.hpp
+include/raul/Slave.hpp
+include/raul/SMFReader.hpp
+include/raul/SMFWriter.hpp
+include/raul/SRMWQueue.hpp
+include/raul/SRSWQueue.hpp
+include/raul/Stateful.hpp
+include/raul/Symbol.hpp
+include/raul/Table.hpp
+include/raul/TableImpl.hpp
+include/raul/Thread.hpp
+include/raul/TimeSlice.hpp
+include/raul/TimeStamp.hpp
+include/raul/WeakPtr.hpp
+@dirrm include/raul
+lib/libraul.so.2
+lib/libraul.so
+lib/libraul.la
+libdata/pkgconfig/raul.pc