aboutsummaryrefslogtreecommitdiff
path: root/audio/rebler
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-04 22:43:38 +0000
commit93872f18cc0a948ab9c010bbe5694579bd59f8c4 (patch)
tree918c0e1660ed837a4087b57670a1b1c181c285e0 /audio/rebler
parentd7568468f977aa272698f2ab9e7164f2a52b0ad5 (diff)
downloadports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.tar.gz
ports-93872f18cc0a948ab9c010bbe5694579bd59f8c4.zip
Notes
Diffstat (limited to 'audio/rebler')
-rw-r--r--audio/rebler/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/rebler/Makefile b/audio/rebler/Makefile
index f8fb6cd2541c..b1b8645dd30b 100644
--- a/audio/rebler/Makefile
+++ b/audio/rebler/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
aviplay.0:${PORTSDIR}/multimedia/avifile \
popt:${PORTSDIR}/devel/popt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
USE_BZIP2= yes
AVIFILE_CONFIG?= ${LOCALBASE}/bin/avifile-config
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
@@ -32,6 +26,12 @@ CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
LIBS+= -L${LOCALBASE}/lib -lm -lmpeg2 ${PTHREAD_LIBS} \
`${AVIFILE_CONFIG} --libs` -lpopt
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
do-build:
@(cd ${WRKSRC} ; \
${CXX} ${CXXFLAGS} rebler.cpp -o rebler ${LIBS})