aboutsummaryrefslogtreecommitdiff
path: root/audio/rezound
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-09 20:20:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-09 20:20:51 +0000
commit03fa6838a410ff227ee3d3d421c24b110f1653da (patch)
tree60491c7d1d6379cbf9f2770bfc84f6a05f320852 /audio/rezound
parent1a59abafcf3a70f8d70240da56d39c75e40190e3 (diff)
downloadports-03fa6838a410ff227ee3d3d421c24b110f1653da.tar.gz
ports-03fa6838a410ff227ee3d3d421c24b110f1653da.zip
Notes
Diffstat (limited to 'audio/rezound')
-rw-r--r--audio/rezound/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 3a65b2a12f8a..38e058b58b41 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -14,26 +14,28 @@ MASTER_SITES= SF/${PORTNAME}/ReZound/${DISTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Graphical audio file editor
+LICENSE= GPLv2
+
LIB_DEPENDS= FOX-1.4:${PORTSDIR}/x11-toolkits/fox14
USE_BISON= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --disable-alsa
+CONFIGURE_ARGS= --disable-alsa
OPTIONS= LARGEFILE "Enable 64-bit I/O support (not yet!)" off \
- JACK "Enable Jack audio server support" on \
+ JACK "Enable Jack audio server support" off \
AUDIOFILE "Enable Audio File Library support" on \
PORTAUDIO "Enable PortAudio support" on \
OGG "Enable OGG support" on \
VORBIS "Enable Vorbis support" on \
FLAC "Enable FLAC support" on \
- FFTW "Enable FFTW support" on \
+ FFTW "Enable FFTW support" off \
SOUNDTOUCH "Enable SoundTouch features" on \
LADSPA "Enable LADSPA plugin support" on \
- LAME "Enable loading and saving MP3s" on \
- CDRDAO "Enable burning audio files to CD" on \
- NLS "Enable National Language Support" on
+ LAME "Enable loading and saving MP3 files" on \
+ CDRDAO "Enable burning audio files to CD" off \
+ NLS "Enable Native Language Support" on
.include <bsd.port.pre.mk>
@@ -104,9 +106,8 @@ PLIST_SUB+= NLS="@comment "
.endif
post-patch: .SILENT
- ${REINPLACE_CMD} -e '/atoll/d' ${WRKSRC}/config/platform/bsd.h
- ${REINPLACE_CMD} -e '/round/d' ${WRKSRC}/config/platform/bsd.h
- ${REINPLACE_CMD} -e '/nearbyint/d' ${WRKSRC}/config/platform/bsd.h
+ ${REINPLACE_CMD} -E '/atoll|round|nearbyint/d' \
+ ${WRKSRC}/config/platform/bsd.h
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...), ; \
/^C(XX)?FLAGS=/d ; /CXXFLAGS="\$$CXXFLAGS -[gW]/d' \
${WRKSRC}/configure