aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox-devel/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-16 20:53:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-16 20:53:40 +0000
commit72496a9db63e7b10d371dc52dc7f7752a6e7822b (patch)
treeea7c0d4675a7547b1e3886068bd5596ef20fc981 /audio/rhythmbox-devel/Makefile
parent9bc99a0f52f704410466799c5903c32e698c6434 (diff)
Notes
Diffstat (limited to 'audio/rhythmbox-devel/Makefile')
-rw-r--r--audio/rhythmbox-devel/Makefile43
1 files changed, 26 insertions, 17 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index b0b64073a817..e5abed943edd 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -6,16 +6,13 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.10
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= audio gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= rhythmbox \
- sources/${PORTNAME}/0.6
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.8
DIST_SUBDIR= gnome2
-MAINTAINER= marcus@FreeBSD.org
+MAINTAINER= marcus@freebsd.org
COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
@@ -23,22 +20,39 @@ LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
mad.2:${PORTSDIR}/audio/libmad \
id3tag.2:${PORTSDIR}/audio/libid3tag
-#USE_BZIP2= yes
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix libgnomeui
-USE_LIBTOOL_VER= 13
+USE_GNOME= gnomehack intlhack lthack gnomeprefix libgnomeui
+USE_LIBTOOL_VER=13
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+OPTIONS= XINE "Use xine backend instead of GStreamer" off \
+ MONKEYMEDIA "Use MonkeyMedia metadata reader" off \
+ IPOD "Enable iPod support" off
+
+.include <bsd.port.pre.mk>
+
.ifdef (WITH_XINE)
LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
-CONFIGURE_ARGS+= --enable-xine
+CONFIGURE_ARGS+= --with-player=xine
+WITH_MONKEYMEDIA= yes
.else
+CONFIGURE_ARGS+= --with-player=gstreamer
USE_GNOME+= gstreamerplugins
.endif
-.include <bsd.port.pre.mk>
+.ifdef (WITH_MONKEYMEDIA)
+CONFIGURE_ARGS+= --with-metadata=monkeymedia
+.else
+CONFIGURE_ARGS+= --with-metadata=gstreamer
+USE_GNOME+= gstreamerplugins
+.endif
+
+.ifdef (WITH_IPOD)
+CONFIGURE_ARGS+= --enable-ipod
+.endif
.if exists(${LOCALBASE}/lib/libvorbis.so)
WITH_VORBIS= yes
@@ -61,10 +75,5 @@ pre-everything::
@${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
@${ECHO_MSG}
.endif
-.if !defined(WITH_XINE)
- @${ECHO_MSG}
- @${ECHO_MSG} "Define WITH_XINE to use xine backend instead of gstreamer"
- @${ECHO_MSG}
-.endif
.include <bsd.port.post.mk>