aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /audio/rhythmbox
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
Notes
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile6
-rw-r--r--audio/rhythmbox/files/patch-remote_dbus_rb-client.c38
2 files changed, 41 insertions, 3 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index fda731c22eb7..2bd4be2bc162 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/audio/rhythmbox/Makefile,v 1.107 2010/04/08 23:16:25 kwm Exp $
+# $MCom: ports/audio/rhythmbox/Makefile,v 1.111 2010/09/28 15:55:46 kwm Exp $
#
PORTNAME= rhythmbox
PORTVERSION= 0.12.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -25,7 +25,7 @@ LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
sexy.2:${PORTSDIR}/x11-toolkits/libsexy \
soup-2.4.1:${PORTSDIR}/devel/libsoup \
gnome-media-profiles.0:${PORTSDIR}/audio/gnome-media \
- brasero-media.2:${PORTSDIR}/sysutils/brasero
+ brasero-media.3:${PORTSDIR}/sysutils/brasero
USE_BZIP2= yes
USE_GETTEXT= yes
diff --git a/audio/rhythmbox/files/patch-remote_dbus_rb-client.c b/audio/rhythmbox/files/patch-remote_dbus_rb-client.c
new file mode 100644
index 000000000000..c73cde0dcc11
--- /dev/null
+++ b/audio/rhythmbox/files/patch-remote_dbus_rb-client.c
@@ -0,0 +1,38 @@
+--- remote/dbus/rb-client.c.orig 2010-10-10 11:56:07.000000000 -0400
++++ remote/dbus/rb-client.c 2010-10-10 11:57:02.000000000 -0400
+@@ -54,7 +54,7 @@ static gboolean previous = FALSE;
+ static gboolean notify = FALSE;
+
+ static gboolean play = FALSE;
+-static gboolean pause = FALSE;
++static gboolean rbpause = FALSE;
+ static gboolean play_pause = FALSE;
+ static gboolean stop = FALSE;
+
+@@ -91,7 +91,7 @@ static GOptionEntry args[] = {
+ { "notify", 0, 0, G_OPTION_ARG_NONE, &notify, N_("Show notification of the playing song"), NULL },
+
+ { "play", 0, 0, G_OPTION_ARG_NONE, &play, N_("Resume playback if currently paused"), NULL },
+- { "pause", 0, 0, G_OPTION_ARG_NONE, &pause, N_("Pause playback if currently playing"), NULL },
++ { "pause", 0, 0, G_OPTION_ARG_NONE, &rbpause, N_("Pause playback if currently playing"), NULL },
+ { "play-pause", 0, 0, G_OPTION_ARG_NONE, &play_pause, N_("Toggle play/pause mode"), NULL },
+ /* { "stop", 0, 0, G_OPTION_ARG_NONE, &stop, N_("Stop playback"), NULL }, */
+
+@@ -608,7 +608,7 @@ main (int argc, char **argv)
+ if (next || previous ||
+ clear_queue ||
+ play_uri || other_stuff ||
+- play || pause || play_pause || stop ||
++ play || rbpause || play_pause || stop ||
+ print_playing || print_playing_format || notify ||
+ (set_volume > -0.01) || volume_up || volume_down || print_volume || mute || unmute || (set_rating > -0.01))
+ no_present = TRUE;
+@@ -696,7 +696,7 @@ main (int argc, char **argv)
+ org_gnome_Rhythmbox_Player_get_playing (player_proxy, &is_playing, &error);
+ if (!annoy (&error)) {
+ rb_debug ("playback state: %d", is_playing);
+- if (play || pause || play_pause) {
++ if (play || rbpause || play_pause) {
+ if (is_playing != play || play_pause) {
+ rb_debug ("calling playPause to change playback state");
+ org_gnome_Rhythmbox_Player_play_pause (player_proxy, FALSE, &error);