aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-06 04:23:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-02-06 04:23:10 +0000
commit9c2a98b7ec90458c67e5d0c2c9d997cf4419b8a9 (patch)
tree9fecfad263a52b54a76158d34a564c4763371cce /audio/rhythmbox
parentcd5732224d22c134a4a66bf6344ec55650203904 (diff)
downloadports-9c2a98b7ec90458c67e5d0c2c9d997cf4419b8a9.tar.gz
ports-9c2a98b7ec90458c67e5d0c2c9d997cf4419b8a9.zip
Notes
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile2
-rw-r--r--audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c26
-rw-r--r--audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.c17
-rw-r--r--audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.h13
4 files changed, 55 insertions, 3 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index e9912b3ee580..30a75205d8f2 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -8,7 +8,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.12.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c b/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c
index 923a00e94618..831777c0f789 100644
--- a/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c
+++ b/audio/rhythmbox/files/patch-plugins_status-icon_rb-status-icon-plugin.c
@@ -1,5 +1,5 @@
---- plugins/status-icon/rb-status-icon-plugin.c.orig 2011-08-21 21:46:27.000000000 +0200
-+++ plugins/status-icon/rb-status-icon-plugin.c 2011-08-21 21:46:43.000000000 +0200
+--- plugins/status-icon/rb-status-icon-plugin.c.orig 2010-03-24 20:10:13.000000000 -0400
++++ plugins/status-icon/rb-status-icon-plugin.c 2012-02-05 23:19:58.000000000 -0500
@@ -394,7 +394,7 @@ do_notify (RBStatusIconPlugin *plugin,
icon_name = NULL;
@@ -9,3 +9,25 @@
g_signal_connect_object (plugin->priv->notification,
"closed",
+@@ -405,21 +405,6 @@ do_notify (RBStatusIconPlugin *plugin,
+ notify_notification_update (plugin->priv->notification, primary, secondary, icon_name);
+ }
+
+- switch (plugin->priv->icon_mode) {
+- case ICON_NEVER:
+- break;
+-
+- case ICON_WITH_NOTIFY:
+- case ICON_ALWAYS:
+- case ICON_OWNS_WINDOW:
+- rb_tray_icon_attach_notification (plugin->priv->tray_icon,
+- plugin->priv->notification);
+- break;
+-
+- default:
+- g_assert_not_reached ();
+- }
+-
+ notify_notification_set_timeout (plugin->priv->notification, timeout);
+
+ if (pixbuf != NULL) {
diff --git a/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.c b/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.c
new file mode 100644
index 000000000000..2ed986982a87
--- /dev/null
+++ b/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.c
@@ -0,0 +1,17 @@
+--- plugins/status-icon/rb-tray-icon-gtk.c.orig 2012-02-05 23:21:11.000000000 -0500
++++ plugins/status-icon/rb-tray-icon-gtk.c 2012-02-05 23:21:24.000000000 -0500
+@@ -339,14 +339,6 @@ rb_tray_icon_is_embedded (RBTrayIcon *tr
+ return gtk_status_icon_is_embedded (tray->priv->icon);
+ }
+
+-#if defined(HAVE_NOTIFY)
+-void
+-rb_tray_icon_attach_notification (RBTrayIcon *tray, NotifyNotification *notification)
+-{
+- notify_notification_attach_to_status_icon (notification, tray->priv->icon);
+-}
+-#endif
+-
+ void
+ rb_tray_icon_set_visible (RBTrayIcon *tray, gboolean visible)
+ {
diff --git a/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.h b/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.h
new file mode 100644
index 000000000000..e71f2dd90240
--- /dev/null
+++ b/audio/rhythmbox/files/patch-plugins_status-icon_rb-tray-icon-gtk.h
@@ -0,0 +1,13 @@
+--- plugins/status-icon/rb-tray-icon-gtk.h.orig 2012-02-05 23:22:03.000000000 -0500
++++ plugins/status-icon/rb-tray-icon-gtk.h 2012-02-05 23:22:11.000000000 -0500
+@@ -74,10 +74,6 @@ gboolean rb_tray_icon_is_embedded (RBTr
+
+ void rb_tray_icon_menu_popup (RBTrayIcon *icon, GtkWidget *popup, gint button);
+
+-#if defined(HAVE_NOTIFY)
+-void rb_tray_icon_attach_notification (RBTrayIcon *icon, NotifyNotification *notification);
+-#endif
+-
+ void rb_tray_icon_set_visible (RBTrayIcon *icon, gboolean visible);
+
+ G_END_DECLS