aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-21 16:28:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-21 16:28:09 +0000
commit411e705cb2bf1c01f0eb60c437ba210eaac5a2f2 (patch)
tree763f71c3d3ab5f5f1e04583769b1fdd2970e3749 /audio/rhythmbox
parent419c6e665a9918936db48ae764966a134bbab796 (diff)
downloadports-411e705cb2bf1c01f0eb60c437ba210eaac5a2f2.tar.gz
ports-411e705cb2bf1c01f0eb60c437ba210eaac5a2f2.zip
Notes
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index b7f03ab3bca9..1ba4c99b4cd9 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= marcus@freebsd.org
COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/libmusicbrainz \
- gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins \
FLAC.5:${PORTSDIR}/audio/flac \
mad.1:${PORTSDIR}/audio/mad
@@ -40,11 +39,23 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --disable-vorbistest
.endif
+.ifdef (WITH_XINE)
+LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+= --enable-xine
+.else
+LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+.endif
+
pre-everything::
.if !defined(WITH_VORBIS)
@${ECHO_MSG}
@${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
@${ECHO_MSG}
.endif
+.if !defined(WITH_XINE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Define WITH_XINE to use xine backend instead of gstreamer"
+ @${ECHO_MSG}
+.endif
.include <bsd.port.post.mk>