aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 03:57:35 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-07 03:57:35 +0000
commitbf6aa6da7c4cc3c67c931dabce9b48f10ab96e92 (patch)
tree190752df23d08dcc21ba01fa6391517b2468a625 /audio/rhythmbox
parentcc6500205b23fce27fe741c90fd490cc4d166e9a (diff)
downloadports-bf6aa6da7c4cc3c67c931dabce9b48f10ab96e92.tar.gz
ports-bf6aa6da7c4cc3c67c931dabce9b48f10ab96e92.zip
Notes
Diffstat (limited to 'audio/rhythmbox')
-rw-r--r--audio/rhythmbox/Makefile21
-rw-r--r--audio/rhythmbox/distinfo2
-rw-r--r--audio/rhythmbox/files/patch-lib_rb-tree-dnd.c26
-rw-r--r--audio/rhythmbox/files/patch-shell_Makefile.in10
-rw-r--r--audio/rhythmbox/pkg-plist1
5 files changed, 23 insertions, 37 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index 77cae8ddb7d0..02386c823892 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= rhythmbox
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 0.6.1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -18,7 +17,8 @@ COMMENT= Audio player for the Gnome 2 desktop environment
LIB_DEPENDS= musicbrainz.3:${PORTSDIR}/audio/libmusicbrainz \
FLAC.5:${PORTSDIR}/audio/flac \
- mad.2:${PORTSDIR}/audio/mad
+ mad.2:${PORTSDIR}/audio/libmad \
+ id3tag.2:${PORTSDIR}/audio/libid3tag
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -28,6 +28,14 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+.ifdef (WITH_XINE)
+LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
+CONFIGURE_ARGS+= --enable-xine
+.else
+#USE_GNOME+= gstreamerplugins
+LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
+.endif
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libvorbis.so)
@@ -40,13 +48,6 @@ LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --disable-vorbis --disable-vorbistest
.endif
-.ifdef (WITH_XINE)
-LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
-CONFIGURE_ARGS+= --enable-xine
-.else
-LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
-.endif
-
pre-everything::
.if !defined(WITH_XINE)
@${ECHO_MSG}
diff --git a/audio/rhythmbox/distinfo b/audio/rhythmbox/distinfo
index e82342d64f5a..2412d10fff52 100644
--- a/audio/rhythmbox/distinfo
+++ b/audio/rhythmbox/distinfo
@@ -1 +1 @@
-MD5 (gnome2/rhythmbox-0.6.0.tar.bz2) = 4b2f613f3a9f0e66facdc571867093c1
+MD5 (gnome2/rhythmbox-0.6.1.tar.bz2) = 5791f9fb69c9a855d84e1e666b2e86a9
diff --git a/audio/rhythmbox/files/patch-lib_rb-tree-dnd.c b/audio/rhythmbox/files/patch-lib_rb-tree-dnd.c
deleted file mode 100644
index 5ce40a753dd3..000000000000
--- a/audio/rhythmbox/files/patch-lib_rb-tree-dnd.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- lib/rb-tree-dnd.c.orig Tue Nov 11 20:58:54 2003
-+++ lib/rb-tree-dnd.c Tue Nov 11 20:59:17 2003
-@@ -710,9 +710,10 @@
- gint n_targets,
- GdkDragAction actions)
- {
-+ RbTreeDndData *priv_data;
- g_return_if_fail (GTK_IS_TREE_VIEW (tree_view));
-
-- RbTreeDndData *priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-+ priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-
- if (!priv_data->button_press_event_handler) {
-
-@@ -746,9 +747,10 @@
- gint n_targets,
- GdkDragAction actions)
- {
-+ RbTreeDndData *priv_data;
- g_return_if_fail (GTK_IS_TREE_VIEW (tree_view));
-
-- RbTreeDndData *priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-+ priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-
- if (!priv_data->drag_leave_handler) {
-
diff --git a/audio/rhythmbox/files/patch-shell_Makefile.in b/audio/rhythmbox/files/patch-shell_Makefile.in
new file mode 100644
index 000000000000..47028e3f4ca1
--- /dev/null
+++ b/audio/rhythmbox/files/patch-shell_Makefile.in
@@ -0,0 +1,10 @@
+--- shell/Makefile.in.orig Fri Nov 21 22:07:58 2003
++++ shell/Makefile.in Fri Nov 21 22:08:21 2003
+@@ -254,6 +254,7 @@
+ $(top_builddir)/iradio/librbiradio.la \
+ $(top_builddir)/corba/librbcorba.la \
+ $(top_builddir)/monkey-media/libmonkey-media.la \
++ $(ID3TAG_LIBS) \
+ $(RHYTHMBOX_LIBS)
+
+
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
index 7e263f181dbe..3743701324ac 100644
--- a/audio/rhythmbox/pkg-plist
+++ b/audio/rhythmbox/pkg-plist
@@ -114,6 +114,7 @@ share/gnome/rhythmbox/node-views/rb-node-view-songs.xml
share/locale/am/LC_MESSAGES/rhythmbox.mo
share/locale/az/LC_MESSAGES/rhythmbox.mo
share/locale/be/LC_MESSAGES/rhythmbox.mo
+share/locale/ca/LC_MESSAGES/rhythmbox.mo
share/locale/cs/LC_MESSAGES/rhythmbox.mo
share/locale/cy/LC_MESSAGES/rhythmbox.mo
share/locale/da/LC_MESSAGES/rhythmbox.mo