aboutsummaryrefslogtreecommitdiff
path: root/audio/rio
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>1999-03-02 00:07:03 +0000
committerBill Fenner <fenner@FreeBSD.org>1999-03-02 00:07:03 +0000
commit360e18a1237e7f9b1f9dd398e650f941567b8253 (patch)
tree30158aa13a3ca1671ee84ddf42461cdaadb2f562 /audio/rio
parentc0f94b39e736dc1327df32f1309b075c6218f093 (diff)
downloadports-360e18a1237e7f9b1f9dd398e650f941567b8253.tar.gz
ports-360e18a1237e7f9b1f9dd398e650f941567b8253.zip
Notes
Diffstat (limited to 'audio/rio')
-rw-r--r--audio/rio/Makefile26
-rw-r--r--audio/rio/distinfo1
-rw-r--r--audio/rio/files/patch-aa18
-rw-r--r--audio/rio/files/patch-ab40
-rw-r--r--audio/rio/pkg-comment1
-rw-r--r--audio/rio/pkg-descr8
-rw-r--r--audio/rio/pkg-plist1
7 files changed, 95 insertions, 0 deletions
diff --git a/audio/rio/Makefile b/audio/rio/Makefile
new file mode 100644
index 000000000000..21294bbdb509
--- /dev/null
+++ b/audio/rio/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: rio
+# Version required: 1.05
+# Date created: 6 February 1999
+# Whom: Dermot McNally <derm@ibm.net>
+#
+# $Id$
+#
+
+DISTNAME= rio005
+PKGNAME= rio-1.05
+CATEGORIES= audio
+MASTER_SITES= http://www.world.co.uk/sba/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= derm@ibm.net
+
+WRKSRC= ${WRKDIR}/rio
+MAKEFILE= makefile
+
+BINOWN= root
+BINMODE= 4755
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rio ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/rio/distinfo b/audio/rio/distinfo
new file mode 100644
index 000000000000..9eeb55a4c9a8
--- /dev/null
+++ b/audio/rio/distinfo
@@ -0,0 +1 @@
+MD5 (rio005.tgz) = e4d4f77df95d7e850769671908bd6749
diff --git a/audio/rio/files/patch-aa b/audio/rio/files/patch-aa
new file mode 100644
index 000000000000..afd3b1dc93dc
--- /dev/null
+++ b/audio/rio/files/patch-aa
@@ -0,0 +1,18 @@
+*** app.cpp Mon Feb 1 17:55:34 1999
+--- rio.bsd/app.cpp Sat Feb 6 21:00:07 1999
+***************
+*** 27,32 ****
+--- 27,39 ----
+ #include <stdlib.h>
+ #define SIZE_MAXPATH _MAX_PATH
+
++ #elif defined(__FreeBSD__)
++ // FreeBSD g++
++ // (anybody know if this stuff applies more generally to other BSDs?)
++ #include <unistd.h>
++ #include <sys/syslimits.h>
++ #define SIZE_MAXPATH PATH_MAX
++
+ #elif defined(__linux__)
+ // linux g++
+ #include <unistd.h>
diff --git a/audio/rio/files/patch-ab b/audio/rio/files/patch-ab
new file mode 100644
index 000000000000..db6747904778
--- /dev/null
+++ b/audio/rio/files/patch-ab
@@ -0,0 +1,40 @@
+*** rio.cpp Mon Feb 1 17:55:34 1999
+--- rio.bsd/rio.cpp Sat Feb 6 21:00:22 1999
+***************
+*** 49,54 ****
+--- 49,65 ----
+ #define CLOCK_SECOND 1000
+ #define DELETEARRAY delete[]
+
++ #elif defined(__FreeBSD__)
++ // FreeBSD g++
++ // (anybody know if this stuff applies more generally to other BSDs?)
++ #include <fcntl.h>
++ #include <unistd.h>
++ #include <machine/cpufunc.h>
++ #define OUTPORT(p,v) outb( p, v )
++ #define INPORT(p) inb( p )
++ #define CLOCK_SECOND CLOCKS_PER_SEC
++ #define DELETEARRAY delete[]
++
+ #elif defined(__linux__)
+ // linux g++
+ #include <unistd.h>
+***************
+*** 201,206 ****
+--- 212,226 ----
+ m_iPortData = m_iPortBase + OFFSET_PORT_DATA;
+ m_iPortStatus = m_iPortBase + OFFSET_PORT_STATUS;
+ m_iPortControl = m_iPortBase + OFFSET_PORT_CONTROL;
++
++ // if FreeBSD
++ #if defined(__FreeBSD__)
++ // Request direct access to memory addresses
++ if (open("/dev/io", O_RDONLY) < 0) {
++ LogError( CRIO_ERROR_IOPRERM, "open(/dev/io) failed, reason '%s'", SZERROR );
++ return FALSE;
++ }
++ #endif
+
+ // if linux
+ #if defined(__linux__)
diff --git a/audio/rio/pkg-comment b/audio/rio/pkg-comment
new file mode 100644
index 000000000000..09867665579b
--- /dev/null
+++ b/audio/rio/pkg-comment
@@ -0,0 +1 @@
+Tool for transferring files to and from the Diamond Rio .mp3 player
diff --git a/audio/rio/pkg-descr b/audio/rio/pkg-descr
new file mode 100644
index 000000000000..b68914c1f311
--- /dev/null
+++ b/audio/rio/pkg-descr
@@ -0,0 +1,8 @@
+This is a port of the Diamond Rio tool originally written for Linux, Win32 and
+DOS. It consists of a single binary, 'rio', with which you can list those files
+currently on the Rio, transfer files to or from the device, delete files, etc.
+
+http://www.world.co.uk/sba/rio.htm
+
+Dermot McNally
+derm@ibm.net
diff --git a/audio/rio/pkg-plist b/audio/rio/pkg-plist
new file mode 100644
index 000000000000..3e7af1551477
--- /dev/null
+++ b/audio/rio/pkg-plist
@@ -0,0 +1 @@
+bin/rio