aboutsummaryrefslogtreecommitdiff
path: root/audio/rosegarden
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-06-27 18:38:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-06-27 18:38:00 +0000
commit27c357d708637de906a65889206c1db9d492682f (patch)
treea39c5caffcd2d81e1906def78c8532d6b44f9974 /audio/rosegarden
parenta9a4f731513bdc7e03c245def48445b6641a9417 (diff)
downloadports-27c357d708637de906a65889206c1db9d492682f.tar.gz
ports-27c357d708637de906a65889206c1db9d492682f.zip
Notes
Diffstat (limited to 'audio/rosegarden')
-rw-r--r--audio/rosegarden/Makefile42
-rw-r--r--audio/rosegarden/distinfo6
-rw-r--r--audio/rosegarden/files/patch-aa63
-rw-r--r--audio/rosegarden/files/patch-ab19
-rw-r--r--audio/rosegarden/files/patch-ac9
-rw-r--r--audio/rosegarden/files/patch-ad77
-rw-r--r--audio/rosegarden/files/patch-ae11
-rw-r--r--audio/rosegarden/files/patch-ag12
-rw-r--r--audio/rosegarden/files/patch-ah12
-rw-r--r--audio/rosegarden/files/patch-ai33
-rw-r--r--audio/rosegarden/files/patch-aj9
-rw-r--r--audio/rosegarden/files/patch-ak15
-rw-r--r--audio/rosegarden/files/patch-al10
-rw-r--r--audio/rosegarden/files/patch-configure13
-rw-r--r--audio/rosegarden/files/rosegarden2
-rw-r--r--audio/rosegarden/pkg-plist50
16 files changed, 63 insertions, 320 deletions
diff --git a/audio/rosegarden/Makefile b/audio/rosegarden/Makefile
index 2e16ef00d955..55203a94a12a 100644
--- a/audio/rosegarden/Makefile
+++ b/audio/rosegarden/Makefile
@@ -6,33 +6,31 @@
#
PORTNAME= rosegarden
-PORTVERSION= 2.1.2
-PORTREVISION= 3
+PORTVERSION= 10.04.2
CATEGORIES= audio
-MASTER_SITES= http://www.cannam.demon.co.uk/rosegarden/distribution/
-DISTNAME= ${PORTNAME}-2.1pl2
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/10.04/
MAINTAINER= ports@FreeBSD.org
COMMENT= The Rosegarden Editor and Sequencer suite
-BUILD_DEPENDS= ${LOCALBASE}/lib/tclmidi/tclmidi31.so:${PORTSDIR}/audio/tclmidi
-RUN_DEPENDS= ${LOCALBASE}/lib/tclmidi/tclmidi31.so:${PORTSDIR}/audio/tclmidi
+BUILD_DEPENDS= ${LOCALBASE}/lib/tclmidi/tclmidi31.so:${PORTSDIR}/audio/tclmidi \
+ dssi_osc_update:${PORTSDIR}/audio/dssi \
+ makedepend:${PORTSDIR}/devel/makedepend
+RUN_DEPENDS= ${LOCALBASE}/lib/tclmidi/tclmidi31.so:${PORTSDIR}/audio/tclmidi \
+ dssi_osc_update:${PORTSDIR}/audio/dssi
+LIB_DEPENDS+= lrdf.2:${PORTSDIR}/textproc/liblrdf \
+ fftw3.5:${PORTSDIR}/math/fftw3 \
+ fftw3f.5:${PORTSDIR}/math/fftw3-float \
+ asound.2:${PORTSDIR}/audio/alsa-lib
-USE_XORG= xaw
-USE_AUTOTOOLS= autoconf:213
-CONFIGURE_ARGS= --with-tclincl=${LOCALBASE}/include/tcl8.2
-MAKE_JOBS_UNSAFE= yes
-
-post-patch:
- @${CP} ${FILESDIR}/rosegarden ${WRKSRC}/rosegarden.sh
-.for file in Rosegarden rosegarden.sh
- @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
-.endfor
-
-do-install:
- @( \
- cd ${WRKSRC} ; ${SETENV} PREFIX="${PREFIX}" ./do-install \
- )
- ${INSTALL_SCRIPT} ${WRKSRC}/rosegarden.sh ${PREFIX}/bin/rosegarden
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml network corelib sql qt3support \
+ rcc_build moc_build uic_build linguist_build
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= QTLIBDIR=${QT_LIBDIR} LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/audio/rosegarden/distinfo b/audio/rosegarden/distinfo
index 2ad84ace376a..6f9244d6e240 100644
--- a/audio/rosegarden/distinfo
+++ b/audio/rosegarden/distinfo
@@ -1,3 +1,3 @@
-MD5 (rosegarden-2.1pl2.tar.gz) = 994a0d35a68817abc8fa7882d12b4929
-SHA256 (rosegarden-2.1pl2.tar.gz) = cc7cd2e2104043e2f3c228c0a77f6fb50c40a0bf937169cccfd446f5c13f7a31
-SIZE (rosegarden-2.1pl2.tar.gz) = 607980
+MD5 (rosegarden-10.04.2.tar.bz2) = e961a6f1deb2f57c2ed9dd7f1bc71a94
+SHA256 (rosegarden-10.04.2.tar.bz2) = 3bf680fa117553997f476c48b252b50f5ccbc745c9cdfd4d3fb168496b86332f
+SIZE (rosegarden-10.04.2.tar.bz2) = 5909808
diff --git a/audio/rosegarden/files/patch-aa b/audio/rosegarden/files/patch-aa
deleted file mode 100644
index 1a9b6ccb2cf1..000000000000
--- a/audio/rosegarden/files/patch-aa
+++ /dev/null
@@ -1,63 +0,0 @@
---- configure.in.orig Tue Sep 21 11:25:38 1999
-+++ configure.in Tue Nov 30 22:58:02 2004
-@@ -9,8 +9,8 @@
- AC_PROG_LN_S
- AC_PROG_MAKE_SET
- AC_PROG_RANLIB
--dnl Checks for makedepend, uses /bin/true if not found
--AC_PATH_PROG(MAKEDEPEND, makedepend, /bin/true)
-+dnl Checks for makedepend, uses /usr/bin/true if not found
-+AC_PATH_PROG(MAKEDEPEND, makedepend, /usr/bin/true)
-
- AC_CANONICAL_SYSTEM
-
-@@ -67,11 +67,11 @@
-
- Petal=Petal
-
--AC_CHECK_HEADER(tcl.h, TCL_CHECK=1, TCL_CHECK=0)
-+TCL_CHECK=1
-
- if test $TCL_CHECK -eq 1
- then
-- AC_PATH_PROG(TCLSH, tclsh)
-+ AC_PATH_PROG(TCLSH, tclsh8.2)
- if test -n "$TCLSH"
- then
- # Check Tcl version:
-@@ -88,7 +88,7 @@
- then
- # Check for TclMIDI
- AC_CHECKING(if TclMIDI is installed)
-- TCL_MIDI_CHECK=`echo "package require tclmidi" | $TCLSH 2>&1`
-+ TCL_MIDI_CHECK=
- if test -n "$TCL_MIDI_CHECK"
- then
- Petal=""
-@@ -153,7 +153,7 @@
- *freebsd*)
- defines="-DNO_SYS_ERRLIST"
- AC_CHECK_HEADER(machine/soundcard.h, sound_system="-DSYSTEM_OSS")
-- extra_libs="-lmalloc"
-+ # extra_libs="-lmalloc"
- # LDFLAGS="-L/usr/lib -L/usr/X11R6/lib"
-
- PETAL_LD=ld
-@@ -181,6 +181,17 @@
-
- #x_includes="-I$x_includes"
- #x_libraries="-L$x_libraries"
-+
-+AC_MSG_CHECKING(Tcl include Path)
-+AC_ARG_WITH(tclincl,
-+ [ --with-tclincl Set tcl include Path],
-+ with_tclincl=$withval,
-+ with_tclincl=no)
-+AC_MSG_RESULT($with_tclincl)
-+
-+if test "$with_tclincl" != "no"; then
-+ PETAL_CFLAGS="${PETAL_CFLAGS} -I ${with_tclincl}"
-+fi
-
- AC_SUBST(rosegarden)
-
diff --git a/audio/rosegarden/files/patch-ab b/audio/rosegarden/files/patch-ab
deleted file mode 100644
index b88afd03fb63..000000000000
--- a/audio/rosegarden/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- petal/Makefile.in.orig Wed Oct 8 07:40:55 1997
-+++ petal/Makefile.in Thu Dec 14 02:14:42 2000
-@@ -7,13 +7,13 @@
-
- pkgIndex.tcl : Petal.so Petal.tcl
- @echo "The error message for Petal.tcl is normal"
-- echo "pkg_mkIndex . Petal.so Petal.tcl" | tclsh
-+ echo "pkg_mkIndex . Petal.so Petal.tcl" | tclsh8.2
-
- petaleditor/pkgIndex.tcl : petaleditor/PetalEditor.tcl
-- cd petaleditor; make
-+ cd petaleditor; $(MAKE)
-
- petalmidi/pkgIndex.tcl : petalmidi/PetalMidi.tcl
-- cd petalmidi; make
-+ cd petalmidi; $(MAKE)
-
- Petal.so : Petal.o
- $(LD) $(LDFLAGS) Petal.o -o Petal.so
diff --git a/audio/rosegarden/files/patch-ac b/audio/rosegarden/files/patch-ac
deleted file mode 100644
index 8e87a7aaa9ce..000000000000
--- a/audio/rosegarden/files/patch-ac
+++ /dev/null
@@ -1,9 +0,0 @@
---- /tmp/rosegarden-2.1/petal/petaleditor/Makefile Sun Mar 2 20:03:35 1997
-+++ ./petal/petaleditor/Makefile Fri May 14 17:20:35 1999
-@@ -2,5 +2,5 @@
-
- pkgIndex.tcl : PetalEditor.tcl
- @echo "The error message for PetalEditor.tcl is normal"
-- echo "pkg_mkIndex . PetalEditor.tcl" | tclsh
-+ echo "pkg_mkIndex . PetalEditor.tcl" | tclsh8.2
-
diff --git a/audio/rosegarden/files/patch-ad b/audio/rosegarden/files/patch-ad
deleted file mode 100644
index 4083055b9715..000000000000
--- a/audio/rosegarden/files/patch-ad
+++ /dev/null
@@ -1,77 +0,0 @@
---- do-install.orig Wed Oct 22 06:20:43 1997
-+++ do-install Wed Dec 13 03:31:28 2000
-@@ -1,34 +1,30 @@
- #!/bin/sh
-
--BINDIR=/usr/local/bin
--LIBDIR=/usr/local/lib
-+BINDIR=${PREFIX}/bin
-+LIBDIR=${PREFIX}/lib
-+APP=${PREFIX}/lib/X11/app-defaults
-
--install="sh ./install-sh"
--
--if [ ! -f ./bin/rosegarden ]; then
-- echo "You're supposed to build it first..."
-- exit 1
--fi
-+install=/usr/bin/install
-
- echo
- echo Rosegarden 2.1 basic install script
- echo
--echo 'Enter directory for the main rosegarden executable ['$BINDIR']'
--read newbin
--if [ t"$newbin" != t ]; then BINDIR="$newbin"; fi
--echo 'Enter directory to contain the rosegarden lib directory ['$LIBDIR']'
--read newlib
--if [ t"$newlib" != t ]; then LIBDIR="$newlib"; fi
--echo
--echo Thanks
--echo
-+# echo 'Enter directory for the main rosegarden executable ['$BINDIR']'
-+# read newbin
-+# if [ t"$newbin" != t ]; then BINDIR="$newbin"; fi
-+# echo 'Enter directory to contain the rosegarden lib directory ['$LIBDIR']'
-+# read newlib
-+# if [ t"$newlib" != t ]; then LIBDIR="$newlib"; fi
-+# echo
-+# echo Thanks
-+# echo
-
- ROSELIBDIR=$LIBDIR/rosegarden
-
- ( set -x
-
- $install -d $BINDIR
--$install -s -c ./bin/rosegarden $BINDIR
-+$install -s -c ./bin/rosegarden $BINDIR/rosegarden-bin
-
- $install -d $ROSELIBDIR/bin
- $install -s -c ./bin/sequencer $ROSELIBDIR/bin
-@@ -46,20 +42,20 @@
- $install -c -m 644 ./common/help/rosehelp.hnx $ROSELIBDIR/help
-
- $install -d $ROSELIBDIR/petal
--test -f ./petal/Petal.so && $install -m 644 ./petal/Petal.so $ROSELIBDIR/petal
-+test -f ./petal/Petal.so && $install -c -m 644 ./petal/Petal.so $ROSELIBDIR/petal
- $install -c ./petal/Petal.tcl $ROSELIBDIR/petal
- $install -c ./petal/petaleditor/PetalEditor.tcl $ROSELIBDIR/petal
- $install -c ./petal/petalmidi/PetalMidi.tcl $ROSELIBDIR/petal
-
--( cd $ROSELIBDIR/petal ; echo "pkg_mkIndex . Petal.so *.tcl" | tclsh )
-+( cd $ROSELIBDIR/petal ; echo "pkg_mkIndex . Petal.so *.tcl" | tclsh8.2 )
-
- $install -d $ROSELIBDIR/rosepetal-filters
- $install -c ./petal/harmonizer.tcl $ROSELIBDIR/rosepetal-filters
- $install -c ./petal/pattern.tcl $ROSELIBDIR/rosepetal-filters
-
--test -d $HOME/.. || exit 0 # not set
--test -f $HOME/Rosegarden && mv $HOME/Rosegarden $HOME/Rosegarden.SAVED
--$install -c -m 644 Rosegarden $HOME
-+
-+test -f $APP/Rosegarden && mv $APP/Rosegarden $APP/Rosegarden.SAVED
-+$install -c -m 644 Rosegarden $APP
-
- )
-
diff --git a/audio/rosegarden/files/patch-ae b/audio/rosegarden/files/patch-ae
deleted file mode 100644
index 99a28434b000..000000000000
--- a/audio/rosegarden/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- /tmp/rosegarden-2.1/petal/dump.tcl Mon Oct 20 19:23:58 1997
-+++ ./petal/dump.tcl Fri May 14 17:22:47 1999
-@@ -1,6 +1,6 @@
- #!/bin/sh
--# the next line restarts using tclsh \
--exec tclsh "$0" "$@"
-+# the next line restarts using tclsh8.0 \
-+exec tclsh8.2 "$0" "$@"
-
- package require "Petal"
- PetalInit
diff --git a/audio/rosegarden/files/patch-ag b/audio/rosegarden/files/patch-ag
deleted file mode 100644
index 807599badbe7..000000000000
--- a/audio/rosegarden/files/patch-ag
+++ /dev/null
@@ -1,12 +0,0 @@
---- /tmp/rosegarden-2.1/petal/harmonizer.tcl Wed Oct 22 22:18:27 1997
-+++ ./petal/harmonizer.tcl Fri May 14 17:22:11 1999
-@@ -1,7 +1,7 @@
- #!/bin/sh
- # FilterName: Harmonize
--# the next line restarts using tclsh \
--exec tclsh "$0" "$@"
-+# the next line restarts using tclsh8.2 \
-+exec tclsh8.2 "$0" "$@"
-
- # Trivial harmonizer
-
diff --git a/audio/rosegarden/files/patch-ah b/audio/rosegarden/files/patch-ah
deleted file mode 100644
index dfabe8df7d82..000000000000
--- a/audio/rosegarden/files/patch-ah
+++ /dev/null
@@ -1,12 +0,0 @@
---- /tmp/rosegarden-2.1/petal/pattern.tcl Wed Oct 22 22:18:28 1997
-+++ ./petal/pattern.tcl Fri May 14 17:22:36 1999
-@@ -1,7 +1,7 @@
- #!/bin/sh
- # FilterName: Instantiate Pattern
--# the next line restarts using tclsh \
--exec tclsh "$0" "$@"
-+# the next line restarts using tclsh8.2 \
-+exec tclsh8.2 "$0" "$@"
-
- # Pattern instantiator (very dumb)
- # Main staff is the pattern,
diff --git a/audio/rosegarden/files/patch-ai b/audio/rosegarden/files/patch-ai
deleted file mode 100644
index 4c038125c147..000000000000
--- a/audio/rosegarden/files/patch-ai
+++ /dev/null
@@ -1,33 +0,0 @@
---- Rosegarden.orig Thu Oct 23 05:14:54 1997
-+++ Rosegarden Wed Dec 13 02:41:20 2000
-@@ -8,15 +8,15 @@
-
- !!! Paths, edit these
-
--Rosegarden*editorName: /usr/local/lib/rosegarden/bin/editor
--Rosegarden*sequencerName: /usr/local/lib/rosegarden/bin/sequencer
--Rosegarden*helpFile: /usr/local/lib/rosegarden/help/rosehelp.info
--Rosegarden*midiFmPatchFile: /usr/local/lib/rosegarden/synth-patches/std.sb
--Rosegarden*midiFmDrumPFile: /usr/local/lib/rosegarden/synth-patches/drums.sb
-+Rosegarden*editorName: %%PREFIX%%/lib/rosegarden/bin/editor
-+Rosegarden*sequencerName: %%PREFIX%%/lib/rosegarden/bin/sequencer
-+Rosegarden*helpFile: %%PREFIX%%/lib/rosegarden/help/rosehelp.info
-+Rosegarden*midiFmPatchFile: %%PREFIX%%/lib/rosegarden/synth-patches/std.sb
-+Rosegarden*midiFmDrumPFile: %%PREFIX%%/lib/rosegarden/synth-patches/drums.sb
-
- !!! directory for Petal filters. ~/.rosepetal-filters will also be searched
-
--Rosegarden*filtersDirectory: /usr/local/lib/rosegarden/rosepetal-filters
-+Rosegarden*filtersDirectory: %%PREFIX%%/lib/rosegarden/rosepetal-filters
-
- !!! this is the default directory used for file dialogs:
-
-@@ -24,7 +24,7 @@
-
- !!! this is for the sequencer's "Play through Slave":
-
--Rosegarden*externalPlayer: /usr/local/bin/xplaymidi
-+Rosegarden*externalPlayer: %%PREFIX%%/bin/xplaymidi
-
- !!! midi device location
- !!! for OSS this is normally /dev/sequencer, for ZILOG it's
diff --git a/audio/rosegarden/files/patch-aj b/audio/rosegarden/files/patch-aj
deleted file mode 100644
index fca6882c3c57..000000000000
--- a/audio/rosegarden/files/patch-aj
+++ /dev/null
@@ -1,9 +0,0 @@
---- /tmp/rosegarden-2.1/petal/petalmidi/Makefile Sun Mar 2 20:03:37 1997
-+++ ./petal/petalmidi/Makefile Fri May 14 17:24:26 1999
-@@ -2,5 +2,5 @@
-
- pkgIndex.tcl : PetalMidi.tcl
- @echo "The error message for PetalMidi.tcl is normal"
-- echo "pkg_mkIndex . PetalMidi.tcl" | tclsh
-+ echo "pkg_mkIndex . PetalMidi.tcl" | tclsh8.2
-
diff --git a/audio/rosegarden/files/patch-ak b/audio/rosegarden/files/patch-ak
deleted file mode 100644
index e94a529d37db..000000000000
--- a/audio/rosegarden/files/patch-ak
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: mapper/src/Mapper_OSS.c
-@@ -964,6 +964,13 @@
-
- BEGIN("Mapper_ReadEvent");
-
-+#ifdef __FreeBSD__
-+ /* on FreeBSD the read() will block when there is no data available... */
-+ out = 0;
-+ ioctl(seqfd, SNDCTL_SEQ_GETINCOUNT, &out);
-+ if (!out)
-+ RETURN_BOOL(False);
-+#endif
- if ( ( out = read(seqfd, &InBytes, sizeof(InBytes)) ) <= 0 )
- RETURN_BOOL(False);
-
diff --git a/audio/rosegarden/files/patch-al b/audio/rosegarden/files/patch-al
deleted file mode 100644
index af31fbaa885a..000000000000
--- a/audio/rosegarden/files/patch-al
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: include/Mapper_OSS.h
-@@ -4,7 +4,7 @@
- #undef MIDI_PITCH_BEND
- #endif
-
--#ifdef SYSTEM_FREEBSD || defined (__FreeBSD__)
-+#if defined(SYSTEM_FREEBSD) || defined (__FreeBSD__)
- #include <machine/soundcard.h>
- #elif SYSTEM_OSS
- #include <sys/soundcard.h>
diff --git a/audio/rosegarden/files/patch-configure b/audio/rosegarden/files/patch-configure
new file mode 100644
index 000000000000..320c59317281
--- /dev/null
+++ b/audio/rosegarden/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2010-06-09 12:33:23.000000000 +0700
++++ configure 2010-06-09 12:34:06.000000000 +0700
+@@ -4971,9 +4971,7 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_dl_dlopen" >&5
+ $as_echo "$ac_cv_lib_dl_dlopen" >&6; }
+ if test "x$ac_cv_lib_dl_dlopen" = x""yes; then :
+- LIBS="$LIBS -ldl"
+-else
+- as_fn_error "Failed to find required dl library" "$LINENO" 5
++ LIBS="$LIBS"
+ fi
+
+
diff --git a/audio/rosegarden/files/rosegarden b/audio/rosegarden/files/rosegarden
deleted file mode 100644
index 6ab6a8566c21..000000000000
--- a/audio/rosegarden/files/rosegarden
+++ /dev/null
@@ -1,2 +0,0 @@
-#! /bin/sh
-TCLLIBPATH="$TCLLIBPATH %%PREFIX%%/lib/rosegarden/petal" %%PREFIX%%/bin/rosegarden-bin
diff --git a/audio/rosegarden/pkg-plist b/audio/rosegarden/pkg-plist
index 75cc4d16cda5..adfe6dfd03f1 100644
--- a/audio/rosegarden/pkg-plist
+++ b/audio/rosegarden/pkg-plist
@@ -1,24 +1,28 @@
bin/rosegarden
-bin/rosegarden-bin
-lib/rosegarden/bin/editor
-lib/rosegarden/bin/sequencer
-lib/rosegarden/example/glazunov.rose
-lib/rosegarden/synth-patches/std.sb
-lib/rosegarden/synth-patches/drums.sb
-lib/rosegarden/help/rosehelp.hnx
-lib/rosegarden/help/rosehelp.info
-lib/rosegarden/petal/Petal.so
-lib/rosegarden/petal/Petal.tcl
-lib/rosegarden/petal/PetalEditor.tcl
-lib/rosegarden/petal/PetalMidi.tcl
-lib/rosegarden/petal/pkgIndex.tcl
-lib/rosegarden/rosepetal-filters/harmonizer.tcl
-lib/rosegarden/rosepetal-filters/pattern.tcl
-lib/X11/app-defaults/Rosegarden
-@dirrm lib/rosegarden/example
-@dirrm lib/rosegarden/help
-@dirrm lib/rosegarden/bin
-@dirrm lib/rosegarden/petal
-@dirrm lib/rosegarden/rosepetal-filters
-@dirrm lib/rosegarden/synth-patches
-@dirrm lib/rosegarden
+share/applications/rosegarden.desktop
+share/icons/hicolor/16x16/mimetypes/audio-x-rosegarden-composition.png
+share/icons/hicolor/16x16/mimetypes/audio-x-rosegarden-device.png
+share/icons/hicolor/16x16/mimetypes/audio-x-rosegarden-project.png
+share/icons/hicolor/16x16/mimetypes/audio-x-rosegarden-template.png
+share/icons/hicolor/32x32/apps/rosegarden.png
+share/icons/hicolor/32x32/mimetypes/audio-x-rosegarden-composition.png
+share/icons/hicolor/32x32/mimetypes/audio-x-rosegarden-device.png
+share/icons/hicolor/32x32/mimetypes/audio-x-rosegarden-project.png
+share/icons/hicolor/32x32/mimetypes/audio-x-rosegarden-template.png
+share/icons/hicolor/64x64/mimetypes/audio-x-rosegarden-composition.png
+share/icons/hicolor/64x64/mimetypes/audio-x-rosegarden-device.png
+share/icons/hicolor/64x64/mimetypes/audio-x-rosegarden-project.png
+share/icons/hicolor/64x64/mimetypes/audio-x-rosegarden-template.png
+share/mime/packages/rosegarden.xml
+@dirrmtry share/mime/packages
+@dirrmtry share/mime
+@dirrm share/icons/hicolor/64x64/mimetypes
+@dirrm share/icons/hicolor/64x64
+@dirrm share/icons/hicolor/32x32/mimetypes
+@dirrm share/icons/hicolor/32x32/apps
+@dirrm share/icons/hicolor/32x32
+@dirrm share/icons/hicolor/16x16/mimetypes
+@dirrm share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications