aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-audiofile/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-26 05:17:02 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-26 05:17:02 +0000
commit19889bf93a70dd813e626b6268d40dd29301fbeb (patch)
treef35ed2c4c5943530fc0b3ceeb4fbdf6a4eb2bf36 /audio/ruby-audiofile/Makefile
parent1efc93f474bf42ff5169184cd12b6e1033b6c2c2 (diff)
downloadports-19889bf93a70dd813e626b6268d40dd29301fbeb.tar.gz
ports-19889bf93a70dd813e626b6268d40dd29301fbeb.zip
Notes
Diffstat (limited to 'audio/ruby-audiofile/Makefile')
-rw-r--r--audio/ruby-audiofile/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/audio/ruby-audiofile/Makefile b/audio/ruby-audiofile/Makefile
index 6a51aa33e354..b4bcb8a71823 100644
--- a/audio/ruby-audiofile/Makefile
+++ b/audio/ruby-audiofile/Makefile
@@ -6,12 +6,13 @@
#
PORTNAME= audiofile
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2
CATEGORIES= audio ruby
MASTER_SITES= http://%SUBDIR%.sourceforge.net/download/
#MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ruby-${PORTNAME}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${CDDB_DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ruby
@@ -21,24 +22,17 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
-CDDB_DISTNAME= cddb-0.1
-CDDB_WRKSRC= ${WRKDIR}/cddb
+CDDB_DISTNAME= cddb-0.2
+CDDB_WRKSRC= ${WRKDIR}/example
+NO_BUILD= yes
INSTALL_TARGET= site-install
DOCS= audiofile.html audiofile.rd
post-patch:
${RUBY} -i -pe 'gsub %r|/home/jaredj/ruby-lib/cddb\b|, "cddb"' \
- ${CDDB_WRKSRC}/wavcddb.rb
-
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${RUBY_RD} audiofile.rd > audiofile.html
-.endif
+ ${CDDB_WRKSRC}/wavcddb
post-install:
.if !defined(NOPORTDOCS)