aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-esound/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-08 10:26:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-08 10:26:48 +0000
commitc9ea46692ba090d8301dd62d37a5f38fb6dd8610 (patch)
tree0bbd5614e3fc7322b06690e79115c7462a108975 /audio/ruby-esound/Makefile
parentecc8c32df6ff94f3cd402135ab9da76471ffef71 (diff)
Notes
Diffstat (limited to 'audio/ruby-esound/Makefile')
-rw-r--r--audio/ruby-esound/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/audio/ruby-esound/Makefile b/audio/ruby-esound/Makefile
new file mode 100644
index 000000000000..97fcbc0f0d0a
--- /dev/null
+++ b/audio/ruby-esound/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: Ruby/EsounD
+# Date created: 8 October 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= esound
+PORTVERSION= 0.1
+CATEGORIES= audio ruby
+MASTER_SITES= http://www.kokone.to/~kgt/Archive/
+MASTER_SITE_SUBDIR= ruby-${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/ruby-EsounD-${PORTVERSION}
+INSTALL_TARGET= site-install
+
+DOCS_EN= esound-0.2.22.patch
+DOCS_JA= METHODS.ja README.ja
+
+post-patch:
+ ${RUBY} -i -pe 'gsub(%r:\./esd\.so:, "esd")' ${WRKSRC}/test/*.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/*.rb ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>