aboutsummaryrefslogtreecommitdiff
path: root/audio/ruby-freedb
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-02 04:12:40 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-02 04:12:40 +0000
commitcf130ad6dedb912934a56ce1c8d03c9b966f496b (patch)
tree26f733d8965c1cef0d28a5d8815eec9a1ad6a1ab /audio/ruby-freedb
parentc3fcfe012d889968cfadce3cf0a41112e1116da8 (diff)
downloadports-cf130ad6dedb912934a56ce1c8d03c9b966f496b.tar.gz
ports-cf130ad6dedb912934a56ce1c8d03c9b966f496b.zip
Notes
Diffstat (limited to 'audio/ruby-freedb')
-rw-r--r--audio/ruby-freedb/Makefile3
-rw-r--r--audio/ruby-freedb/distinfo2
-rw-r--r--audio/ruby-freedb/files/patch-freedb_misc.rb26
3 files changed, 2 insertions, 29 deletions
diff --git a/audio/ruby-freedb/Makefile b/audio/ruby-freedb/Makefile
index 92a4e2d54883..f17da027723e 100644
--- a/audio/ruby-freedb/Makefile
+++ b/audio/ruby-freedb/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freedb
-PORTVERSION= 0.3
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= audio net ruby
MASTER_SITES= http://davedd.free.fr/%SUBDIR%/
MASTER_SITE_SUBDIR= ruby-${PORTNAME}
diff --git a/audio/ruby-freedb/distinfo b/audio/ruby-freedb/distinfo
index bb7a6a626b5f..1c5e18af8e05 100644
--- a/audio/ruby-freedb/distinfo
+++ b/audio/ruby-freedb/distinfo
@@ -1 +1 @@
-MD5 (ruby/ruby-freedb-0.3.tar.gz) = 56c7c87d2d7d1cd27cc4f57e42fcffb6
+MD5 (ruby/ruby-freedb-0.3.1.tar.gz) = 6c1c67dfbc9403faa7b44f097c2e307f
diff --git a/audio/ruby-freedb/files/patch-freedb_misc.rb b/audio/ruby-freedb/files/patch-freedb_misc.rb
deleted file mode 100644
index 4d5318d92815..000000000000
--- a/audio/ruby-freedb/files/patch-freedb_misc.rb
+++ /dev/null
@@ -1,26 +0,0 @@
---- lib/freedb_misc.rb.orig Sun Apr 7 22:40:20 2002
-+++ lib/freedb_misc.rb Fri Aug 30 19:58:47 2002
-@@ -4,12 +4,12 @@
- class Freedb
- VERSION = "0.3"
- PROTO_LEVEL = 1
-- attr_reader :results, :artist, :title, :tracks, :discid
-+ attr_reader :results, :genre, :artist, :title, :tracks, :discid
-
- def initialize(param = "/dev/cdrom", is_discid = false)
- @discid = ( is_discid ? param : get_cdrom(param) )
- @tracks = Array.new()
-- @hello_str="#{ENV["USER"]} #{`hostname`.strip} ruby-freedb #{VERSION}"
-+ @hello_str="#{ENV['USER']} #{`hostname`.strip} ruby-freedb #{VERSION}"
- end
-
- def fetch_net(server = "freedb.org", port = 8880)
-@@ -29,6 +29,8 @@
- lines = getmultiline(@handler)
- lines.each { |line|
- case line
-+ when /^210 (\S+)/
-+ @genre = $1
- when /^DTITLE=/
- md = /DTITLE=(.*) \/ (.*)/.match(line)
- if md.nil? #the DTITLE field is wrong.Should we throw an exception?