aboutsummaryrefslogtreecommitdiff
path: root/audio/rubyripper/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-06 19:13:24 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-11-06 19:13:24 +0000
commitd6d9c9ec618ff0e3ac3778608ee3c61a274997ee (patch)
tree3ff98cd64bd6391af30172b061bd71a29d3f5989 /audio/rubyripper/Makefile
parente58358dd0800df6dffac75b9666e925456afa41e (diff)
downloadports-d6d9c9ec618ff0e3ac3778608ee3c61a274997ee.tar.gz
ports-d6d9c9ec618ff0e3ac3778608ee3c61a274997ee.zip
Notes
Diffstat (limited to 'audio/rubyripper/Makefile')
-rw-r--r--audio/rubyripper/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/audio/rubyripper/Makefile b/audio/rubyripper/Makefile
new file mode 100644
index 000000000000..afd2bfdc404e
--- /dev/null
+++ b/audio/rubyripper/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: Rubyripper
+# Date created: 6 Nov 2010
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rubyripper
+DISTVERSION= 0.6.0
+CATEGORIES= audio sysutils ruby
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Digital audio CD extraction tool for accurate ripping
+
+LICENSE= GPLv3
+
+# cdparanoia is not really required for build, but it would not configure
+# without it (ideally, configure script should be fixed instead of forcing
+# superfluous build dependency)
+BUILD_DEPENDS= ${RUBY_SITELIBDIR}/gettext.rb:${PORTSDIR}/devel/ruby-gettext \
+ cdparanoia:${PORTSDIR}/audio/cdparanoia
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
+ ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
+ cdrdao:${PORTSDIR}/sysutils/cdrdao \
+ cd-discid:${PORTSDIR}/audio/cd-discid
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_RUBY= yes
+INSTALLS_ICONS= yes
+
+DESKTOP_ENTRIES="Rubyripper" "Secure Audio Disc Ripper" \
+ "${PORTNAME}.png" "rrip_gtk2" \
+ "Audio;AudioVideo;" ${FALSE}
+
+post-patch:
+# fix an apparent typo
+ @${REINPLACE_CMD} -e 's,cdparanioa,cdparanoia,' \
+ ${WRKSRC}/locale/po/bg/rubyripper.po \
+ ${WRKSRC}/locale/po/ru/rubyripper.po
+
+do-build:
+ cd ${WRKSRC} && ${RUBY} configure --update-lang
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/rr_lib.rb ${RUBY_SITELIBDIR}
+.for frontend in cli gtk2
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}_${frontend}.rb \
+ ${PREFIX}/bin/rrip_${frontend}
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png \
+ ${PREFIX}/share/icons/hicolor/128x128/apps
+ cd ${WRKSRC} && ${FIND} . -type f -name \*.mo | ${XARGS} ${TAR} \
+ cf - | ${TAR} xf - -C ${PREFIX}/share
+
+.include <bsd.port.mk>