aboutsummaryrefslogtreecommitdiff
path: root/audio/rubyripper
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-06 11:59:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-07-06 11:59:01 +0000
commitdc4a9cf0c6555914793f304704f5180a9f073686 (patch)
tree6fee9c5c875f19b68dc9d07d3be7b71efac4ac6e /audio/rubyripper
parent86560de87a784eb5150f2912d85b0a74739934d0 (diff)
downloadports-dc4a9cf0c6555914793f304704f5180a9f073686.tar.gz
ports-dc4a9cf0c6555914793f304704f5180a9f073686.zip
Notes
Diffstat (limited to 'audio/rubyripper')
-rw-r--r--audio/rubyripper/Makefile8
-rw-r--r--audio/rubyripper/files/patch-rr_lib.rb16
2 files changed, 16 insertions, 8 deletions
diff --git a/audio/rubyripper/Makefile b/audio/rubyripper/Makefile
index afd2bfdc404e..a8246f87c59c 100644
--- a/audio/rubyripper/Makefile
+++ b/audio/rubyripper/Makefile
@@ -7,8 +7,9 @@
PORTNAME= rubyripper
DISTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= audio sysutils ruby
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= danfe@FreeBSD.org
COMMENT= Digital audio CD extraction tool for accurate ripping
@@ -18,7 +19,7 @@ LICENSE= GPLv3
# cdparanoia is not really required for build, but it would not configure
# without it (ideally, configure script should be fixed instead of forcing
# superfluous build dependency)
-BUILD_DEPENDS= ${RUBY_SITELIBDIR}/gettext.rb:${PORTSDIR}/devel/ruby-gettext \
+BUILD_DEPENDS= rubygem-gettext:${PORTSDIR}/devel/rubygem-gettext \
cdparanoia:${PORTSDIR}/audio/cdparanoia
RUN_DEPENDS:= ${BUILD_DEPENDS} \
${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
@@ -31,8 +32,7 @@ USE_RUBY= yes
INSTALLS_ICONS= yes
DESKTOP_ENTRIES="Rubyripper" "Secure Audio Disc Ripper" \
- "${PORTNAME}.png" "rrip_gtk2" \
- "Audio;AudioVideo;" ${FALSE}
+ "${PORTNAME}.png" "rrip_gtk2" "Audio;AudioVideo;" false
post-patch:
# fix an apparent typo
diff --git a/audio/rubyripper/files/patch-rr_lib.rb b/audio/rubyripper/files/patch-rr_lib.rb
index b982f9446957..c70b266b8b62 100644
--- a/audio/rubyripper/files/patch-rr_lib.rb
+++ b/audio/rubyripper/files/patch-rr_lib.rb
@@ -1,6 +1,14 @@
--- rr_lib.rb.orig
+++ rr_lib.rb
-@@ -70,6 +70,7 @@
+@@ -22,6 +22,7 @@
+ $rr_version = '0.6.0' #application wide setting
+
+ begin
++ require 'rubygems'
+ require 'gettext'
+ include GetText
+ bindtextdomain("rubyripper")
+@@ -70,6 +71,7 @@
Thread.new do
if installed('eject') ; `eject #{cdrom}`
elsif installed('diskutil'); `diskutil eject #{cdrom}` #Mac users don't got eject, but diskutil
@@ -8,7 +16,7 @@
else puts _("No eject utility found!")
end
end
-@@ -573,15 +574,15 @@
+@@ -573,15 +575,15 @@
end
end
@@ -27,7 +35,7 @@
"for device %s on your system! These permissions are\n"\
"necessary for cdparanoia to scan your drive.\n\n%s\n"\
"You might want to add yourself to the necessary group in /etc/group")\
-@@ -605,13 +606,13 @@
+@@ -605,13 +607,13 @@
return true
end
@@ -43,7 +51,7 @@
"for device %s on your system! These permissions are\n"\
"necessary for cdparanoia to scan your drive.\n\n%s\n"\
"You might want to add yourself to the necessary group in /etc/group")\
-@@ -2524,7 +2525,7 @@
+@@ -2524,7 +2526,7 @@
# 6) is req_matches_all <= req_matches_errors
def checkConfig