aboutsummaryrefslogtreecommitdiff
path: root/audio/schism/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-12 16:30:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-04-12 16:30:34 +0000
commit3d3b909ba4882558f122dc91365edeccd11d9b0f (patch)
tree6bf58dac08e3de3d8bc2e30c9c0425b1ec84888b /audio/schism/Makefile
parent4af528f41855f0a7e0107dea08f4d6cea2367e9e (diff)
downloadports-3d3b909ba4882558f122dc91365edeccd11d9b0f.tar.gz
ports-3d3b909ba4882558f122dc91365edeccd11d9b0f.zip
Notes
Diffstat (limited to 'audio/schism/Makefile')
-rw-r--r--audio/schism/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/audio/schism/Makefile b/audio/schism/Makefile
deleted file mode 100644
index 504fae7bddd3..000000000000
--- a/audio/schism/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# Created by: Emanuel Haupt <ehaupt@critical.ch>
-# $FreeBSD$
-
-PORTNAME= schism
-PORTVERSION= 20160913
-PORTREVISION= 1
-CATEGORIES= audio
-
-MAINTAINER= ehaupt@FreeBSD.org
-COMMENT= Module tracker editor/player resembling impulse tracker
-
-LICENSE= GPLv2
-
-ONLY_FOR_ARCHS= i386 amd64
-
-USES= autoreconf python compiler:c++11-lib
-USE_SDL= sdl
-USE_XORG= x11 xext xv
-GNU_CONFIGURE= yes
-
-USE_GITHUB= yes
-GH_ACCOUNT= schismtracker
-GH_PROJECT= schismtracker
-
-PLIST_FILES= bin/${PORTNAME}
-
-# if you touch these make sure configure finds X11/XKBlib.h presence
-LDFLAGS+= `sdl-config --libs`
-LIBS+= -lm -lX11
-CPPFLAGS+= -I${LOCALBASE}/include
-
-post-patch:
- @${REINPLACE_CMD} \
- -e "s|^\(AC_INIT.*\)\[last_git_commit\]|\1${PORTVERSION}|" \
- -e '/^m4_define.*last_git_commit.*git/d' \
- ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e '/^schismtracker_LDADD/d' ${WRKSRC}/Makefile.am
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/schismtracker ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
-.include <bsd.port.mk>