aboutsummaryrefslogtreecommitdiff
path: root/audio/sdl_mixer/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-07-19 20:56:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-07-19 20:56:50 +0000
commit463f958a43385bed59f2e1f1f8fdd94afcedd636 (patch)
tree2b78b7696237534c4e45b4811573bb334e61c86d /audio/sdl_mixer/Makefile
parent0f0ffd53a9cbb737759611471a0c0eb95cfcc77b (diff)
downloadports-463f958a43385bed59f2e1f1f8fdd94afcedd636.tar.gz
ports-463f958a43385bed59f2e1f1f8fdd94afcedd636.zip
Notes
Diffstat (limited to 'audio/sdl_mixer/Makefile')
-rw-r--r--audio/sdl_mixer/Makefile30
1 files changed, 20 insertions, 10 deletions
diff --git a/audio/sdl_mixer/Makefile b/audio/sdl_mixer/Makefile
index 9c7daf3a17d9..d914c2185684 100644
--- a/audio/sdl_mixer/Makefile
+++ b/audio/sdl_mixer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl_mixer
PORTVERSION= 1.2.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.libsdl.org/projects/SDL_mixer/release/
DISTNAME= SDL_mixer-${PORTVERSION}
@@ -14,11 +15,7 @@ DISTNAME= SDL_mixer-${PORTVERSION}
MAINTAINER= krion@FreeBSD.org
COMMENT= A sample multi-channel audio mixer library
-LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
- smpeg.1:${PORTSDIR}/multimedia/smpeg
-
USE_SDL= sdl
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -26,15 +23,28 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
INSTALLS_SHLIB= yes
+OPTIONS= MIKMOD "Enable MOD music via libMikMod" on \
+ VORBIS "Enable Ogg Vorbis music" on \
+ SMPEG "Enable MP3 music via SMPEG" on
+
.include <bsd.port.pre.mk>
-.if defined(WITH_MIKMOD)
-LIB_DEPENDS+= mikmod.2:${PORTSDIR}/audio/libmikmod
+.if defined(WITHOUT_MIKMOD)
+CONFIGURE_ARGS+= --disable-music-libmikmod
+.else
+LIB_DEPENDS= mikmod.2:${PORTSDIR}/audio/libmikmod
.endif
-post-configure:
- @${REINPLACE_CMD} -e \
- 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --disable-music-ogg
+.else
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+.endif
+
+.if defined(WITHOUT_SMPEG)
+CONFIGURE_ARGS+= --disable-music-mp3
+.else
+LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+.endif
.include <bsd.port.post.mk>