aboutsummaryrefslogtreecommitdiff
path: root/audio/sfront/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-08-29 13:22:01 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-08-29 13:22:01 +0000
commitf72ba3d0a434822a9927b396a3207a5e89866d9f (patch)
treed04502b479f045a8a89acb11fa8037b590f0bb5e /audio/sfront/Makefile
parentc715e8b92444f4369de4419d36079a8863f0236c (diff)
downloadports-f72ba3d0a434822a9927b396a3207a5e89866d9f.tar.gz
ports-f72ba3d0a434822a9927b396a3207a5e89866d9f.zip
Notes
Diffstat (limited to 'audio/sfront/Makefile')
-rw-r--r--audio/sfront/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/audio/sfront/Makefile b/audio/sfront/Makefile
index 1baccb17f4c6..9c45ec7f7809 100644
--- a/audio/sfront/Makefile
+++ b/audio/sfront/Makefile
@@ -1,23 +1,20 @@
-# ex:ts=8
# New ports collection makefile for: sfront
-# Date created: Nov 4, 2001
-# Whom: ijliao
+# Date created: Nov 4, 2001
+# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= sfront
-PORTVERSION= 0.88
+PORTVERSION= 0.89
CATEGORIES= audio
MASTER_SITES= http://www.cs.berkeley.edu/~lazzaro/sa/
DISTNAME= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ehaupt@critical.ch
COMMENT= A translator that converts MP4-SA files into efficient C programs
-.if !defined(NOPORTDOCS)
PORTDOCS= book sfman
-.endif
WRKSRC= ${WRKDIR}/${PORTNAME}/src
@@ -27,11 +24,13 @@ ALL_TARGET= ${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sfront ${PREFIX}/bin
- ${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKDIR}/sfront/examples/ ${EXAMPLESDIR}
+
.if !defined(NOPORTDOCS)
- ${CP} -R ${WRKDIR}/sfront/sfman ${DOCSDIR}/
- ${CP} -R ${WRKDIR}/sfront/book ${DOCSDIR}/
+ ${MKDIR} ${DOCSDIR}
+.for d in ${PORTDOCS}
+ ${CP} -R ${WRKDIR}/sfront/${d} ${DOCSDIR}/
+.endfor
.endif
- ${CP} -R ${WRKDIR}/sfront/examples/ ${EXAMPLESDIR}
.include <bsd.port.mk>