aboutsummaryrefslogtreecommitdiff
path: root/audio/shairport-sync/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2020-04-12 12:30:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2020-04-12 12:30:37 +0000
commit1d63c97c74eebcfc5c4fa82b30a2e5fe4fc4da79 (patch)
treecc103968bf47d4641ef393971218aa6440f57575 /audio/shairport-sync/Makefile
parent4d21eb6b103589f39bd276f2ec1aca7d3fe46a05 (diff)
Notes
Diffstat (limited to 'audio/shairport-sync/Makefile')
-rw-r--r--audio/shairport-sync/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/audio/shairport-sync/Makefile b/audio/shairport-sync/Makefile
index d976e15a89c9..154ef615dfd4 100644
--- a/audio/shairport-sync/Makefile
+++ b/audio/shairport-sync/Makefile
@@ -3,6 +3,7 @@
PORTNAME= shairport-sync
DISTVERSION= 3.3.6
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= ehaupt@FreeBSD.org
@@ -25,9 +26,10 @@ GH_ACCOUNT= mikebrady
USE_RC_SUBR= ${PORTNAME}
-OPTIONS_DEFINE= ALAC ALSA SNDIO PULSEAUDIO
+OPTIONS_DEFINE= ALAC ALSA SNDIO PULSEAUDIO MQTT
OPTIONS_DEFAULT=SNDIO
ALAC_DESC= Build with libalac support (experimental)
+MQTT_DESC= Build with MQTT protocol support
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc \
--with-piddir=/var/run/shairport-sync --with-avahi \
@@ -45,6 +47,9 @@ ALAC_CONFIGURE_ON= --with-apple-alac
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ON= --with-alsa
+MQTT_LIB_DEPENDS= libmosquitto.so:net/mosquitto
+MQTT_CONFIGURE_ON= --with-mqtt-client
+
SNDIO_CONFIGURE_ON= --with-sndio
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio