aboutsummaryrefslogtreecommitdiff
path: root/audio/shairport
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2012-01-07 11:24:21 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2012-01-07 11:24:21 +0000
commit17fb319ee4b6d9a4e95dd6c4da53ab49ad5d08b3 (patch)
treef07282d2daa2c2c7e324389577aa958f1d1d5ae0 /audio/shairport
parent34763a9b5d5b53f6a1a372b1fbf6949a7e0ad7b0 (diff)
downloadports-17fb319ee4b6d9a4e95dd6c4da53ab49ad5d08b3.tar.gz
ports-17fb319ee4b6d9a4e95dd6c4da53ab49ad5d08b3.zip
Notes
Diffstat (limited to 'audio/shairport')
-rw-r--r--audio/shairport/Makefile48
-rw-r--r--audio/shairport/distinfo2
-rw-r--r--audio/shairport/files/shairport.in31
-rw-r--r--audio/shairport/pkg-descr8
4 files changed, 89 insertions, 0 deletions
diff --git a/audio/shairport/Makefile b/audio/shairport/Makefile
new file mode 100644
index 000000000000..45b4fb1ba396
--- /dev/null
+++ b/audio/shairport/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: shairport
+# Date created: 2011.09.30
+# Whom: Aldis Berjoza <graudeejs@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= shairport
+PORTVERSION= 0.05
+CATEGORIES= audio
+MASTER_SITES= http://cloud.github.com/downloads/miks/${PORTNAME}/
+DISTNAME= miks-${PORTNAME}-${REV}
+
+MAINTAINER= miks.mikelsons@gmail.com
+COMMENT= Airtunes emulator
+
+LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-HTTP-Message \
+ avahi-publish-service:${PORTSDIR}/net/avahi-app
+
+USE_GMAKE= yes
+USE_PERL5_RUN= yes
+USE_OPENSSL= yes
+USE_GNOME= pkgconfig
+
+USE_RC_SUBR= ${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME} bin/hairtunes bin/${PORTNAME}.pl
+
+REV= b1cb9ea
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|avahi-|${LOCALBASE}/bin/avahi-|g' \
+ -e 's|$$FindBin.*|"${PREFIX}/bin/hairtunes";|' \
+ -e '/use FindBin;/d' ${WRKSRC}/shairport.c ${WRKSRC}/shairport.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin
+.for file in ${PORTNAME} hairtunes
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/audio/shairport/distinfo b/audio/shairport/distinfo
new file mode 100644
index 000000000000..5fbdac01a60f
--- /dev/null
+++ b/audio/shairport/distinfo
@@ -0,0 +1,2 @@
+SHA256 (miks-shairport-b1cb9ea.tar.gz) = daf55530ba1fecb5a6b5a4c770c97e44cb0ca59a58cd87451975635197e1304f
+SIZE (miks-shairport-b1cb9ea.tar.gz) = 40425
diff --git a/audio/shairport/files/shairport.in b/audio/shairport/files/shairport.in
new file mode 100644
index 000000000000..1cf04f88d46a
--- /dev/null
+++ b/audio/shairport/files/shairport.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: shairport
+# REQUIRE: DAEMON avahi_daemon
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf to
+# enable shairport:
+#
+# shairport_enable (bool): Set to NO by default. Set it to YES to
+# enable shairport.
+# shairport_flags='-a freebsdShairport'
+
+. /etc/rc.subr
+
+name="shairport"
+rcvar=${name}_enable
+
+command="%%PREFIX%%/bin/${name}.pl"
+pidfile="/var/run/${name}.pid"
+procname="perl"
+
+command_args="-d -w ${pidfile}"
+
+load_rc_config ${name}
+
+: ${shairport_enable="NO"}
+
+run_rc_command "$1"
diff --git a/audio/shairport/pkg-descr b/audio/shairport/pkg-descr
new file mode 100644
index 000000000000..97a90015e971
--- /dev/null
+++ b/audio/shairport/pkg-descr
@@ -0,0 +1,8 @@
+This program emulates an AirPort Express for the purpose of streaming music
+from iTunes and compatible iPods. It implements a server for the Apple RAOP
+protocol. ShairPort does not support AirPlay v2 (video and photo streaming).
+
+It supports multiple simultaneous streams, if your audio output chain (as
+detected by libao) does so.
+
+WWW: https://github.com/albertz/shairport