aboutsummaryrefslogtreecommitdiff
path: root/audio/shoutcast
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:01:25 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:01:25 +0000
commite0263e215c96247fda97039f99188d16b84a2218 (patch)
tree7f63e5074ee4b11ca1eee3dca53fec21151b1703 /audio/shoutcast
parent16a1d1bab40ffba11285074572008fff630ea884 (diff)
downloadports-e0263e215c96247fda97039f99188d16b84a2218.tar.gz
ports-e0263e215c96247fda97039f99188d16b84a2218.zip
Notes
Diffstat (limited to 'audio/shoutcast')
-rw-r--r--audio/shoutcast/Makefile18
-rw-r--r--audio/shoutcast/pkg-install7
2 files changed, 15 insertions, 10 deletions
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index ac3644c61011..e21381cbc1f0 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -37,7 +37,7 @@ BROKEN= unsupported FreeBSD version
.endif
post-patch:
- ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
+ @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
-e 's|=sc_serv.log|=/var/log/sc_serv.log|' \
-e 's|=sc_w3c.log|=/var/log/sc_w3c.log|' \
-e 's|ScreenLog=1|ScreenLog=0|' \
@@ -47,17 +47,17 @@ post-patch:
${WRKSRC}/sc_serv.conf
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${PREFIX}/sbin
- ${MKDIR} ${PREFIX}/etc/shoutcast
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf.sample
- @[ -f ${PREFIX}/etc/shoutcast/sc_serv.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${PREFIX}/etc/shoutcast/sc_serv.conf
+ @${INSTALL_PROGRAM} ${WRKSRC}/sc_serv ${TARGETDIR}/sbin
+ @${MKDIR} ${TARGETDIR}/etc/shoutcast
+ @${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf.sample
+ @[ -f ${TARGETDIR}/etc/shoutcast/sc_serv.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/sc_serv.conf ${TARGETDIR}/etc/shoutcast/sc_serv.conf
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}
.endif
post-install:
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/audio/shoutcast/pkg-install b/audio/shoutcast/pkg-install
index bb97ac95dde2..75387ad52143 100644
--- a/audio/shoutcast/pkg-install
+++ b/audio/shoutcast/pkg-install
@@ -8,7 +8,12 @@ SC_GROUP=shoutcast
SC_USER=shoutcast
SC_SHELL=/bin/sh
SC_HOME=/nonexistent
-PW=/usr/sbin/pw
+
+if [ -n "${DESTDIR}" ] ; then
+ PW="/usr/sbin/chroot ${DESTDIR} /usr/sbin/pw"
+else
+ PW="/usr/sbin/pw"
+fi
if ! ${PW} show group ${SC_GROUP} -q >/dev/null; then
gid=210