aboutsummaryrefslogtreecommitdiff
path: root/audio/sidplay2
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-10 22:13:39 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-10 22:13:39 +0000
commit6d8d8210985c12b8bae67126208043c9332bbc69 (patch)
tree77789cfa2edfb65071add871a3130ea1ae7a0642 /audio/sidplay2
parent663a78a6e93e61d854c6b690bc3825fabd2cd66d (diff)
downloadports-6d8d8210985c12b8bae67126208043c9332bbc69.tar.gz
ports-6d8d8210985c12b8bae67126208043c9332bbc69.zip
Notes
Diffstat (limited to 'audio/sidplay2')
-rw-r--r--audio/sidplay2/Makefile25
-rw-r--r--audio/sidplay2/distinfo3
-rw-r--r--audio/sidplay2/files/patch-src_audio_oss_audiodrv.h19
-rw-r--r--audio/sidplay2/pkg-descr6
4 files changed, 53 insertions, 0 deletions
diff --git a/audio/sidplay2/Makefile b/audio/sidplay2/Makefile
new file mode 100644
index 000000000000..bb93077a272a
--- /dev/null
+++ b/audio/sidplay2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: sidplay2
+# Date created: 09 June 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sidplay2
+PORTVERSION= 2.0.9
+CATEGORIES= audio emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= sidplay-${PORTVERSION}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= A player that plays Commodore SID music files using libsidplay2
+
+LIB_DEPENDS= sidplay2.1:${PORTSDIR}/audio/libsidplay2
+
+MAN1= sidplay2.1
+PLIST_FILES= bin/sidplay2
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/audio/sidplay2/distinfo b/audio/sidplay2/distinfo
new file mode 100644
index 000000000000..ccb43ee7cc13
--- /dev/null
+++ b/audio/sidplay2/distinfo
@@ -0,0 +1,3 @@
+MD5 (sidplay-2.0.9.tar.gz) = 8b0449e501ba8e684f718dce9b77c5a5
+SHA256 (sidplay-2.0.9.tar.gz) = b850986ce9226cb6eecca50057967be313771b67aed721421e74e6c931e02215
+SIZE (sidplay-2.0.9.tar.gz) = 362140
diff --git a/audio/sidplay2/files/patch-src_audio_oss_audiodrv.h b/audio/sidplay2/files/patch-src_audio_oss_audiodrv.h
new file mode 100644
index 000000000000..a28ff35d2cfd
--- /dev/null
+++ b/audio/sidplay2/files/patch-src_audio_oss_audiodrv.h
@@ -0,0 +1,19 @@
+--- src/audio/oss/audiodrv.h.orig Fri Jun 9 13:55:40 2006
++++ src/audio/oss/audiodrv.h Fri Jun 9 13:56:03 2006
+@@ -57,15 +57,7 @@
+ #include <stdio.h>
+ #include <unistd.h>
+
+-#if defined(HAVE_LINUX_SOUNDCARD_H)
+-# include <linux/soundcard.h>
+-#elif defined(HAVE_MACHINE_SOUNDCARD_H)
+-# include <machine/soundcard.h>
+-#elif defined(HAVE_SOUNDCARD_H)
+-# include <soundcard.h>
+-#else
+-# error Audio driver not supported.
+-#endif
++#include <sys/soundcard.h>
+
+ #include "../AudioBase.h"
+
diff --git a/audio/sidplay2/pkg-descr b/audio/sidplay2/pkg-descr
new file mode 100644
index 000000000000..44f31f02cd2b
--- /dev/null
+++ b/audio/sidplay2/pkg-descr
@@ -0,0 +1,6 @@
+Sidplay 2 is the second in the Sidplay series originally developed by Michael
+Schwendt. This version is written by Simon White and is cycle accurate for
+improved sound reproduction. Sidplay 2 is capable of playing all C64 mono and
+stereo file formats.
+
+WWW: http://sidplay2.sourceforge.net/