aboutsummaryrefslogtreecommitdiff
path: root/audio/slimserver-sqlplaylist
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2007-10-28 21:40:39 +0000
committerTim Bishop <tdb@FreeBSD.org>2007-10-28 21:40:39 +0000
commit515a7a346eb0e3c977ed4cf146b0b9f2c6e59ccc (patch)
tree1a6cdff2c3ff523e2a4f7fd1cc812d32a395540b /audio/slimserver-sqlplaylist
parent052ffb217c18c8768c26bd2000ed1828dece2bda (diff)
downloadports-515a7a346eb0e3c977ed4cf146b0b9f2c6e59ccc.tar.gz
ports-515a7a346eb0e3c977ed4cf146b0b9f2c6e59ccc.zip
Notes
Diffstat (limited to 'audio/slimserver-sqlplaylist')
-rw-r--r--audio/slimserver-sqlplaylist/Makefile34
-rw-r--r--audio/slimserver-sqlplaylist/distinfo3
-rw-r--r--audio/slimserver-sqlplaylist/pkg-descr19
-rw-r--r--audio/slimserver-sqlplaylist/pkg-plist133
4 files changed, 189 insertions, 0 deletions
diff --git a/audio/slimserver-sqlplaylist/Makefile b/audio/slimserver-sqlplaylist/Makefile
new file mode 100644
index 000000000000..d4e5cf8f7290
--- /dev/null
+++ b/audio/slimserver-sqlplaylist/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: slimserver-sqlplaylist
+# Date created: 28 October 2007
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlplaylist
+PORTVERSION= 1.21
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-sqlplaylist&filename=/
+PKGNAMEPREFIX= slimserver-
+DISTNAME= SQLPlayList-${PORTVERSION}
+DIST_SUBDIR= slimserver
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SlimServer plugin to create playlists based on SQL queries
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/slimserver \
+ ${LOCALBASE}/${SLIMDIR}/Plugins/DynamicPlayList/Plugin.pm:${PORTSDIR}/audio/slimserver-dynamicplaylist
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/SQLPlayList
+
+SLIMDIR?= slimserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${SLIMDIR}/Plugins/SQLPlayList
+
+.include <bsd.port.mk>
diff --git a/audio/slimserver-sqlplaylist/distinfo b/audio/slimserver-sqlplaylist/distinfo
new file mode 100644
index 000000000000..003b603fca3a
--- /dev/null
+++ b/audio/slimserver-sqlplaylist/distinfo
@@ -0,0 +1,3 @@
+MD5 (slimserver/SQLPlayList-1.21.zip) = c322dfae2c8d62468a2925d41ec5455f
+SHA256 (slimserver/SQLPlayList-1.21.zip) = 8d798e5551384cbbe97ff77bace5b468a4fb2ceef0a7a5340e50488e05024e3a
+SIZE (slimserver/SQLPlayList-1.21.zip) = 273302
diff --git a/audio/slimserver-sqlplaylist/pkg-descr b/audio/slimserver-sqlplaylist/pkg-descr
new file mode 100644
index 000000000000..12bdd9629eb1
--- /dev/null
+++ b/audio/slimserver-sqlplaylist/pkg-descr
@@ -0,0 +1,19 @@
+This plugin for Slimserver makes it possible to create smart
+playlists. Although the standard Slimserver doesn't support smart
+playlists by itself, together with iTunes and the standard Slimserver
+iTunes integration, it is possible to use smart playlists defined
+in iTunes. The problem though is that the integrated iTunes smart
+playlists will not be recalculated until the next time you perform
+a rescan in Slimserver. The SQL Playlist plugin takes care of this
+problem and implements native smart playlist in Slimserver without
+any need to use iTunes. The smart playlists implemented in SQL
+Playlist will also be automatically re-calculated after each track
+played so they will be based on the latest statistic information.
+
+A smart playlist in SQL Playlist are continous and will run forever
+in the same way as the standard Random Mix plugin, you can optionally
+also choose that a smart playlist shouldn't repeat already played
+tracks and in that case the music will stop when all songs matching
+the playlist has been played.
+
+WWW: http://wiki.erland.homeip.net/index.php/SQL_Playlist_plugin
diff --git a/audio/slimserver-sqlplaylist/pkg-plist b/audio/slimserver-sqlplaylist/pkg-plist
new file mode 100644
index 000000000000..9e4027282e32
--- /dev/null
+++ b/audio/slimserver-sqlplaylist/pkg-plist
@@ -0,0 +1,133 @@
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/BaseParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/ContentParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/DirectoryLoader.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/Main.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/ParameterHandler.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/PlaylistWebAdminMethods.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/PluginLoader.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/TemplateContentParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/TemplateParser.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager/WebAdminMethods.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/catchtab.js
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_list.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_redirect.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/sqlplaylist_reload.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_edititem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_editsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_login.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newitemtypes.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_newsimpleitem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_publishitemparameters.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_register.html
+%%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList/webadminmethods_savedownloadeditem.html
+%%SLIMDIR%%/Plugins/SQLPlayList/LICENSE.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomalbums.sql.values
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomartists.sql.values
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomtracks.sql.values
+%%SLIMDIR%%/Plugins/SQLPlayList/Playlists/randomyears.sql.values
+%%SLIMDIR%%/Plugins/SQLPlayList/Plugin.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/README.txt
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advanced.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/advancedwithrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomalbums.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomartists.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforrating.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomforratingandyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomweightedtracks.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/randomyears.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/simple.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforalbum.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforartist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforgenre.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforplaylist.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.template
+%%SLIMDIR%%/Plugins/SQLPlayList/Templates/topratedforyear.sql.xml
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/Apache/SOAP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/Apache/XMLRPC/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/IO/SessionData.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/IO/SessionSet.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/FTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/HTTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/IO.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/JABBER.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/LOCAL.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/MAILTO.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/MQ.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/POP3.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport/TCP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Client.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Constants.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Data.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Deserializer.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Fault.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Header.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Packager.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/SOM.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Schema.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Serializer.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Server.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Test.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Trace.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/FTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/HTTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/IO.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/JABBER.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/LOCAL.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/MAILTO.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/MQ.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/POP3.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport/TCP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Utils.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/UDDI/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XML/Parser/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Lite.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Test.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Transport/HTTP.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Transport/POP3.pm
+%%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Transport/TCP.pm
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC/Transport
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/XMLRPC
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/XML/Parser
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/XML
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/UDDI
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP/Transport
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/SOAP
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP/Transport
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs/SOAP
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/OldDocs
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/IO
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/Apache/XMLRPC
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs/Apache
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/libs
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/Templates
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/Playlists
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins/SQLPlayList
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/HTML
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList/ConfigManager
+@dirrm %%SLIMDIR%%/Plugins/SQLPlayList