aboutsummaryrefslogtreecommitdiff
path: root/audio/slimserver-trackstat
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2007-10-28 21:42:29 +0000
committerTim Bishop <tdb@FreeBSD.org>2007-10-28 21:42:29 +0000
commitd9b6d624ebf781875b421dc58c91e1e791a4957e (patch)
tree066de668a26d8f25fb12e4f6c71b860f1eee5cdc /audio/slimserver-trackstat
parent7a4a4aba6dabda902f5de40194bd21a62b9fdf42 (diff)
downloadports-d9b6d624ebf781875b421dc58c91e1e791a4957e.tar.gz
ports-d9b6d624ebf781875b421dc58c91e1e791a4957e.zip
Notes
Diffstat (limited to 'audio/slimserver-trackstat')
-rw-r--r--audio/slimserver-trackstat/Makefile33
-rw-r--r--audio/slimserver-trackstat/distinfo3
-rw-r--r--audio/slimserver-trackstat/pkg-descr28
-rw-r--r--audio/slimserver-trackstat/pkg-plist165
4 files changed, 229 insertions, 0 deletions
diff --git a/audio/slimserver-trackstat/Makefile b/audio/slimserver-trackstat/Makefile
new file mode 100644
index 000000000000..36a61a11faac
--- /dev/null
+++ b/audio/slimserver-trackstat/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: slimserver-trackstat
+# Date created: 28 October 2007
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackstat
+PORTVERSION= 1.40.1
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-trackstat&filename=/
+PKGNAMEPREFIX= slimserver-
+DISTNAME= TrackStat-${PORTVERSION}
+DIST_SUBDIR= slimserver
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SlimServer plugin to store ratings and statistics about songs
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/slimserver
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/TrackStat
+
+SLIMDIR?= slimserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+
+.include <bsd.port.mk>
diff --git a/audio/slimserver-trackstat/distinfo b/audio/slimserver-trackstat/distinfo
new file mode 100644
index 000000000000..1ec96a6e7813
--- /dev/null
+++ b/audio/slimserver-trackstat/distinfo
@@ -0,0 +1,3 @@
+MD5 (slimserver/TrackStat-1.40.1.zip) = 7e93b4a01189345c3e2c5ec5de353ae7
+SHA256 (slimserver/TrackStat-1.40.1.zip) = 47c5d8c39d3edb541f736f2aac21d1e32b93bc21c7c7ee52e980f3335740c9d8
+SIZE (slimserver/TrackStat-1.40.1.zip) = 213774
diff --git a/audio/slimserver-trackstat/pkg-descr b/audio/slimserver-trackstat/pkg-descr
new file mode 100644
index 000000000000..1ed9d17e663f
--- /dev/null
+++ b/audio/slimserver-trackstat/pkg-descr
@@ -0,0 +1,28 @@
+This is a statistic plugin for Slimserver. Slimserver normally
+stores statistics about the last time a track was played, when a
+specific track was added to the library and how many times a track
+has been played. The problem is that all of these statistics are
+cleared every time you perform a full rescan of slimserver.
+
+The TrackStat plugin solves this problem by making sure that the
+statistics survive a rescan. Besides this TrackStat also extends
+the statistics a bit, one example is that it doesn't count a track
+as played just because you listen to the first 2 seconds of it, you
+will have to play a certain amount of the track until it is played.
+TrackStat also makes it possible to put a rating on all your tracks
+by holding a number between 1-5 down on the now playing screen.
+
+The other main functionality the TrackStat plugins provides is
+various ways to browse your music based on the statistic information.
+The standard slimserver only makes it possible to show most played
+tracks. The TrackStat plugin makes it possible to show the statistics
+in a lot more ways. The purpose is simply to give you another way
+to select which music you like to play, for example like:
+
+ * Find tracks you haven't played for a long time
+ * Find tracks you have recently added to the library
+ * Find top rated tracks
+ * Find least played tracks
+ * And a lot more...
+
+WWW: http://wiki.erland.homeip.net/index.php/TrackStat_plugin
diff --git a/audio/slimserver-trackstat/pkg-plist b/audio/slimserver-trackstat/pkg-plist
new file mode 100644
index 000000000000..7f168f994c38
--- /dev/null
+++ b/audio/slimserver-trackstat/pkg-plist
@@ -0,0 +1,165 @@
+%%SLIMDIR%%/Plugins/TrackStat/Amarok/Common.pm
+%%SLIMDIR%%/Plugins/TrackStat/Amarok/Export.pm
+%%SLIMDIR%%/Plugins/TrackStat/Amarok/Import.pm
+%%SLIMDIR%%/Plugins/TrackStat/Backup/File.pm
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/albumratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/artistratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.template
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/albumheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/artistheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderdata.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackheaderratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/ContextMenus/trackratings.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueries/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/problems.xml
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.template
+%%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates/statistics.xml
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images/h_PLUGIN_TRACKSTAT.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat/css10scale
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/controls
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/css10scale
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/index.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/listitems
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/mixerlink65.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/selectfavourites.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/selectstatistics.html
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/controls
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/css
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/css10scale
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_delete.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_down.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/b_up.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/empty_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images/star_noborder.gif
+%%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html/images/mixbutton.gif
+%%SLIMDIR%%/Plugins/TrackStat/LICENSE.txt
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.template
+%%SLIMDIR%%/Plugins/TrackStat/MenuTemplates/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Menus/trackstat.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatalbum.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatartist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatgenre.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatplaylist.xml
+%%SLIMDIR%%/Plugins/TrackStat/Mixes/trackstatyear.xml
+%%SLIMDIR%%/Plugins/TrackStat/MusicMagic/Export.pm
+%%SLIMDIR%%/Plugins/TrackStat/MusicMagic/Import.pm
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayed.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/mostplayedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/notrated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyadded.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/recentlyaddedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/toprated.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedalbums.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedartists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedgenres.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedplaylists.xml
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.template
+%%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates/topratedyears.xml
+%%SLIMDIR%%/Plugins/TrackStat/Plugin.pm
+%%SLIMDIR%%/Plugins/TrackStat/README.txt
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbcreate.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_added.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_history.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_musicbrainz.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type.sql
+%%SLIMDIR%%/Plugins/TrackStat/SQL/mysql/dbupgrade_url_type255.sql
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/All.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/Base.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/FirstPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/LastAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/LastPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/LeastPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/LeastPlayedRecentAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/MostPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/MostPlayedRecent.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/MostPlayedRecentAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotCompletelyRated.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotCompletelyRatedRecent.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotCompletelyRatedRecentAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotRated.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotRatedRecent.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/NotRatedRecentAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/PartlyPlayed.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/SpecificRating.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/TopRated.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/TopRatedRecent.pm
+%%SLIMDIR%%/Plugins/TrackStat/Statistics/TopRatedRecentAdded.pm
+%%SLIMDIR%%/Plugins/TrackStat/Storage.pm
+%%SLIMDIR%%/Plugins/TrackStat/Template/Reader.pm
+%%SLIMDIR%%/Plugins/TrackStat/Time/Stopwatch.pm
+%%SLIMDIR%%/Plugins/TrackStat/TrackStatiTunesUpdateWin.pl
+%%SLIMDIR%%/Plugins/TrackStat/iTunes/Export.pm
+%%SLIMDIR%%/Plugins/TrackStat/iTunes/Import.pm
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/iTunes
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Time
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Template
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Statistics
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL/mysql
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/SQL
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/PlaylistTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/MusicMagic
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Mixes
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Menus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/MenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Nokia770
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Fishbone
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins/TrackStat
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/plugins
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html/images
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default/html
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML/Default
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/HTML
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueryTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/DataQueries
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenus
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/ContextMenuTemplates
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Backup
+@dirrm %%SLIMDIR%%/Plugins/TrackStat/Amarok
+@dirrm %%SLIMDIR%%/Plugins/TrackStat