aboutsummaryrefslogtreecommitdiff
path: root/audio/snowstar/Makefile
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2003-01-19 23:03:47 +0000
committerBill Fenner <fenner@FreeBSD.org>2003-01-19 23:03:47 +0000
commit514ef6190f54635bebfdb085a229270d6ccbc69a (patch)
treeee4c4882b1707b97bc8507fab70d5b8c32799ae0 /audio/snowstar/Makefile
parent3b85e78755e0223254e72db7af815416900c7d2a (diff)
downloadports-514ef6190f54635bebfdb085a229270d6ccbc69a.tar.gz
ports-514ef6190f54635bebfdb085a229270d6ccbc69a.zip
Notes
Diffstat (limited to 'audio/snowstar/Makefile')
-rw-r--r--audio/snowstar/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/snowstar/Makefile b/audio/snowstar/Makefile
index a4d998c6ea3a..012c112ddfee 100644
--- a/audio/snowstar/Makefile
+++ b/audio/snowstar/Makefile
@@ -17,13 +17,15 @@ RUN_DEPENDS= rio:${PORTSDIR}/audio/rio \
NO_BUILD= true
NO_WRKSUBDIR= true
+USE_REINPLACE= true
DOC_FILES= CHANGES TODO README_Snowstar LICENSE
# somehow snowstar.tcl managed to get loaded with ^M's.
post-patch:
- @${PERL} -pi -e "s|\r\n|\n|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/snowstar.tcl
+ @${CP} ${WRKSRC}/snowstar.tcl ${WRKSRC}/snowstar.tcl.bak
+ @${TR} -d '\r' < ${WRKSRC}/snowstar.tcl.bak | \
+ sed -e "s|%%LOCALBASE%%|${LOCALBASE}|g" > ${WRKSRC}/snowstar.tcl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/snowstar.tcl ${PREFIX}/bin/snowstar