aboutsummaryrefslogtreecommitdiff
path: root/audio/solfege/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-08 20:07:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-08 20:07:25 +0000
commit3ea1527f5402e8168d017073d84fc67f753d9411 (patch)
tree023d228007fed0f2779234b1d60672319d8dcd64 /audio/solfege/Makefile
parentd2a913f0cc1446f5763d435ece68cf328471212e (diff)
Notes
Diffstat (limited to 'audio/solfege/Makefile')
-rw-r--r--audio/solfege/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/audio/solfege/Makefile b/audio/solfege/Makefile
index 6b12e93f4611..8eeea45e8d11 100644
--- a/audio/solfege/Makefile
+++ b/audio/solfege/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= solfege
-PORTVERSION= 2.2.1
+PORTVERSION= 2.4.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,22 +26,27 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
CONFIGURE_ARGS= --disable-oss-sound
-PLIST_SUB= VERSION=${PORTVERSION}
MAN1= lessonfile_editor.1 solfege.1
post-patch:
- @${GREP} -lR "/usr/bin/python2.2" ${WRKSRC} | ${XARGS} \
- ${REINPLACE_CMD} -e 's|/usr/bin/python2.2|${SETENV} python|g'
- @${REINPLACE_CMD} -e 's|type=sequencer-device|type=fake-synth| g; \
- s|/usr/bin|${LOCALBASE}/bin|g' ${WRKSRC}/default.config
- @${REINPLACE_CMD} -e 's|share/solfege|share/gnome/solfege|g' \
- ${WRKSRC}/run-solfege.py.in
- @${REINPLACE_CMD} -e 's|(datadir)/locale|(prefix)/share/locale|g' \
- ${WRKSRC}/po/Makefile
+ @${GREP} -lR "/usr/bin/python" ${WRKSRC} | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|/usr/bin/python|${SETENV} python|g'
+.for file in lessonfile_editor.py.in run-solfege.py.in
@${REINPLACE_CMD} -e 's|share", "solfege|share", "gnome", "solfege|g' \
- ${WRKSRC}/src/configureoutput.py.in
+ ${WRKSRC}/${file}
+.endfor
+.for file in src/inputwidgets.py src/runtime.py
@${REINPLACE_CMD} -e 's|gnome.canvas|gnomecanvas|g' \
- ${WRKSRC}/src/inputwidgets.py
+ ${WRKSRC}/${file}
+.endfor
+.for file in default.config
+ @${REINPLACE_CMD} -e 's|type=sequencer-device|type=fake-synth|g ; \
+ s|/usr/bin|${LOCALBASE}/bin|g' ${WRKSRC}/${file}
+.endfor
+.for file in po/Makefile
+ @${REINPLACE_CMD} -e 's|(datadir)/locale|(prefix)/share/locale|g' \
+ ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>