aboutsummaryrefslogtreecommitdiff
path: root/audio/sonata/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-08-06 13:37:23 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-08-06 13:37:23 +0000
commita6a495595badfeeb7434c9ce5dafee308950bd7c (patch)
treeb70196b39ae392c210765a807aded40f543a8d91 /audio/sonata/Makefile
parent4945852ccbe2388fbc4aede11f52ddcb359f5b3c (diff)
downloadports-a6a495595badfeeb7434c9ce5dafee308950bd7c.tar.gz
ports-a6a495595badfeeb7434c9ce5dafee308950bd7c.zip
Notes
Diffstat (limited to 'audio/sonata/Makefile')
-rw-r--r--audio/sonata/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/audio/sonata/Makefile b/audio/sonata/Makefile
index 5b4f8c3210cb..e7450f46e8ab 100644
--- a/audio/sonata/Makefile
+++ b/audio/sonata/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= sonata
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTVERSION= 1.2.2
+#PORTREVISION= 0
CATEGORIES= audio python
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,12 +22,15 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Sonata
-RM_OPTS= -R
-
OPTIONS= MPD "Install Music Player Daemon" on \
TAGLIB "Install support for editing metadata" off \
SOAPPY "Install support for automatic lyrics fetching" off
+REINPLACE_ARGS= -i.bak -e 's,%%DOCSDIR%%,${DOCSDIR},'
+
+post-patch:
+ ${REINPLACE_CMD} ${WRKSRC}/${PYSETUP}
+
.include <bsd.port.pre.mk>
.if defined (WITH_MPD)
@@ -42,9 +45,4 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/tagpy/__init__.py:${PORTSDIR}/audio/py-tagpy
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/SOAPpy/__init__.py:${PORTSDIR}/net/py-soappy
.endif
-.if defined (NOPORTDOCS)
-post-install:
- ${RM} ${RM_OPTS} ${DOCSDIR}
-.endif
-
.include <bsd.port.post.mk>