aboutsummaryrefslogtreecommitdiff
path: root/audio/sonata
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /audio/sonata
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'audio/sonata')
-rw-r--r--audio/sonata/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/sonata/Makefile b/audio/sonata/Makefile
index 176f4f8ffc2f..791bf12f4ced 100644
--- a/audio/sonata/Makefile
+++ b/audio/sonata/Makefile
@@ -12,9 +12,9 @@ COMMENT= Elegant music player for MPD
LICENSE= GPLv3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpd>=0.2.0:audio/py-mpd
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mpd>=0.2.0:audio/py-mpd@${FLAVOR}
-USES= gettext pkgconfig python
+USES= gettext pkgconfig python:2.7
USE_GNOME= pygtk2
USE_PYTHON= distutils autoplist
@@ -30,10 +30,11 @@ OPTIONS_SUB= yes
MANPAGES_MAKE_ENV_OFF= NO_INSTALL_MANPAGES=yes
DOCS_MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
MPD_RUN_DEPENDS+= musicpd:audio/musicpd
-MMKEYS_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}dbus>=0.82.4:devel/py-dbus
-PYGNOMEEXTRAS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gnome-extras>=2.25.3_4:x11-toolkits/py-gnome-extras
-TAGLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tagpy>=0.94.5:audio/py-tagpy
-ZSI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zsi>=2.0,1:net/py-zsi
+MMKEYS_RUN_DEPENDS=${PYTHON_PKGNAMEPREFIX}dbus>=0.82.4:devel/py-dbus@${FLAVOR}
+PYGNOMEEXTRAS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gnome-extras>=2.25.3_4:x11-toolkits/py-gnome-extras@${FLAVOR}
+PYGNOMEEXTRAS_IGNORE= Dependency py-gnome-extras gone.
+TAGLIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tagpy>=0.94.5:audio/py-tagpy@${FLAVOR}
+ZSI_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zsi>=2.0,1:net/py-zsi@${FLAVOR}
post-patch:
@${REINPLACE_CMD} -e 's,%%DOCSDIR%%,${DOCSDIR},' \