aboutsummaryrefslogtreecommitdiff
path: root/audio/sound-juicer
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /audio/sound-juicer
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Notes
Notes: svn path=/head/; revision=130972
Diffstat (limited to 'audio/sound-juicer')
-rw-r--r--audio/sound-juicer/Makefile13
-rw-r--r--audio/sound-juicer/distinfo4
-rw-r--r--audio/sound-juicer/files/patch-src::bacon-cd-selection.c15
-rw-r--r--audio/sound-juicer/files/patch-src::cd-drive.c103
-rw-r--r--audio/sound-juicer/files/patch-src::sj-genres.c13
-rw-r--r--audio/sound-juicer/files/patch-src::sj-main.c13
-rw-r--r--audio/sound-juicer/files/patch-src::sj-metadata-musicbrainz.c18
-rw-r--r--audio/sound-juicer/files/patch-src::sj-util.c76
-rw-r--r--audio/sound-juicer/pkg-plist45
9 files changed, 110 insertions, 190 deletions
diff --git a/audio/sound-juicer/Makefile b/audio/sound-juicer/Makefile
index 1c4baeb4411c..1796cc0cf6c0 100644
--- a/audio/sound-juicer/Makefile
+++ b/audio/sound-juicer/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= sound-juicer
-PORTVERSION= 0.6.0
-PORTREVISION= 2
+PORTVERSION= 2.10.0
CATEGORIES= audio gnome
-MASTER_SITES= http://www.burtonini.com/computing/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -18,14 +18,17 @@ COMMENT= Clean, mean and lean CD ripper for GNOME2
LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
gnome-media-profiles.0:${PORTSDIR}/audio/gnomemedia2
+USE_BZIP2= yes
USE_X_PREFIX= yes
-INSTALLS_OMF= yes
USE_GMAKE= yes
+INSTALLS_OMF= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui nautiluscdburner
USE_GSTREAMER= cdparanoia vorbis flac
USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --enable-ignore-missing-cd
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= sound-juicer.schemas
diff --git a/audio/sound-juicer/distinfo b/audio/sound-juicer/distinfo
index 49ba9dee4363..b235ee6b29aa 100644
--- a/audio/sound-juicer/distinfo
+++ b/audio/sound-juicer/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/sound-juicer-0.6.0.tar.gz) = bab9ac8e3f0ba66f360485aafdd379f8
-SIZE (gnome2/sound-juicer-0.6.0.tar.gz) = 597829
+MD5 (gnome2/sound-juicer-2.10.0.tar.bz2) = 2450626f15847d922e47781e3e259b83
+SIZE (gnome2/sound-juicer-2.10.0.tar.bz2) = 503090
diff --git a/audio/sound-juicer/files/patch-src::bacon-cd-selection.c b/audio/sound-juicer/files/patch-src::bacon-cd-selection.c
deleted file mode 100644
index 3bf5d559e3a5..000000000000
--- a/audio/sound-juicer/files/patch-src::bacon-cd-selection.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/bacon-cd-selection.c.orig Sun Dec 12 10:27:00 2004
-+++ src/bacon-cd-selection.c Sun Dec 12 10:27:57 2004
-@@ -179,10 +179,10 @@
- static void
- bacon_cd_selection_init (BaconCdSelection *bcs)
- {
-- bcs->priv = g_new0 (BaconCdSelectionPrivate, 1);
--
- GtkCellRenderer *cell;
- GtkListStore *store;
-+
-+ bcs->priv = g_new0 (BaconCdSelectionPrivate, 1);
-
- store = gtk_list_store_new (1, G_TYPE_STRING);
- gtk_combo_box_set_model (GTK_COMBO_BOX (bcs),
diff --git a/audio/sound-juicer/files/patch-src::cd-drive.c b/audio/sound-juicer/files/patch-src::cd-drive.c
deleted file mode 100644
index 56d594fb962f..000000000000
--- a/audio/sound-juicer/files/patch-src::cd-drive.c
+++ /dev/null
@@ -1,103 +0,0 @@
---- src/cd-drive.c.orig Sun Dec 12 01:39:32 2004
-+++ src/cd-drive.c Sun Dec 12 01:41:50 2004
-@@ -596,7 +596,49 @@
-
- #if defined(__linux__) || defined(__FreeBSD__)
-
-+#if !defined(__linux)
-+static int
-+get_device_max_read_speed (char *device)
-+{
-+ int fd;
-+ int max_speed;
-+ int read_speed, write_speed;
-+
-+ max_speed = -1;
-+
-+ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
-+ if (fd < 0) {
-+ return -1;
-+ }
-
-+ get_read_write_speed (fd, &read_speed, &write_speed);
-+ close (fd);
-+ max_speed = (int)floor (read_speed) / CD_ROM_SPEED;
-+
-+ return max_speed;
-+}
-+#endif
-+
-+static int
-+get_device_max_write_speed (char *device)
-+{
-+ int fd;
-+ int max_speed;
-+ int read_speed, write_speed;
-+
-+ max_speed = -1;
-+
-+ fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
-+ if (fd < 0) {
-+ return -1;
-+ }
-+
-+ get_read_write_speed (fd, &read_speed, &write_speed);
-+ close (fd);
-+ max_speed = (int)floor (write_speed) / CD_ROM_SPEED;
-+
-+ return max_speed;
-+}
-
- #endif /* __linux__ || __FreeBSD__ */
-
-@@ -798,50 +840,6 @@
- }
- }
- return NULL;
--}
--
--#if !defined(__linux)
--static int
--get_device_max_read_speed (char *device)
--{
-- int fd;
-- int max_speed;
-- int read_speed, write_speed;
--
-- max_speed = -1;
--
-- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
-- if (fd < 0) {
-- return -1;
-- }
--
-- get_read_write_speed (fd, &read_speed, &write_speed);
-- close (fd);
-- max_speed = (int)floor (read_speed) / CD_ROM_SPEED;
--
-- return max_speed;
--}
--#endif
--
--static int
--get_device_max_write_speed (char *device)
--{
-- int fd;
-- int max_speed;
-- int read_speed, write_speed;
--
-- max_speed = -1;
--
-- fd = open (device, O_RDWR|O_EXCL|O_NONBLOCK);
-- if (fd < 0) {
-- return -1;
-- }
--
-- get_read_write_speed (fd, &read_speed, &write_speed);
-- close (fd);
-- max_speed = (int)floor (write_speed) / CD_ROM_SPEED;
--
-- return max_speed;
- }
-
- static char *
diff --git a/audio/sound-juicer/files/patch-src::sj-genres.c b/audio/sound-juicer/files/patch-src::sj-genres.c
new file mode 100644
index 000000000000..5bbf888cbed3
--- /dev/null
+++ b/audio/sound-juicer/files/patch-src::sj-genres.c
@@ -0,0 +1,13 @@
+--- src/sj-genres.c.orig Mon Jan 17 13:22:28 2005
++++ src/sj-genres.c Mon Jan 17 13:22:34 2005
+@@ -20,9 +20,9 @@
+ * Authors: Ross Burton <ross@burtonini.com>
+ */
+
+-#include "sound-juicer.h"
+
+ #include <glib/gi18n.h>
++#include "sound-juicer.h"
+
+ #include "sj-genres.h"
+
diff --git a/audio/sound-juicer/files/patch-src::sj-main.c b/audio/sound-juicer/files/patch-src::sj-main.c
deleted file mode 100644
index 547e5c245d67..000000000000
--- a/audio/sound-juicer/files/patch-src::sj-main.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/sj-main.c.orig Tue Jun 15 19:45:05 2004
-+++ src/sj-main.c Tue Jun 15 19:46:13 2004
-@@ -535,8 +535,9 @@
- */
- void device_changed_cb (GConfClient *client, guint cnxn_id, GConfEntry *entry, gpointer user_data)
- {
-- g_assert (strcmp (entry->key, GCONF_DEVICE) == 0);
- gboolean ignore_no_media = GPOINTER_TO_INT (user_data);
-+
-+ g_assert (strcmp (entry->key, GCONF_DEVICE) == 0);
-
- if (entry->value == NULL
- || !cd_drive_exists (gconf_value_get_string (entry->value))) {
diff --git a/audio/sound-juicer/files/patch-src::sj-metadata-musicbrainz.c b/audio/sound-juicer/files/patch-src::sj-metadata-musicbrainz.c
new file mode 100644
index 000000000000..c510a48dc6f4
--- /dev/null
+++ b/audio/sound-juicer/files/patch-src::sj-metadata-musicbrainz.c
@@ -0,0 +1,18 @@
+--- src/sj-metadata-musicbrainz.c.orig Mon Jan 17 13:22:54 2005
++++ src/sj-metadata-musicbrainz.c Mon Jan 17 13:23:02 2005
+@@ -18,7 +18,6 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-#include "sound-juicer.h"
+
+ #include <string.h>
+ #include <glib-object.h>
+@@ -32,6 +31,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+
++#include "sound-juicer.h"
+ #include "sj-metadata-musicbrainz.h"
+ #include "sj-structures.h"
+ #include "sj-error.h"
diff --git a/audio/sound-juicer/files/patch-src::sj-util.c b/audio/sound-juicer/files/patch-src::sj-util.c
index feea811fcebb..b29d97bbd4f9 100644
--- a/audio/sound-juicer/files/patch-src::sj-util.c
+++ b/audio/sound-juicer/files/patch-src::sj-util.c
@@ -1,71 +1,43 @@
---- src/sj-util.c.orig Tue Jun 15 19:14:09 2004
-+++ src/sj-util.c Tue Jun 15 19:29:16 2004
-@@ -122,6 +122,9 @@
- gtk_widget_destroy (dialog);
- goto done;
- }
-+#ifdef __FreeBSD__
-+ ioctl (fd, CDIOCALLOW);
-+#endif
- result = ioctl (fd, CDROMEJECT);
- if (result == -1) {
- GtkWidget *dialog;
-@@ -151,20 +154,32 @@
- {
- int fd, status;
-
-+#if defined(__linux__)
- fd = open (device, O_RDONLY | O_NONBLOCK | O_EXCL);
+--- src/sj-util.c.orig Tue Feb 8 14:06:57 2005
++++ src/sj-util.c Tue Feb 8 14:25:03 2005
+@@ -157,6 +157,15 @@
if (fd < 0) {
return FALSE;
}
++#if defined(__FreeBSD__)
++ status = FALSE;
++
++ ioctl (fd, CDIOCCLOSE);
++
++ close (fd);
++
++ return status;
++#else
status = ioctl (fd, CDROM_DRIVE_STATUS, CDSL_CURRENT);
-+ close (fd);
if (status < 0) {
-- close (fd);
- return FALSE;
- }
+@@ -167,6 +176,7 @@
+ close (fd);
-- close (fd);
--
return status == CDS_TRAY_OPEN;
-+#elif defined(__FreeBSD__)
-+ struct ioc_toc_header h;
-+
-+ fd = open (device, O_RDONLY | O_NONBLOCK | O_EXCL);
-+ if (fd < 0) {
-+ return FALSE;
-+ }
-+
-+ status = ioctl (fd, CDIOREADTOCHEADER, &h);
-+ close (fd);
-+
-+ return status < 0;
+#endif
}
gboolean is_audio_cd (const char *device)
-@@ -191,15 +210,19 @@
- return FALSE;
+@@ -191,7 +201,7 @@
+ default:
+ return FALSE;
}
-
-+#if defined(__linux__)
- status = ioctl (fd, CDROM_DISC_STATUS, CDSL_CURRENT);
-+ close (fd);
- if (status < 0) {
-- close (fd);
+-
++/*
+ fd = open (device, O_RDONLY | O_NONBLOCK | O_EXCL);
+ if (fd <0) {
return FALSE;
- }
+@@ -206,6 +216,7 @@
+ close (fd);
-- close (fd);
--
return status == CDS_AUDIO;
-+#elif defined (__FreeBSD__)
-+ return TRUE;
-+#else
-+ return TRUE;
-+#endif
++ */
}
/* Pass NULL to use g_free */
diff --git a/audio/sound-juicer/pkg-plist b/audio/sound-juicer/pkg-plist
index af60b4f7cc77..bab1ce85bba4 100644
--- a/audio/sound-juicer/pkg-plist
+++ b/audio/sound-juicer/pkg-plist
@@ -9,6 +9,51 @@ share/gnome/omf/sound-juicer/sound-juicer-manual-C.omf
share/gnome/pixmaps/sound-juicer.png
share/gnome/sound-juicer/orange-slice.png
share/gnome/sound-juicer/sound-juicer.glade
+share/locale/ar/LC_MESSAGES/sound-juicer.mo
+share/locale/az/LC_MESSAGES/sound-juicer.mo
+share/locale/be/LC_MESSAGES/sound-juicer.mo
+share/locale/bg/LC_MESSAGES/sound-juicer.mo
+share/locale/ca/LC_MESSAGES/sound-juicer.mo
+share/locale/cs/LC_MESSAGES/sound-juicer.mo
+share/locale/da/LC_MESSAGES/sound-juicer.mo
+share/locale/de/LC_MESSAGES/sound-juicer.mo
+share/locale/el/LC_MESSAGES/sound-juicer.mo
+share/locale/en_CA/LC_MESSAGES/sound-juicer.mo
+share/locale/en_GB/LC_MESSAGES/sound-juicer.mo
+share/locale/es/LC_MESSAGES/sound-juicer.mo
+share/locale/et/LC_MESSAGES/sound-juicer.mo
+share/locale/eu/LC_MESSAGES/sound-juicer.mo
+share/locale/fi/LC_MESSAGES/sound-juicer.mo
+share/locale/fr/LC_MESSAGES/sound-juicer.mo
+share/locale/gu/LC_MESSAGES/sound-juicer.mo
+share/locale/hi/LC_MESSAGES/sound-juicer.mo
+share/locale/hr/LC_MESSAGES/sound-juicer.mo
+share/locale/hu/LC_MESSAGES/sound-juicer.mo
+share/locale/it/LC_MESSAGES/sound-juicer.mo
+share/locale/ja/LC_MESSAGES/sound-juicer.mo
+share/locale/ko/LC_MESSAGES/sound-juicer.mo
+share/locale/lt/LC_MESSAGES/sound-juicer.mo
+share/locale/mk/LC_MESSAGES/sound-juicer.mo
+share/locale/ml/LC_MESSAGES/sound-juicer.mo
+share/locale/ms/LC_MESSAGES/sound-juicer.mo
+share/locale/nb/LC_MESSAGES/sound-juicer.mo
+share/locale/ne/LC_MESSAGES/sound-juicer.mo
+share/locale/nl/LC_MESSAGES/sound-juicer.mo
+share/locale/no/LC_MESSAGES/sound-juicer.mo
+share/locale/pa/LC_MESSAGES/sound-juicer.mo
+share/locale/pl/LC_MESSAGES/sound-juicer.mo
+share/locale/pt/LC_MESSAGES/sound-juicer.mo
+share/locale/pt_BR/LC_MESSAGES/sound-juicer.mo
+share/locale/ru/LC_MESSAGES/sound-juicer.mo
+share/locale/sq/LC_MESSAGES/sound-juicer.mo
+share/locale/sr/LC_MESSAGES/sound-juicer.mo
+share/locale/sr@Latn/LC_MESSAGES/sound-juicer.mo
+share/locale/sv/LC_MESSAGES/sound-juicer.mo
+share/locale/th/LC_MESSAGES/sound-juicer.mo
+share/locale/tr/LC_MESSAGES/sound-juicer.mo
+share/locale/uk/LC_MESSAGES/sound-juicer.mo
+share/locale/zh_CN/LC_MESSAGES/sound-juicer.mo
+share/locale/zh_TW/LC_MESSAGES/sound-juicer.mo
@dirrm share/gnome/sound-juicer
@dirrm share/gnome/omf/sound-juicer
@dirrm share/gnome/help/sound-juicer/C/figures