aboutsummaryrefslogtreecommitdiff
path: root/audio/soundconverter
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-16 13:09:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-16 13:09:40 +0000
commit7690e06c8028ce45486cf23c83bd56b610a3ad76 (patch)
treea82b1a2c34af68f48111c12130a7770f4f26f7cd /audio/soundconverter
parent7549225a8a1d957655d41b6cd6cbfdfcc1644b3b (diff)
downloadports-7690e06c8028ce45486cf23c83bd56b610a3ad76.tar.gz
ports-7690e06c8028ce45486cf23c83bd56b610a3ad76.zip
Notes
Diffstat (limited to 'audio/soundconverter')
-rw-r--r--audio/soundconverter/Makefile12
-rw-r--r--audio/soundconverter/distinfo4
-rw-r--r--audio/soundconverter/pkg-plist63
3 files changed, 65 insertions, 14 deletions
diff --git a/audio/soundconverter/Makefile b/audio/soundconverter/Makefile
index 968d7c9700d1..44bc515d985e 100644
--- a/audio/soundconverter/Makefile
+++ b/audio/soundconverter/Makefile
@@ -2,31 +2,29 @@
# $FreeBSD$
PORTNAME= soundconverter
-PORTVERSION= 1.5.4
-PORTREVISION= 1
+PORTVERSION= 2.1.5
CATEGORIES= audio python
-MASTER_SITES= BERLIOS \
+MASTER_SITES= https://launchpad.net/soundconverter/trunk/2.1.5/+download/ \
http://BSDforge.com/projects/source/audio/soundconverter/
MAINTAINER= portmaster@BSDforge.com
COMMENT= Sound conversion application for the GNOME environment
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gstreamer>=0.10:${PORTSDIR}/multimedia/py-gstreamer
NO_ARCH= yes
-USES= desktop-file-utils gmake python:2 shebangfix
+USES= desktop-file-utils gmake python:2 shebangfix tar:xz
-SHEBANG_FILES= src/soundconverter.py
-python_OLD_CMD= /usr/bin/python -tt
+SHEBANG_FILES= bin/soundconverter.py
GNU_CONFIGURE= yes
USE_GNOME= intltool pygtk2 pygnome2
MAKE_ENV= MAKE=${MAKE_CMD}
INSTALLS_ICONS= yes
-OPTIONS_DEFAULT= NLS
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
diff --git a/audio/soundconverter/distinfo b/audio/soundconverter/distinfo
index 86354567c85a..2714c1f76bcf 100644
--- a/audio/soundconverter/distinfo
+++ b/audio/soundconverter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (soundconverter-1.5.4.tar.gz) = 980ba4d65c76747aa223b2913e1193a183c312c7e3b13733b636c6131938aac4
-SIZE (soundconverter-1.5.4.tar.gz) = 241383
+SHA256 (soundconverter-2.1.5.tar.xz) = cace2109b967744325e4ce8938d286b78b86f0615d4f145966f42decc7a74e06
+SIZE (soundconverter-2.1.5.tar.xz) = 195380
diff --git a/audio/soundconverter/pkg-plist b/audio/soundconverter/pkg-plist
index 9fc939273da9..a307b1a62ae6 100644
--- a/audio/soundconverter/pkg-plist
+++ b/audio/soundconverter/pkg-plist
@@ -1,8 +1,56 @@
bin/soundconverter
+lib/soundconverter/python/soundconverter/__init__.py
+lib/soundconverter/python/soundconverter/__init__.pyc
+lib/soundconverter/python/soundconverter/__init__.pyo
+lib/soundconverter/python/soundconverter/batch.py
+lib/soundconverter/python/soundconverter/batch.pyc
+lib/soundconverter/python/soundconverter/batch.pyo
+lib/soundconverter/python/soundconverter/error.py
+lib/soundconverter/python/soundconverter/error.pyc
+lib/soundconverter/python/soundconverter/error.pyo
+lib/soundconverter/python/soundconverter/fileoperations.py
+lib/soundconverter/python/soundconverter/fileoperations.pyc
+lib/soundconverter/python/soundconverter/fileoperations.pyo
+lib/soundconverter/python/soundconverter/gconfstore.py
+lib/soundconverter/python/soundconverter/gconfstore.pyc
+lib/soundconverter/python/soundconverter/gconfstore.pyo
+lib/soundconverter/python/soundconverter/gstreamer.py
+lib/soundconverter/python/soundconverter/gstreamer.pyc
+lib/soundconverter/python/soundconverter/gstreamer.pyo
+lib/soundconverter/python/soundconverter/messagearea.py
+lib/soundconverter/python/soundconverter/messagearea.pyc
+lib/soundconverter/python/soundconverter/messagearea.pyo
+lib/soundconverter/python/soundconverter/namegenerator.py
+lib/soundconverter/python/soundconverter/namegenerator.pyc
+lib/soundconverter/python/soundconverter/namegenerator.pyo
+lib/soundconverter/python/soundconverter/notify.py
+lib/soundconverter/python/soundconverter/notify.pyc
+lib/soundconverter/python/soundconverter/notify.pyo
+lib/soundconverter/python/soundconverter/queue.py
+lib/soundconverter/python/soundconverter/queue.pyc
+lib/soundconverter/python/soundconverter/queue.pyo
+lib/soundconverter/python/soundconverter/settings.py
+lib/soundconverter/python/soundconverter/settings.pyc
+lib/soundconverter/python/soundconverter/settings.pyo
+lib/soundconverter/python/soundconverter/soundfile.py
+lib/soundconverter/python/soundconverter/soundfile.pyc
+lib/soundconverter/python/soundconverter/soundfile.pyo
+lib/soundconverter/python/soundconverter/task.py
+lib/soundconverter/python/soundconverter/task.pyc
+lib/soundconverter/python/soundconverter/task.pyo
+lib/soundconverter/python/soundconverter/ui.py
+lib/soundconverter/python/soundconverter/ui.pyc
+lib/soundconverter/python/soundconverter/ui.pyo
+lib/soundconverter/python/soundconverter/utils.py
+lib/soundconverter/python/soundconverter/utils.pyc
+lib/soundconverter/python/soundconverter/utils.pyo
man/man1/soundconverter.1.gz
-%%DATADIR%%/soundconverter-logo.svg
-%%DATADIR%%/soundconverter.glade
+share/appdata/soundconverter.appdata.xml
+share/applications/soundconverter.desktop
+share/icons/hicolor/48x48/apps/soundconverter.png
+share/icons/hicolor/scalable/apps/soundconverter.svg
%%NLS%%share/locale/ar/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/bg/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/br/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/ca/LC_MESSAGES/soundconverter.mo
@@ -11,6 +59,7 @@ man/man1/soundconverter.1.gz
%%NLS%%share/locale/de/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/el/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/en_AU/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/eo/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/es/LC_MESSAGES/soundconverter.mo
@@ -19,12 +68,16 @@ man/man1/soundconverter.1.gz
%%NLS%%share/locale/fa/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/fi/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/fr/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/fr_CA/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/fr_FR/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/gl/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/he/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/hi/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/hu/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/it/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/ja/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/soundconverter.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/ml/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/ms/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/nl/LC_MESSAGES/soundconverter.mo
@@ -43,6 +96,6 @@ man/man1/soundconverter.1.gz
%%NLS%%share/locale/uk/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/vi/LC_MESSAGES/soundconverter.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/soundconverter.mo
-share/applications/soundconverter.desktop
-share/icons/hicolor/48x48/apps/soundconverter.png
-share/icons/hicolor/scalable/apps/soundconverter.svg
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/soundconverter.mo
+%%DATADIR%%/soundconverter-logo.svg
+%%DATADIR%%/soundconverter.glade